VPN Client and Windows 7 - Window won't show

Answered Question
May 6th, 2011

Bizarre issue I've now experienced on two separate PC's with VPN Client 5.00.07.0410 on 32-bit Windows 7:

Out of the blue, when the user double-clicks the Cisco VPN Client icon, the lock shows up in the system tray, and the application shows in the taskbar. You may get a glimpse of the window when you double-click the taskbar icon, or single click it and choose the application from the list. However, you are not able to actually get the window to be visible. This of course makes it impossible for the user to click the "connect" button.

I've discovered that when the icon is in the taskbar, and you hit "Enter" on the keyboard, it will connect. However I wouldn't expect a user to be able to figure this out, and so it was quite frustrating for them when this happened.

I've noticed there is a new version of the software for 64-bit users, but not for 32.

Anybody else experience this? Find a solution?

I tried uninstalling/re-installing and it made no difference.

-Chris

I have this problem too.
5 votes
Correct Answer by akirchwey about 4 years 2 weeks ago

This may be similar to an issue we experienced with VPN client 5.0.07.0290 where the window was actually off screen. Here was our resolution:

For Windows 7:

  • 1.       Hold the Alt key, press Tab key until the VPN Client window is highlighted. Release Alt.
  • 2.       Hold the Windows key and press the right arrow key once. This should bring the window back on screen.

If that doesn’t work or the user has XP, try this:

  • 1.     Alt-tab to the Cisco window
  • 2.     Press Alt+Space.
  • 3.     Press M.
  • 4.     Press any Arrow key.
  • 5.     Move the mouse. The window position should now follow the mouse cursor.
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.8 (8 ratings)
christopheradlam Mon, 06/13/2011 - 07:33

Nobody?  I have now had this problem on a 3rd machine. It cannot possibly be that rare.....

Correct Answer
akirchwey Mon, 06/13/2011 - 09:59

This may be similar to an issue we experienced with VPN client 5.0.07.0290 where the window was actually off screen. Here was our resolution:

For Windows 7:

  • 1.       Hold the Alt key, press Tab key until the VPN Client window is highlighted. Release Alt.
  • 2.       Hold the Windows key and press the right arrow key once. This should bring the window back on screen.

If that doesn’t work or the user has XP, try this:

  • 1.     Alt-tab to the Cisco window
  • 2.     Press Alt+Space.
  • 3.     Press M.
  • 4.     Press any Arrow key.
  • 5.     Move the mouse. The window position should now follow the mouse cursor.
albrto1982 Wed, 08/15/2012 - 10:55

I had same problem here. Solution works perfectly! Thanks a lot.

Oliver Drew Fri, 08/31/2012 - 05:46

I've just had the same problem running version 5.0.07.0290 on Windows 7 Professional 32-bit. The solution provided above worked - thank you!

Brian Carscadden Tue, 02/05/2013 - 11:17

Same here ... need to add this to my list of stupid Microsoft Windows problems. I like my Mac even more today.

hetalsoni Wed, 09/04/2013 - 10:56

Hello,

I have to do above steps each time, when I open up vpn client. Is there anyway to fixed this permanenetly?

Thanks

Hetal Soni

PhilReinemann Tue, 06/17/2014 - 10:59

Try this so you don't have to do it each time... it worked for XP Pro 32-bit (Dell E6410). Haven't yet encountered on W7 Pro:

Bring up Task Manager (Ctrl+Alt_Delete). Open the Applications tab. Highlight VPN Client, right-click and select Maximize. (Sometimes if the system dies (power-loss) when connected to VPN the registry remembers the minimized setting and will not un-minimize it except with this process (and maybe one yet to be determined).)

I'm currently working (20140617) on a similar issue for W7 Pro for the User Authentication window where the RSA passcode needs to be entered. Alt-Tab works but I'm trying to make it permanent. (One problem is the user has a difficult time following instructions.)

Silvia Perelli Tue, 05/12/2015 - 22:30

It worked for me in Windows 7 x32!!!

"Bring up Task Manager (Ctrl+Alt_Delete). Open the Applications tab. Highlight VPN Client, right-click and select Maximize. (Sometimes if the system dies (power-loss) when connected to VPN the registry remembers the minimized setting and will not un-minimize it except with this process (and maybe one yet to be determined).) - See more at: https://supportforums.cisco.com/discussion/11186511/vpn-client-and-windows-7-window-wont-show#sthash.I6d7QiBe.dpuf"

Thanks!

Vinay Sharma Sun, 04/26/2015 - 07:09

Hello Alexander

Thank you for sharing such a paramount information with Cisco users, very much appreciated. 5+ :-)

I have captured this critical information in a document.

https://supportforums.cisco.com/document/12486091/vpn-client-and-windows-7-window-wont-show

Regards,

Vinay Sharma,
Community Manager,
CCIE#44972

chekspeare Wed, 06/17/2015 - 08:48

Hello,

I have the same problem with my MAC OS X Yomite 10. The VPN client window does not show up so I can't click on connect. I'd appreciate your help. 

 

--Thierry

John Getzke Tue, 03/05/2013 - 09:20

You can also modify or delete the .ini which controls the startup position for the VPN GUI.

Modify the vpnclient.ini:

1. Navigate to (Win7) C:\Program Files (x86)\Cisco Systems\VPN Client

2. Highlight and right click the vpnclient.ini file

3. Select Edit

4. Modify the WindowX and Window7 properties

5. Save the .ini

6. Relaunch the Cisco VPN

hetalsoni Wed, 09/04/2013 - 10:55

Hello,

Please advise me, what value should I use for  step 4?

4. Modify the WindowX and Window7( windows Y) properties

Thanks

Hetal Soni

Brian Carscadden Wed, 09/04/2013 - 11:07

I had the same question, but fiddled with the values and came up with these. Keep in mind they will be dependent on your screen resolution - but the window should at least appear on the screen.

[GUI]

WindowWidth=660

WindowHeight=333

WindowX=138

WindowY=29

VisibleTab=0

AdvancedView=1

LogWindowWidth=450

LogWindowHeight=500

LogWindowX=250

LogWindowY=50

Frankaviglia Wed, 09/11/2013 - 03:44

Confirm the same problem and resolution.

With regards to this last one, what is the file to be changed with these parameteres?

[GUI]

WindowWidth=660

WindowHeight=333

WindowX=138

WindowY=29

VisibleTab=0

AdvancedView=1

LogWindowWidth=450

LogWindowHeight=500

LogWindowX=250

LogWindowY=50

Thanks,

Frank

s.guzzoni80 Thu, 04/16/2015 - 12:25

It is quite simple to solve:

1-go in program directory (i.e. C:\Program Files (x86)\Cisco Systems\VPN Client)

2-open file vpnclient.ini

3-look for parameter WindowX and WindowY

4- write : WindowWidth=600
WindowHeight=330
WindowX=180
WindowY=180

 

ciao

Actions

This Discussion

Related Content