9971 camera not working

Answered Question
May 19th, 2011
User Badges:

Hello Guys, i have a 9971 phone but i cannot

get the camera to work. all parameters seem fine. i activated it in system ->enterprise configuration ->cisco camera enabled.

any advice to get this working?

thanks in advance

Correct Answer by tketterman about 6 years 1 month ago

Just found this:


http://www.cisco.com/en/US/docs/voice_ip_comm/cuipph/9971_9951_8961/firmware/9_1_2/release_notes/9900_8900_912.html



There is an issue (CSCtf09186) with some 802.3af switches, which results in the Cisco Unified IP Phone 9951 and 9971 unable to negotiate for the additional power required to operate the IP phone's camera. To power the camera, set the Power Negotiation parameter of the Cisco Unified IP Phone 9951 and 9971 using the Phone Configuration window. To disable the Power Negotiation parameter access the Product Specific Configuration of Cisco Unified Communications Manager 8.5 and later releases. A device pack must be installed to add the configuration parameter to the database for Cisco Unified Communications Manager releases before 8.5. Disabling power negotiation enables the IP phone to power up the camera and to use up to 15.4 watts (the AF maximum) without the need to negotiate with the switch.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.8 (10 ratings)
Loading.
priyk Thu, 05/19/2011 - 07:17
User Badges:

Hi,


For IP Phone 9971, CUCM version should be 7.1(3a)su1 or above. Phone
firmware 9.0(2) and above supports video on this phone model.


What phone firmware version were they on? The camera is not supported on
9.0(1) and gives a ³insufficient power² message if 9.0(1) is used. Any
release from 9.0(2) afterwards supports the camera. Preferred release:
9.1(1). There is no problem using 802.3af with the camera and phone.


Regards,

Priya K

abukuru95 Thu, 05/19/2011 - 07:21
User Badges:

hi Priya,

i am running the highest firmware version for 9971 and CUCM 8.5. so this is not the issue i guess.

thanks anyway.

Mudit Mathur Thu, 05/19/2011 - 08:57
User Badges:
  • Cisco Employee,

Hi


Did you check if the video is actually working or enabled. I mean to say, did you test the video quality on the phone and checked if its working or not.


Where exactly are you making a video call, is it another 9971 video enabled ip phone or any other video enabled device ?


Is it a problem you are facing on a single phone, or all 9971 video enabled phones ?

abukuru95 Thu, 05/19/2011 - 23:38
User Badges:

Hi, it is just one phone that i am putting on the network.

I am just trying to enable the camera.

tketterman Thu, 05/19/2011 - 10:21
User Badges:

I'm having the same problem.   Recently upgraded to 8.5.1.10000-26.  Working with two 9971 SIP Phones with USB camera's.  All settings have been verified.  Enterprise Phone Configuration, Devices>Phone>Settings, Phone Settings, etc..  (Video Capabilities, Cisco Camera) All Check!!!


Active Phone Load: sip9971.9-1-1SR1


The phone(s) do not display under settings>accessories any USB Camera options.  Nada! 


The phone itself is working great!  Good Audio, etc..  No video what-so-ever! 


Any help or suggestions would be greatly appreciated. 

Correct Answer
tketterman Thu, 05/19/2011 - 13:01
User Badges:

Just found this:


http://www.cisco.com/en/US/docs/voice_ip_comm/cuipph/9971_9951_8961/firmware/9_1_2/release_notes/9900_8900_912.html



There is an issue (CSCtf09186) with some 802.3af switches, which results in the Cisco Unified IP Phone 9951 and 9971 unable to negotiate for the additional power required to operate the IP phone's camera. To power the camera, set the Power Negotiation parameter of the Cisco Unified IP Phone 9951 and 9971 using the Phone Configuration window. To disable the Power Negotiation parameter access the Product Specific Configuration of Cisco Unified Communications Manager 8.5 and later releases. A device pack must be installed to add the configuration parameter to the database for Cisco Unified Communications Manager releases before 8.5. Disabling power negotiation enables the IP phone to power up the camera and to use up to 15.4 watts (the AF maximum) without the need to negotiate with the switch.

ichehouri Thu, 05/19/2011 - 15:10
User Badges:

Hi,


are you using cisco switches or 3rd party ones. If it is non Cisco you need to disable the following under phone setting:


Cisco Discovery Protocol (CDP): Switch Port

Cisco Discovery Protocol (CDP): PC Port



regards,

Ibrahim

abukuru95 Fri, 05/20/2011 - 05:43
User Badges:

seems interesting, will try this and let you know

abukuru95 Thu, 05/19/2011 - 23:36
User Badges:

thanks GUys, i will try out a couple of things you said.

abukuru95 Fri, 05/20/2011 - 01:58
User Badges:

this is what i get when i issue a show power inline command on the switch

Fa3/0/15   auto  on           12.0  Cisco IP Phone 9971  Class 4

so power over ethernet cannot be the issue.

any ideas ??

all the camera and USB configurations are enabled.

emineibis Fri, 05/20/2011 - 04:17
User Badges:

Hello,


I have the same issue, Cisco UCM version is 8.1.5 and Cisco 9971 Phone's firmware is 9.1.1.SR1.

How do you fix the issue ,


Thanks a lot.

abukuru95 Fri, 05/20/2011 - 04:31
User Badges:

try this,


In configuration mode, apply this command

Interface  fa......

Power inline consumption 20000

This sets the switch port to offer 20 WATTS of power on this interface.

Send the output of your  cdp neighbors fa.... detail command.


I am also still testing this

tketterman Fri, 05/20/2011 - 04:50
User Badges:

I loaded the latest firmware onto CUCM:


(cmterm-9971.9-1-2.cop.sgn). 


Verify that your Cisco 9971 IP Phone has the latest firmware load. 


Active Load: sip9971.9-1-2


Verify the following device settings:


Cisco Camera* -> Enabled

Video Capabilities* -> Enabled

Power Negotiation* -> Disabled


My phone now has the Cisco Unified Video Camera listed in Accessories and is working!


Hope this helps.

emineibis Fri, 05/20/2011 - 05:41
User Badges:

Hello,

 

In my issue;

Third-party switch(Enterasys) ---- Cisco 9971 SIP Phone, --- There is not camera option in accessories


I will change these parameter on switch and CUCM >> Phones.

Thanks.

abukuru95 Fri, 05/20/2011 - 05:50
User Badges:

go to the phone configuration page and at the

last lines you have the option to disa

ble or enable power negotiation

emineibis Fri, 05/20/2011 - 06:20
User Badges:

Thank you for your quick reply.


Cisco UCM >> Device >> Phone ; I searched Cisco 9971 and I cannot see power negotiation on the CUCM side.

But on the switch , this parameter is enable by the default. I will change disable on the switch side.


I attached the related fotos.

Attachment: 
abukuru95 Fri, 05/20/2011 - 06:26
User Badges:

it is at last or second last line of phone config page.

click on the mac address of phone to access this.

power negotiation

sean_simpson Wed, 08/10/2011 - 11:13
User Badges:

Hi Folks


I suspect this power negotiation may be the reason why the camera is not working on my 9971 phones - that is it is NOT listed under the 'Accessories' menu and video-based calls to other 9971s or soft phone end-points have a blank video screen with the camera icon crossed out.


I am using a (non-Cisco) 802.3af based PoE switch so am unable to change anything power negotation or setting related on the "switch side". I really dont want to go down the power-brick route if I have a perfectly good PoE switch and the 9971+camera is proven to actually work with 802.3af based switches.


Would someone be kind enougfh to either post up an anonymised version of the relevant SEP.cnf.xml file (or at least a snippet) for a 9971 phone that has the XML tag showing power negotiation disabled - and hopefully the camera working ;-)


Thanks in advance


Sean

sean_simpson Wed, 08/10/2011 - 12:15
User Badges:

Well so close yet so far....


I decided to do a bit of trial and error experimentation and have managed now to get the camera recognised on the phone using the following XML tags in the SEP.cnf.xml file for the phone (thanks tketterman for the clues in your post above!!):


0

1


This is in addition to the setting, which I already had in the file:

1


So now the camera is recognised and appears in the "Accessories" menu and I can do things like video preview, and whilst in the settings menu, change the brightness and view area. Cool.


However I still cant get phone-to-phone video calls working - either 9971 to 9971 or 9971 to softphone end-point.


Obviously I'm still missing a key setting/XML tag somewhere in the SEP.cnf.xml file (possibly to do with video Codec or resolution settings?) so any visibility of an anonymised but "video working" version would be greatly appreciated.


Thanks


Sean

Olabisi Igbayiloye Wed, 12/19/2012 - 09:51
User Badges:

Am having the same problem here. Can someone please help me on how to disable the power negotiation.

I am using CME 8.6 and my switch is SG300 series switch.

Miguel Angel Es... Fri, 07/31/2015 - 13:38
User Badges:

HI every body,

 

 

I try this advice, with the command over the Switch Cisco 4500 over the ports where the phones 9971 are connected and function it for me, so I already have access to the menú accesories and can find the Cisco Camera Menú.

 

Thanks for your advice.

Randle Rivers Sun, 08/02/2015 - 17:59
User Badges:

I had this same problem but with about 26 phones. Was able to get it to work without making customer buy a bunch of bricks.

under the devices>phone settings:

Cisco Discovery Protocol :switch port* (Disabled)

Link Layer Discovery Protocol (LLDP-MED):switch port* (Disabled)

Power Negotiation* (Disabled)

 

After this I rebooted the phones and they work great. This will not power a sidecar though.

pfaustino1 Mon, 08/10/2015 - 14:18
User Badges:

This worked for us with Enterasys B5G124-48P2 switches. Thanks for the tip, Randle. 

 

 

Actions

This Discussion