SPA525G trouble

Answered Question
Jun 1st, 2011

Hi There,

I have a problem with my SPA 525G phone. I tried to updgrade the firmware and the phone stack after restarting. The bootting process stops at the CISCO logo and there is no way to continue. I have discussed the problem with the support team but it seams there is no cure from CISCO side.

Is there some one knows how and where the firmware can be reloaded with the correct version of firmware? We are located in Mississauga, ON.

Please contact me at pstanchev@chemipharmaceutical.com

Regards,

Pauls Stanchev

I have this problem too.
0 votes
Correct Answer by nseto about 2 years 10 months ago

Please contact the support center.  Phone number at the following link.

Sounds like this could be an RMA issue.

http://www.cisco.com/en/US/support/tsd_cisco_small_business_support_center_contacts.html

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (1 ratings)
nseto Thu, 06/02/2011 - 13:28

You can try the following steps to see if you can recover the phone.

/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-qformat:yes; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin:0in; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-fareast-font-family:"Times New Roman"; mso-fareast-theme-font:minor-fareast; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin; mso-bidi-font-family:"Times New Roman"; mso-bidi-theme-font:minor-bidi;}

1. Cold reboot the phone

2. When the animation appears

3. Press speaker key 3 times

4. User will be show a list of menu, from there

   a. User could reset the configuration

   b. Upgrade the firmware

pstanchev Fri, 06/03/2011 - 07:38

Thank you for the response.

I have tried the steps but didn't get anywhere with pressing the button. I have the CISCO logo on the screen but it does not accept any key pressings.

Do you have any other options?

pstanchev Fri, 06/03/2011 - 08:40

The problem is that this thing happened 2 weeks after the warranty end. The custommer suport suggests to buy new phone. The owner whants to replace the whole phone system.

Actions

Login or Register to take actions

This Discussion

Posted June 1, 2011 at 12:32 PM
Stats:
Replies:4 Avg. Rating:5
Views:665 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard