web authentication - login successful! Can I remove?

Unanswered Question
Jun 8th, 2011
User Badges:

Can I "turn off" the small pop out box that opens when a user authenticates to our guest wireless network?  Its the small pop out box that says "web authentication - Login successful! and has a "logout" button at the bottom. 


Thanks

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Surendra BG Wed, 06/08/2011 - 17:15
User Badges:
  • Cisco Employee,

Hi,


if we are using the Customized Web auth page, then if you go to the WLAN Edit page that is..


WLAN >> WLAN EDIT >> Security >> Layer 3 >> Check Override global config >> HERE WE SEE LOGOUT PAGE.


If we select None in the drop down, then there wont be any Logout screen.


Lemme know if this answered ur question and please dont forget to rate the useful posts!!


Regards

Surendra

lukeprimm Thu, 06/09/2011 - 06:41
User Badges:

Thanks, that appeared that it would do the trick. I made the changes to "none" but unfortunately the box still opens upon login.  Any other ideas?  Thanks

Surendra BG Thu, 06/09/2011 - 06:45
User Badges:
  • Cisco Employee,

AFAIK.. apart from this there is no way!! If its the Customized page, then we should not use the LOGOUT.html at all.. this will help you!!


lemme know if this answered ur question and please dont forget to rate the usefull posts!!


Regards

Surendra

lukeprimm Thu, 06/09/2011 - 07:00
User Badges:

my understanding is that if I choose "external" and point to my guest manager server, then I shouldnt get anything from the controller? The handoff happens and I authenticate via the external web server.  After I authenticate, I cant figure out why it then decides to throw up the "login successful" window from the controller???  Ughh.

blakekrone Thu, 05/10/2012 - 08:51
User Badges:
  • Silver, 250 points or more

Luke you will still see the popup because your external web server is not doing the authentication, the controller is. So the controller before doing the redirect is loading that popup window. External web servers are simpy a way to have the form on something other than the WLC but the form still passes the data to the WLC for authentication.

Rob Simkins Thu, 05/10/2012 - 08:31
User Badges:

I've got the same issue as lukeprimm. Using customised local webauth bundle in v7.0.116.0


The logout.html page doesn't exist, yet before the redirect you get a confirmation of successful login.  This includes the mgmt IP of the WLC as logout URL... Which we don't want.


Any bug IDs on this or removal in later versions?

Scott Fella Thu, 05/10/2012 - 09:23
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 Wireless

Rob,


Well from this post, you can disable that in 7.2.. well at least the logout page not the succefull login.


https://supportforums.cisco.com/message/3631094#3631094

Actions

This Discussion

Related Content