Timestamp on exported clip - VSM 6.3.1?

Unanswered Question
Jun 10th, 2011

Hi all,

Apologies in advance if I've missed something here, but I have a customer running VSM 6.3.1.

They want to be able to timestamp any clips they make from archives so that the recorded-time is visible whilst watching the footage. When viewing the archives via the VSM web interface, you can select the "Timestamps" checkbox and the time is displayed. However when they export a clip to their local machine (as an avi/wmv etc) the timestamp is not exported with the video.

I've connected to their system today and sure enough, this seems to be what's happening. Is there a way to timestamp these archive clips?

I've come up with a work-around for some of their cameras, for example their Axis PTZ cameras, which are able to display the time & date on screen. So I've configured them to do this and set them to sync with the NTP server and now, when clips are created from these archives, the time & date are visible. Unfortunately, they also have some static Pelco IP cameras which don't have the option to display the time & date and there's my problem.

Has anyone else found a way around this or, like I said initially, have I missed something obvious?

Thanks in advance for your help,

David

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
mcwalter Fri, 06/10/2011 - 10:16

Hi David. You have it right. If you want the time stamp to be "in the archive" then you have to enable it on the camera GUI.

I would look in to maybe upgrading the Pelco firmware. They may have added it. Is it the IP110s?

Regarding NTP, it's really fun when the times don't match. Customers love that.

Good luck.

dav1dsm1th Mon, 06/13/2011 - 02:14

Hi mcwalter,

Thanks for the clarification, it's good to know I didn't miss something simple.

The Pelco cameras are IP110s and I upgraded the firmware previously to the lastest (and still current version) I could find on the Pelco web site (v. 01.02.0006). Unfortunately there's no option for a time "overlay" onto the image with these cameras. If you browse to their IP Address, the time is displayed in text below the video window and there are no options relating to the time display.

I don't suppose anyone knows if the ability to timestamp video clips is in the development roadmap for VSM at all?

Regarding NTP and just to cover my rear from all angles...is there a way to configure the VSM server to sync with the same time server as the cameras? I don't mind configuring via the CLI if that's what it takes but my Linux knowledge is at a level where I'll need to google the commands!

Thanks,

David

adraghav Mon, 06/13/2011 - 03:23

Hi David,

Yes, you can point the VSM servers to the same NTP server as the cameras.

To configure NTP,

  1. Access the YaST Control Center window from the taskbar/ Start Menu.
  2. In the left panel of the YaST Control Center window, click Network Services, then click NTP Configuration in the right panel.
  3. Make sure that the During Boot radio button is selected.
  4. Uncheck the Configure NTP Daemon via DHCP check box
  5. Click Add. In the New Synchronization area, make sure that the Server radio button is selected, and click Next.
  6. In the NTP Server area, take these actions:
    1. In the Address field, enter the IP address or host name of your NTP server.
    2. Click Test to make sure that the server can access the NTP server.
    3. Check the Use for Initial Synchronization check box. Click OK.
      1. Click Finish.

      Regards,

      Aditya

      mcwalter Mon, 06/13/2011 - 06:11

      Hey David. Have you had any other issues with the IP100s? We had a system that was using more storage than what VSOM configured for the cams.

      What i mean is the camera bitrate was set by VSOM when the cameras were set up but in fact were transmitting at a much higher bitrate, thus taking up more storage than we planned for.

      You can see what bitrates your cameras are actually using on the VSMC page in the archives section.

      http://SERVERIP/vsmc

      Also if you do follow Aditya's advice on NTP be sure to stop the Cisco services running on that server first.

      # /etc/init.d/cisco stop

      use this command to restart them after your changes

      # /etc/init.d/cisco restart

      dav1dsm1th Wed, 06/15/2011 - 05:49

      Aditya, thanks for the NTP information.

      Mcwalter, thanks for the reminder about stopping & starting the Cisco services.

      Also mcwalter, this is the only installation where we've used IP110s. I've looked at the vsmc and it ties up with what's configured for these cameras, 1500 for Video Bitrate and 1.149Mbps recording rate. I appreciate though that we're not trying to throttle these cameras as we have sufficient storage space for the customer's required retention period. I will however make sure that I monitor this should we use these cameras again in the future. Thanks again for the heads-up.

      So, just to return to one of my earlier questions, does anyone know if the clip-export timestamp "feature" is in the development road map at Cisco?

      Thanks for all your ideas & help,

      David

      bsteiner@eyesth... Wed, 06/15/2011 - 13:16

      David,

      If you export the clip in the CVA format and embed the Review Player, the Review Player does give you the timestamp at the bottom.     

      Also, I have found a better alternative to the NTP issue to be connecting the Server to an outside NTP, and having the cameras sync to the server for NTP.  A little more setup, but ensures that the cameras and servers are always on the same time.

      dav1dsm1th Thu, 06/16/2011 - 05:56

      Hi Brian,

      Thanks for your response. I'm going to have the customer use this as a work-around. Their requirement was to timestamp avi/wmv clips that were passed to other users on site but I think this will be sufficient for now.

      Ironically, the last time they tried this export method they had an error returned but I've since found that to be due to them viewing a camera in full-screen mode when trying to do the export. Again, a little fiddly to have to change the view before exporting but it's a solution all the same.

      Thanks,

      David

      Actions

      Login or Register to take actions

      This Discussion

      Posted June 10, 2011 at 8:29 AM
      Stats:
      Replies:7 Avg. Rating:
      Views:1133 Votes:0
      Shares:0

      Related Content

      Discussions Leaderboard