native vlan switchport

Unanswered Question
Jun 15th, 2011

Hi,

i know the native vlan by default is vlan1

but what does this command do switchpoirt trunk native vlan 5

int fas0/5

swtichport mode trunk

switport trunk native vlan 5

does this mean anything connected to this port will get ip address in vlan 5 ? and what does switchport trunk native vlan 5 mean >

Thanks

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Antonio Knox Wed, 06/15/2011 - 08:34

It defines the traffic that will be untagged across the trunk.  It must match on both ends of the trunk for the trunk to come up.

Network Pro Wed, 06/15/2011 - 08:50

i have applied this config to nortel ip phones

int fa0/5

switchport mode trunk

switchport  trunk native vla 5

switchport trunk encap dot1q

the ip phones seems to get an ip address

but it doesnt seem to get ann ip address on

switcport mode trunk

switch trunk native vla1

switch trunk encap dot1q

Thanks

Network Pro Wed, 06/15/2011 - 08:52

Sorry error in config. this is the correct one

i have applied this config to nortel ip phones

int fa0/5

switchport mode trunk

switchport  trunk native vla 5

switchport trunk encap dot1q

switchport voice vlan105

the ip phones seems to get an ip address in 105 range

but it doesnt seem to get ann ip address on

switcport mode trunk

switch trunk native vla1

switch trunk encap dot1q

switchport voice vlan105

Thanks

Antonio Knox Wed, 06/15/2011 - 09:15

Do you have an ip address range configured to interface Vlan1?  If not, that is why you don't get an ip address.

Network Pro Wed, 06/15/2011 - 09:19

yes i have a vlan 1 and the same switch is acting as a dhcp server as well in the same range

Antonio Knox Wed, 06/15/2011 - 10:13

Is there any reason in particular that you are using a voice vlan to a nortel phone?  Typically, your config would look like

int fa0/5

switchport mode trunk

switchport  trunk native vla 5

switchport trunk encap dot1q

spanning-tree portfast trunk

wihout the

switchport voice vlan105

Network Pro Thu, 06/16/2011 - 00:00

yes we have daisy chained the pc to phones...so we want pc on native vlan and phones on vla 105

cadet alain Thu, 06/16/2011 - 00:11

Hi,

switchport voice vlan is used usually on access port making it a 'mini-trunk' carrying only tagged frames from the IP phone and untagged frames from PC attached  and it uses CDP to advertise the phone which VLAN it must be tagging its frames with.

It should be working only with Cisco phones, if you configured VLAN on your phones then this command here has no effect as you are already using a trunk port which by default transports all frames( tagged and untagged).

Regards.

Alain.

Network Pro Thu, 06/16/2011 - 00:30

hi,

we are using nortel phones on cisco switches..nortel phones dont use cdp hence the above config.

int fa0/1

switchport mode trunk

switcpot trunk native vlan 5

switchport voice vlan 105

the above native forces pc (untagged frames) to go through trunk and phones go through as well but as soon as they reach vlan 5 i have otpion 128 and option 191 which forces to go through vlan105 (voice dhcp) and gets an address. this works fine but it just does work on the vlan 1..dont know why?

int fas0/1

switchport mode trunk

switchport native vlan1

switchport voice vla105

any clues?

int vl 1

ip addres 172.22.1.1 255.255.255.0

int vl5

ip address 172.22.5.1 255.255.255.0

int 105

ip address 172.22.105.1 255.255.255.0

ip dhcp pool vlan1

network 172.22.1.0 255.255.255.0

domain name...

dns server...

ip dhcp pool vlan5

network 172.22.5.0 255.255.255.0

domain name...

dns server...

ip dhcp pool vlan105

network 172.22.105.0 255.255.255.0

domain name...

dns server...

also i have one more doubt ? switchport native vlan 5  means all untaged frames will go as vlan 5 on the trunk - does this get  tagged ? (bcos native vlan does not tag packets) - if it doesnt tag 5  then how does it get an ip address ?

cadet alain Thu, 06/16/2011 - 01:59

What is the relationship between a VID tag and an IP address? these are 2 unrelated concepts.

You have 2 DHCP scopes on your router/L3 switch  so you need a IP helper -address because the DHCP discovers are broadcasted and so not propagated outside your broadcast domain. So the DHCP server knows which scope it must pick an IP from to offer you.

Could you clarify your question and maybe put a diagram along with what is working and not working.

Regards.

Alain.

Network Pro Fri, 06/17/2011 - 14:01

hi,

ok the l3 switch has multple vlans and dhcp scope for each vlan all on the same layer 3 switch. multiple svi are used on this l3 switch for each vlan. we have layer 2 switches connected to it as access switches. so do i need an ip-helper address for each vlan even if it dhcp is running locally on the switch ( i thought ip helper is needed only dhcp service is running elsewhere)

this is first doubt to start with ?

Thanks

Actions

Login or Register to take actions

This Discussion

Posted June 15, 2011 at 8:32 AM
Stats:
Replies:11 Overall Rating:
Views:1210 Votes:0
Shares:0
Tags: No tags.
 

Discussions Leaderboard

Rank Username Points
1
Jon Marshall
16,516
2
Reza Sharifi
9,299
3
Giuseppe Larosa
8,202
4
Peter Paluch
7,598
5
Leo Laohoo
7,591
Rank Username Points
Jon Marshall
511
Joseph W. Doherty
110
Reza Sharifi
108
Peter Paluch
75
Bilal Nawaz
54