3750X channel-misconfig error detected

Unanswered Question
Jun 20th, 2011

HI everyone

I have two 3750Xs for stack, and i want connect a 2960 switch on this stack with port-channel.

I connect 2960 G0/1 to 3750X G1/0/24, and 2960 G0/2 to 3750X G2/0/24.

the config is that:

3750X:

interface Port-channel1

switchport trunk encapsulation dot1q

switchport mode trunk

interface GigabitEthernet1/0/24

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode on

interface GigabitEthernet2/0/24

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode on

2960:

interface Port-channel1

switchport trunk encapsulation dot1q

switchport mode trunk

interface GigabitEthernet0/1

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode on

interface GigabitEthernet0/2

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode on

after that, 3750X stack show me a error-disable message:

*Mar  1 00:04:00.266: %PM-4-ERR_DISABLE: channel-misconfig (STP) error detected on Gi1/0/24, putting Gi1/0/24 in err-disable state

*Mar  1 00:04:00.333: %PM-4-ERR_DISABLE: channel-misconfig (STP) error detected on Po1, putting Gi1/0/24 in err-disable state

*Mar  1 00:04:00.333: %PM-4-ERR_DISABLE: channel-misconfig (STP) error detected on Po1, putting Po1 in err-disable state

*Mar  1 00:04:01.281: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/24, changed state to down

*Mar  1 00:04:00.300: %PM-4-ERR_DISABLE: channel-misconfig (STP) error detected on Gi2/0/24, putting Gi2/0/24 in err-disable state (Switch-2)

*Mar  1 00:04:01.315: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet2/0/24, changed state to down

*Mar  1 00:04:01.315: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed state to down

i try to config spanning-tree etherchannel guard misconfig, but no use

finally, i have to use  "no errdisable detect cause all"

i check the cisco.com, and find a information: for this case, channel-group can use mode desirble.

but when i try to change the channel-group in 3750X stack, it shows me that: "with pagp enable, desirble mode must config in the same switch"

i try to use mode desirble mode in G1/0/23 and G1/0/24 in 3750X stack, it still can not work.

i want to know how to solve this problem? not only do "no errdisable detect cause all".

Thanks a lot


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 4.5 (2 ratings)
CSCO11151677 Tue, 06/21/2011 - 00:38

Hi

Can you please provide the STP configuration...

aslo output of

sh span root

How many vlans have you configured?

Thanks

Vignesh

ZhengWeiWei83103 Tue, 06/21/2011 - 02:23

the STP :

spanning-tree mode pvst

spanning-tree extend system-id

vlan 150-151

show spanning tree:

Switch#sh spanning-tree

VLAN0001

  Spanning tree enabled protocol ieee

  Root ID    Priority    32769

             Address     40f4.ec9d.2a00

             Cost        3

             Port        488 (Port-channel1)

             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1)

             Address     6400.f100.1e80

             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

             Aging Time  15  sec

Interface           Role Sts Cost      Prio.Nbr Type

------------------- ---- --- --------- -------- --------------------------------

Po1                 Root FWD 3         128.488  P2p

VLAN0150

  Spanning tree enabled protocol ieee

  Root ID    Priority    32918

             Address     40f4.ec9d.2a00

             Cost        3

             Port        488 (Port-channel1)

             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32918  (priority 32768 sys-id-ext 150)

             Address     6400.f100.1e80

             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

             Aging Time  15  sec

Interface           Role Sts Cost      Prio.Nbr Type

------------------- ---- --- --------- -------- --------------------------------

Po1                 Root FWD 3         128.488  P2p

VLAN0151 

  Spanning tree enabled protocol ieee

  Root ID    Priority    32919

             Address     40f4.ec9d.2a00

             Cost        3

             Port        488 (Port-channel1)

             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32919  (priority 32768 sys-id-ext 151)

             Address     6400.f100.1e80

             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

             Aging Time  15  sec

Interface           Role Sts Cost      Prio.Nbr Type

------------------- ---- --- --------- -------- --------------------------------

Po1                 Root FWD 3         128.488  P2p

Peter Paluch Tue, 06/21/2011 - 02:46

Hello,

You are using your EtherChannel without a negotiation protocol. As a result, if the opposite switch is not also configured for EtherChannel operation on the respective ports, there is a danger of a switching loop. The EtherChannel Misconfiguration Guard tries to prevent that loop from occuring by disabling all the ports bundled in the EtherChannel.

I cannot stress this enough: never, never, NEVER use the "on" mode for EtherChannels until absolutely certain you understand all the implications. The EtherChannel negotiation protocols PAgP and LACP are designed precisely to detect whether the opposite switch is configured for EtherChannel and bundle the ports only if the opposite switch has agreed to do the same.

My advice:

  1. Remove the Port-channel1 interface on both switches (no interface po1). This will delete the Port-channel interface and also shutdown all ports that were bundled under it.
  2. On the respective physical interfaces, issue the command channel-group 1 mode active. This will activate the LACP negotiation protocol.
  3. Activate the interfaces using the no shutdown command as they have been deactivated in the Step 1.

This way, you will configure both your switches to negotiate the creation of the EtherChannel, and prevent the misconfig guard from tripping.

Oh, by the way, did I say that using the "on" mode is a bad idea?

Best regards,

Peter

ZhengWeiWei83103 Tue, 06/21/2011 - 23:47

HI peter

thanks for your advice.

I know etherChannel negotiation protocols are designed precisely, so when i found the problem, i try to use "active" mode or "desirable" mode for the etherchannel. but in 3750X stack, i can not config other etherchannel mode except "on"

the 3750X stack show this infomation:

%With PAgP enabled, all ports in the Channel should belong to the same switch

Command rejected (Port-channel1, Gi1/0/24): Invalid etherchnl mode

so i change the EC port with G1/0/23 and G1/0/24 instead of G1/0/24 and G2/0/24, the EC can use "desirable" mode and other.

but for physics line redundancy, i can't connect the line to one 3750X switch with G1/0/23 and G1/0/24, so what other method i can try?

Best regards

Peter Paluch Wed, 06/22/2011 - 06:40

Hello,

In general, when EtherChannel-enabled ports are put into the errdisabled state by the EC Misconfig Guard, it is because all these ports were receiving STP BPDUs sent by the other switch. In a correctly configured EtherChannel, this is not possible because an EtherChannel is considered a single port by STP, and thus only one BPDU over the EtherChannel is sent, regardless of the number of bundled links. Receiving multiple BPDUs on ports bundled in an EtherChannel indicates that the other switch is not yet correctly configured for EtherChannel. The EC Misconfig Guard detects this and disables the links in order to prevent switching loops which could otherwise ensue.

The question is why does your EC Misconfig Guard keep tripping. The configuration seems to be okay. There is a command to disable the EC Misconfig Guard but I do not want to use it just yet.

If your switch does not support LACP (perhaps your IOS needs an upgrade or an additional license?), let's try to do it as follows:

  1. On both switches, delete the Po1 interface by the no interface po1 command. This will remove the EC configuration and shutdown the previously bundled port.
  2. Keep the physical ports shut down. Re-bundle them into EC using the channel-group 1 mode on command but keep them still shut down. Do this on both switches.
  3. Make sure that you configure the Port-channel1 with the switchport trunk encap dot1q and switchport mode trunk command so that the config of the Po1 interface is identical with the physical port configuration.
  4. Only now, activate the physical ports (no shutdown).

The primary goal behind this procedure is to keep the ports physically shutdown until absolutely all EC configuration is performed on both switches, and only then start activating them.

If the EC Misconfig Guard blocks your ports again, I would be interested in seeing the output of your show cdp neighbor output on both switches. Perhaps the wiring is not correct, and we are configuring inappropriate ports.

Best regards,

Peter

ZhengWeiWei83103 Wed, 06/22/2011 - 19:23

Hello peter

thanks for your advice.

i will try reconfig Port-channel 1 when the physical ports shutdown. and see what happens.

thanks again.

daniel.nocito Sat, 12/10/2011 - 08:59

Not sure if you got your answer but I ran into the same problem.  ECs were configured correctly on both sides but getting the misconfig error. Try disabling all physical ports and port-channels on both sides.  Then only enable the port-channel which should automatically enable the physical ports that are members of the channel group as well. 

paivazian Thu, 11/29/2012 - 11:52

Thanks Daniel! 

I had the same problem with EC's configured the same on both sides.  Disabling the Port-Channel's on both sides and then enabling them brought everything up as expected.  Must somehow re-sync the Port-Channel Interface to the physical interfaces.

ReneLazo23 Mon, 04/22/2013 - 15:18

I find for myself that if i create the the portchannel and then i add the interfaces i run into the same problem.

How i got around this problem was,  adding the command: channel-group 1 mode on (on the physical interfaces)and letting the switch created the po on its own.

hope it helps someone

theyounghobbycobby Thu, 06/06/2013 - 03:01

Hi Rene! You are spot on. I hit the issue of channel-miscong error. What i have reliaze is, is i become obssessed with deleting port-channel on interface level. For intstance

C2960G(config)#int range g0/49 - 50

C2960g(config-if)#no channel-group 1

and this never worked.

so i deleted the entire port-channel 1 in global config

e.g:

C2960G(config)# no port-channel 1

and there for did this:

C2960G(config)#int range g0/49 - 50

C2960g(config-if)#channel-group 1 mode on

this created a port-channel and it worked straight away.

Jun  6 09:45:29.705: %LINK-3-UPDOWN: Interface GigabitEthernet0/49, changed state to up

Jun  6 09:45:29.721: %LINK-3-UPDOWN: Interface GigabitEthernet0/50, changed state to up

Jun  6 09:45:31.456: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up

Jun  6 09:45:32.458: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan5, changed state to up

Jun  6 09:45:32.458: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/49, changed state to up

Jun  6 09:45:32.458: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/50, changed state to up

Jun  6 09:45:32.793: %LINK-3-UPDOWN: Interface Port-channel1, changed state to up

Jun  6 09:45:29.705: %LINK-3-UPDOWN: Interface GigabitEthernet0/49, changed state to up
Jun  6 09:45:29.721: %LINK-3-UPDOWN: Interface GigabitEthernet0/50, changed state to up

All thanks to You Rene and hope this will help others too!

Actions

Login or Register to take actions

This Discussion

Posted June 20, 2011 at 11:06 PM
Stats:
Replies:11 Avg. Rating:4.5
Views:22904 Votes:0
Shares:0
Categories: Switches
+

Related Content

 

Discussions Leaderboard

Rank Username Points
1 16,069
2 9,198
3 8,197
4 7,552
5 7,538