ICM v8.5 Upgrade Locked DLLs

Unanswered Question
Jul 8th, 2011
User Badges:

I'm trying to upgrade one of my lab ICMs from 8.0.1 to 8.5, and the upgrade fails each time complaining of a running executable.  The install log shows the following DLLs locked:


Locked file: C:\icm\bin\CampaignManagerPerf.dll

Locked file: C:\icm\bin\CTISVRPerfmonObjectDLL.dll

Locked file: C:\icm\bin\DialerPerf.dll

Locked file: C:\icm\bin\EapimPerfCounters.dll

Locked file: C:\icm\bin\ImportPerf.dll

Locked file: C:\icm\bin\LoggerPerf.dll

Locked file: C:\icm\bin\OPCPerfmonObjectDLL.dll

Locked file: C:\icm\bin\RealTimePerf.dll

Locked file: C:\icm\bin\VRUPIMPerfCounterDLL.dll


Found a similar thread here which indicated that the SNMP service was the culprit, but in my case, all efforts to start/stop/manual/disable the SNMP service have no effect on the error.  Is there any other service that can lock these DLLs?  There is no third party software on this box, and I ran an identical upgrade on it's paired server which ran flawlessly.  Attached is a screenshot of all active services on the problem host.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Amer rajai Sha'er Sat, 07/09/2011 - 03:44
User Badges:
  • Gold, 750 points or more

Hello,


I had a problem not exactly like this but similar when i tried to upgrade from ICM 8.0(1) to 8.0(3) on AgentPG , as i understand from cisco it is a defect , when you manually stop all services , there is a service never stops and it has to be manually stopped from the task manager , this service is called tomcat6 , please give it a try .


Amer

anubhati Sun, 07/10/2011 - 06:17
User Badges:
  • Cisco Employee,

Hi



As Amer mentioned there is a defect were patch manager fails to stop the following services

------

Cisco Contact Center SNMP Management

Cisco ICM Diagnostic Framework

Cisco Performance and Scalability Monitor

-----



Make sure these are stopped alos if you have any third party monitoring software on the serveres please stop those services as well.



Hope this helps


Anuj

kpstross Mon, 07/11/2011 - 14:31
User Badges:

Aside from SQL, there is no other third party software left on this system.  I have tried disabling all of the Cisco services completely, and rebooting (and killing Tomcat6 as mentioned above), and the upgrade still fails with the same error.

Amer rajai Sha'er Mon, 07/11/2011 - 14:34
User Badges:
  • Gold, 750 points or more

Hello,


Since this is lab , can you please try to upgrade to ICM 8.0.3 , is it also giving the same error or not ?


Just to be clear , the tomcat6 will run twice on the processes , when you stop all the service from the service control , you need to kill the tomcat6 then start the upgrade , give it a shot with the ICM 8.0.3 and let's see how things will go.


Amer

kpstross Tue, 07/12/2011 - 06:38
User Badges:

It's the same with 8.0.3.  All Cisco services are disabled, tomcat6 is shut down in Services and killed in Task Manager, but the installation fails with a complaint about the same locked DLLs.  The log shows everything is shutdown, so no indication of what might be causing this to hang.

kpstross Thu, 10/13/2011 - 08:31
User Badges:

It was finally determined to be VMWareService.exe that was locking the DLLs.

shirpati Fri, 10/14/2011 - 09:57
User Badges:
  • Cisco Employee,
You can also use the process explorer, to find out which process is blocking that dll, 

For your reference below the link to download 

http://technet.microsoft.com/en-us/sysinternals/bb896653.aspx


Once you install it in the menu options click find Find handle or Dll enter the dll name
and search it will show you what process is using that dll kill the process and run the
install.
Isidro Fernandez Thu, 01/17/2013 - 01:32
User Badges:

In my case, process wmiprvse.exe was locking this files (W2K8). Stopping Windows Management Instrumentation fixed the issue


Saludos!

Isidro

Oleh Doroshenko Mon, 07/22/2013 - 04:55
User Badges:

Hi all. Unlock files that show up in the install log. Finding blocking process is easy by means some unlocking utility (lockhunter.com). than stop all processes and everything will be ok.

Actions

This Discussion