Help - Voice Lab Setup - No Commn between Router Switch

Answered Question
Jul 12th, 2011

Hi Networkers !!!


I have been trying to set up a basic voice lab with 2621XM and 3524XL (WS-C3524-PWR-XL). I am not able get the switch and  router talk to each other. I am sure that this is something to do with  VLAN and Subinterface Configuration but I can't get it working. Please  find the configuration of 2621 as follows. I sincerely thank you for  your valuable time and support.

VOICE_GATEWAY#show run

Building configuration...

Current configuration : 1819 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname VOICE_GATEWAY

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

no network-clock-participate slot 1

no network-clock-participate wic 0

ip cef

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 172.16.1.1 172.16.1.10

ip dhcp excluded-address 172.16.2.1 172.16.2.10

!

ip dhcp pool VOICE

   network 172.16.1.0 255.255.255.0

   default-router 172.16.1.1

   dns-server 4.2.2.2

   option 150 ip 172.16.1.1

!

!

no ip domain lookup

ip host SW1 172.16.3.2

multilink bundle-name authenticated

!

!

!

!

vlan internal allocation policy ascending

!

!

!

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.1

encapsulation dot1Q 1 native

ip address 172.16.3.1 255.255.255.0

!

interface FastEthernet0/0.10

encapsulation dot1Q 10

ip address 172.16.1.1 255.255.255.0

!

interface Serial0/0

no ip address

shutdown

no fair-queue

!

router eigrp 109

network 172.16.0.0

auto-summary

!

!

ip http server

no ip http secure-server

!

!

!

control-plane

!

!

!

voice-port 1/0/0

!

voice-port 1/0/1

!

!

!

telephony-service

max-ephones 10

max-dn 10

ip source-address 172.16.1.1 port 2000

auto assign 1 to 5

auto assign 1 to 5 type 7940

max-conferences 4 gain -6

transfer-system full-consult

create cnf-files version-stamp Jan 01 2002 00:00:00

!

!

ephone-dn 1 dual-line

number 1001

name Jason

!

!

ephone-dn 2 dual-line

number 1002

name Jensy

!

!

ephone 1

mac-address 0017.9538.84D9

type 7940

button 1:1

!

!

!

ephone 2

mac-address 0013.C44A.7CC0

type 7940

button 2:2

!

!

!

line con 0

password cisco

login

line aux 0

line vty 0 4

password cisco

login

!

!

end

VOICE_GATEWAY#

The Switch Configuration is as follows :

SW_3524>en

SW_3524#show run

Building configuration...

Current configuration:

!

version 12.0

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname SW_3524

!

!

!

!

!

!

!

ip subnet-zero

no ip domain-lookup

ip dhcp-server 172.16.1.1

!

!

!

interface FastEthernet0/1

description UPTLINK to ROUTER

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,10,50,1002-1005

switchport mode trunk

switchport voice vlan 10

switchport priority extend cos 0

spanning-tree portfast

!

interface FastEthernet0/2

!

interface FastEthernet0/3

switchport voice vlan dot1p

spanning-tree portfast

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

switchport access vlan 50

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface VLAN1

ip address 172.16.3.2 255.255.255.0

no ip directed-broadcast

no ip route-cache

shutdown

!

interface VLAN10

no ip directed-broadcast

no ip route-cache

!

interface VLAN50

no ip directed-broadcast

no ip route-cache

shutdown

!

ip default-gateway 172.16.3.1

!

line con 0

transport input none

stopbits 1

line vty 0 4

login

line vty 5 15

login

!

end

SW_3524#

I have this problem too.
0 votes
Correct Answer by adamcrisp about 2 years 9 months ago

The problem is either ccme related or switch related. To rule out the switch, do a show mac address table and see if you can see the phone in vlan 10.

If you can't then remember that nowadays we expect the switchport voice vlan command to do do two things

1, change CDP announcements so that cisco phones pick up that they should be using that vlan and

2, enable forwarding of tagged packets in that vlan on the switchport.

You XL switch is of the ISL era so i would be tempted to change fast 0/3 to dot1q trunking

Ie

int fast 0/3

Switchport encap dot1q

Switchport mode trunk

Sw voice vlan 10 you already have

Ask the phone what ip address it has and what the call server is...

If phone appears in show mac-address table then look to the ccme router

Check tftp configuration, ping the phone etc.

Sorry about any typos - on iPhone.... Adam

Correct Answer by adamcrisp about 2 years 9 months ago

this is a really old XL switch - I reckon the 'management'  command will sort it.

Also given that fa0/1 is a trunk, vlan 1 will come up so long as it's the active management vlan

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (3 ratings)
adamcrisp Tue, 07/12/2011 - 13:19

Vlan 10's probably working, but If you want to ping between the router and switch on vlan 1 then:

1. on the router

change

"

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.1

encapsulation dot1Q 1 native

ip address 172.16.3.1 255.255.255.0

!

"

to

no interface FastEthernet0/0.1

interface FastEthernet0/0

ip address 172.16.3.1 255.255.255.0

and on the switch

conf t

int vlan 1

management

no shut

Adam

adamcrisp Tue, 07/12/2011 - 13:20

also - on the switch make sure you have vlan 10 defined in the database

from enable mode

show vlan

-  see if you have a vlan 10... if not

vlan database

vlan 10

name myvoicevlan

exit

Brian Meade Tue, 07/12/2011 - 13:40

interface VLAN1

no shutdown

Also, you must have a host in VLAN1 for the line protocol to come up.  Then try again.

Correct Answer
adamcrisp Tue, 07/12/2011 - 13:43

this is a really old XL switch - I reckon the 'management'  command will sort it.

Also given that fa0/1 is a trunk, vlan 1 will come up so long as it's the active management vlan

svictoryshanmugam Tue, 07/12/2011 - 15:05

Hi Adam, Thank you for the quick and helpful response. I did make the  management change in the switch and now the switch and router are  connected and I can ping & telnet to both of them back and forth. But when I connect the IP Phone after configuring the VLAN,  it just stays at the place -- Configuring IP....  Please take a look at  my vlan configuration. When I do the "Show vlan bri" the fa0/3 where I have connected my IP Phone is not listed in the Voice Vlan 10.  My dhcp pool configuration in the Router is the same as above in my first post.  Many Thanks

ip subnet-zero

no ip domain-lookup

ip dhcp-server 172.16.1.1

!

!

!

interface FastEthernet0/1

description UPTLINK to ROUTER

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,10,50,1002-1005

switchport mode trunk

switchport voice vlan 10

switchport priority extend cos 0

spanning-tree portfast

!

interface FastEthernet0/2

!

interface FastEthernet0/3

switchport voice vlan 10

spanning-tree portfast

!

SW_3524#show vlan bri

VLAN Name                             Status   Ports

---- -------------------------------- --------- -------------------------------

1   default                         active   Fa0/2, Fa0/3, Fa0/4, Fa0/5,

                                               Fa0/6, Fa0/8, Fa0/9, Fa0/10,

                                               Fa0/11, Fa0/12, Fa0/13, Fa0/14,

                                                Fa0/15, Fa0/16, Fa0/17, Fa0/18,

                                               Fa0/19, Fa0/20, Fa0/21, Fa0/22,

                                               Fa0/23, Fa0/24, Gi0/1, Gi0/2

10   VOICE                           active

50   DATA                             active   Fa0/7

1002 fddi-default                     active

1003 token-ring-default               active

1004 fddinet-default                 active

1005 trnet-default                   active

Correct Answer
adamcrisp Tue, 07/12/2011 - 15:26

The problem is either ccme related or switch related. To rule out the switch, do a show mac address table and see if you can see the phone in vlan 10.

If you can't then remember that nowadays we expect the switchport voice vlan command to do do two things

1, change CDP announcements so that cisco phones pick up that they should be using that vlan and

2, enable forwarding of tagged packets in that vlan on the switchport.

You XL switch is of the ISL era so i would be tempted to change fast 0/3 to dot1q trunking

Ie

int fast 0/3

Switchport encap dot1q

Switchport mode trunk

Sw voice vlan 10 you already have

Ask the phone what ip address it has and what the call server is...

If phone appears in show mac-address table then look to the ccme router

Check tftp configuration, ping the phone etc.

Sorry about any typos - on iPhone.... Adam

svictoryshanmugam Tue, 07/12/2011 - 16:02

Adam, You are the Man...Enabling dot1q on the ip phone ports has resolved the issue... I sincerely thank you for the great help !!!!

svictoryshanmugam Wed, 07/13/2011 - 12:43

Hi,

I am trying to hook up my Desktop into the switch and I did connect the desktop in fa0/7 and placed it in Access Vlan 50. The Desktop does get the IP address 172.16.2.11 from the dhcp-server 172.16.1.1 as seen below but the desktop is not pingable from the Router. I can do a ping to the router(172.16.2.1) from the desktop.  I did do a show ip dhcp binding and can see the two ip phones and one desktop having got ip address from the dhcp server. I can ping the the IP phones ip address but not the desktop ip address. Please help me. Thank You.

Ethernet adapter Local Area Connection 3:

        Connection-specific DNS Suffix  . :

        Description . . . . . . . . . . . : VIA Rhine III Fast Ethernet Adapter

        Physical Address. . . . . . . . . : 00-0C-76-69-49-8A

        Dhcp Enabled. . . . . . . . . . . : Yes

        Autoconfiguration Enabled . . . . : Yes

        IP Address. . . . . . . . . . . . : 172.16.2.11

        Subnet Mask . . . . . . . . . . . : 255.255.255.0

        Default Gateway . . . . . . . . . :

        DHCP Server . . . . . . . . . . . : 172.16.2.1

============================================

SW_3524#show mac

SW_3524#show mac-address-table

Dynamic Address Count:                 7

Secure Address Count:                  0

Static Address (User-defined) Count:   0

System Self Address Count:             51

Total MAC addresses:                   58

Maximum MAC addresses:                 8192

Non-static Address Table:

Destination Address  Address Type  VLAN  Destination Port

-------------------  ------------  ----  --------------------

000c.30c9.d3c0       Dynamic          1  FastEthernet0/1

000c.30c9.d3c0       Dynamic         10  FastEthernet0/1

000c.30c9.d3c0       Dynamic         50  FastEthernet0/1

0013.c44a.7cc0       Dynamic          1  FastEthernet0/3

0013.c44a.7cc0       Dynamic         10  FastEthernet0/3

0017.9538.84d9       Dynamic          1  FastEthernet0/5

0017.9538.84d9       Dynamic         10  FastEthernet0/5

=================================================

out put from show run in SW_3524

interface FastEthernet0/7

switchport access vlan 50

!

=================================================

VOICE_GATEWAY#show ip dhcp binding

Bindings from all pools not associated with VRF:

IP address          Client-ID/              Lease expiration        Type

                    Hardware address/

                    User name

172.16.1.11         0100.13c4.4a7c.c0       Mar 02 2002 12:01 AM    Automatic

172.16.1.12         0100.1795.3884.d9       Mar 02 2002 12:01 AM    Automatic

172.16.2.11         0100.0c76.6949.8a       Mar 02 2002 12:03 AM    Automatic

VOICE_GATEWAY#ping 172.16.2.11

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.16.2.11, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

adamcrisp Wed, 07/13/2011 - 14:02

I am sure everything is fine with the network. Most likely you have a firewall installed on your pc which is blocking the ping.

Sent from Cisco Technical Support iPhone App

svictoryshanmugam Wed, 07/13/2011 - 14:39

HI Adam, Thanks Again for coming to rescue ! That is perfectly correct. And I added the exception in Windows Firewall options to allow incoming router request for the Ethernet adpater which is connected to the switch and I am able to ping from both sides.  Should I run any routing protocols in the router to be able to reach other networks 172.16.1.0  and 172.16.3.0  from 172.16.2.0 (Data Vlan where the desktop resides).

Because I can ping the router 172.16.2.1 from the Desktop (172.16.2.11) but not 172.16.1.1 (the voice vlan network).

Thanks mate !

Actions

Login or Register to take actions

This Discussion

Posted July 12, 2011 at 1:13 PM
Stats:
Replies:11 Avg. Rating:
Views:456 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard

Rank Username Points
1 21,026
2 15,047
3 10,314
4 7,999
5 4,856
Rank Username Points
120
90
67
55
51