Cisco 1142N Radio interface gone

Unanswered Question
Aug 4th, 2011

Hi All,

I have around 20 1142Ns registered to 4402 WLC. WLC was saying:

     802.11a/n Radios     20

     802.11b/g/n Radios     19

So I compared and found the AP which had only 802.11a/n Radio. SSH-d to the AP and sh ver:

******

1 Gigabit Ethernet interface

1 802.11 Radio(s)

******

and if I try to configure the radio interface:

******

apname(config)#interface dot11Radio ?

  <0-1>  Dot11Radio interface number

apname(config)#interface dot11Radio 0?

.  :  <0-1>

apname(config)#interface dot11Radio 0 ?

% Unrecognized command

apnameconfig)#interface dot11Radio 1 ?

  <cr>

******

So as you can see dot11Radio 0 is gone. I've tried rebooting the AP with no success. I'm thinking there is a hardware failure with the radio antenna.

Has anyone experienced this kind of problem? What could be the cause?

Thanks,
Delgee

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
Nicolas Darchis Sun, 08/07/2011 - 01:27

This can happen, the 2.4Ghz radio probably died on you.

Try getting a "Show controllers" of your AP and see what it says about Dot11radio0.

You're probably heading towards an RMA anyway

Gandeleg.G Sun, 08/07/2011 - 17:56

show controller return same as config t, dot11Radio 0 has just disappeared:

lapname#sh controllers dot11Radio 0 ?

% Unrecognized command

lapname#sh controllers dot11Radio 1 ?

  |  Output modifiers

 

Gandeleg.G Thu, 08/11/2011 - 21:10

Consoled and restarted the AP:

bsnInitRcbSlot: slot 0 has NO radio

and it is saying 1 radio interface:

cisco AIR-LAP1142N-A-K9    (PowerPC405ex) processor (revision A0) with 98294K/32768K bytes of memory.

Processor board ID FTX1504EHJF

PowerPC405ex CPU at 586Mhz, revision number 0x147E

Last reset from power-on

LWAPP image version 7.0.98.0

1 Gigabit Ethernet interface

1 802.11 Radio(s)

Leo Laohoo Thu, 08/11/2011 - 23:08

Contact Cisco TAC and get the part replaced.  The 1140 should be covered under the Cisco Limited Lifetime Hardware Warranty. 

Leo Laohoo Sun, 08/07/2011 - 16:09

Right.  I've seen this before.

Try the following:

1.  Console into the AP and post the complete "sh log".

2.  Reload the AP.

I noticed that when running 7.0.98.0 firmware I get APs (1140 and 3500) suddenly loosing one of the two radios (either one).  One way for me fixing it is to reboot the AP and they should be fine.

Hope this helps.

Gandeleg.G Sun, 08/07/2011 - 19:13

I tried reloading the AP with no success. I'll try to console and   reload but its mounted and not that easy to connect. Thanks for the   replies, guys.

Leo Laohoo Sun, 08/07/2011 - 19:23

Ok.  If you can console into the AP then try the following from the WLC CLI:

config ap debug enable

config ap debug command "sh log"

Post the output

config ap debug disable

dennischolmes Fri, 08/12/2011 - 04:04

Hey Leo,

Exactly what I think he should do. Although it probably is a bad radio in the slot, I have seen power being an issue on these Marvell radios. Overloading a PoE switch to its very limits can cause one radio to not initiate and this would only be identified by looking at the output of the debugs on the AP as the controller never sees it in the slot. A quick way to verify this is to replace the AP with another 1142 in the same spot. Since it is port dependent on the switch then the new AP will exhibit the same behaviour. I have only seen this twice in 3 years.

Leo Laohoo Fri, 08/12/2011 - 18:05
Exactly what I think he should do.

Thank you for reminding me something ...

WHAT is the bootstrap version of the 1140???  I've seen Cisco release a bootstrap update for the 1140 ONLY:  12.4(23)JA1

Someone from Cisco told me that this fixes some issues with the radios (the person couldn't be more specific than that).  The new 7.0.116.0 firmware won't upgrade the bootstrap so one has to do something out of the ordinary:

1.  Convert the AP into autonomous;

2.  Copy the bootstrap into the AP;

3.  Copy the bootstrap from the AP to the bootstrap of the AP using the command "copy to bs:";

4.  Reboot;

5.  Convert to CAPWAP.

Gandeleg.G Sat, 08/13/2011 - 20:29

ROM: Bootstrap program is C1140 boot loader

BOOTLDR: C1140 Boot Loader (C1140-BOOT-M) Version 12.4(23c)JA, RELEASE SOFTWARE (fc3?

I've tried to convert it back to autonomous and then to LAP but it was giving me some error which I haven't seen before. We have around 50 of these APs and only this one is giving me this kind of errors. I'll try to convert to autonomous and try what you suggested and if it fails, gonna get it replaced.

Thanks guys!

Leo Laohoo Sat, 08/13/2011 - 21:29
I've tried to convert it back to autonomous and then to LAP

Convert it to autonomous FIRST, then upgrade the bootstrap to 12.4(23)JA1 (using the command I've posted) and then convert it back to LWAP/CAPWAP.

Looking forward to hear the result(s).

Gandeleg.G Sun, 08/14/2011 - 19:13

Converted to autonomous, upgraded bootstrap:

ROM: Bootstrap program is C1140 boot loader

BOOTLDR: C1140 Boot Loader (C1140-BOOT-M) Version 12.4(23c)JA1, RELEASE SOFTWARE (fc1)

Converted back to lightweight and the problem is still same:

APxxxx.xxxx.xxxx#sh ip int br

Interface                  IP-Address      OK? Method Status                Protocol

Dot11Radio1                unassigned      NO  unset  up                    up

GigabitEthernet0           x.x.x.x       YES DHCP   up                    up

LWAPP image version 7.0.98.0

1 Gigabit Ethernet interface

1 802.11 Radio(s)

Guess the only option left is to get it replaced under its warranty.

Gandeleg.G Sat, 08/13/2011 - 20:25

I have replaced the AP with a spare and connected it to my test environment with same results. Thanks for the suggestion but I guess PoE is not the cause here.

dennischolmes Sun, 08/14/2011 - 06:45

The test environment rules out the power as being the problem. I would suggest opening a warranty claim on the unit and replacing it. The time you have spent already exceeds the time the new AP would have taken to arrive. Kudos for trying to resolve this yourself.

Actions

Login or Register to take actions

This Discussion

Posted August 4, 2011 at 8:34 PM
Stats:
Replies:15 Avg. Rating:
Views:2027 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard