Install of CUCM 8.6.1.10000-43 on VMWare fails on installing progmeter

Unanswered Question
Aug 17th, 2011

Hi, Everyone

First time post here, and first time installing CUCM (any version).

I built a VM using a downloaded OVA template for CUCM 6.5.1.10000-43, and the install fails with a critical stop.  Once I figured out how to dump logs to the virtual serial port, and looked at the install.log, I found the following information that looks like where the install failed (these are the only LVL::Error and LVL::Critical messages in the log).

It looks like install failed to install the progmeter application component.

Does anyone know what this app does?  Any ideas on why it might have failed to install and possible workaround?

I may already have the answer to the question, as I'm attempting install on a VM running on VMWare vServer (rather than ESX/ESXi/vSphere).  It is possible that simply being on an unsupported configuration is my problem.  I'm trying to work with the equipment immediately available to me, but fully understand that I may have set myself up for failure by even attempting this.

Any help is appreciated greatly.

Regards,

Sean C

------------------------------------------

INSTALL LOG SNIPPET

------------------------------------------

08/17/2011 17:51:51 component_install|File:/opt/cisco/install/bin/component_install:743, Function: exec_progmeter(), /opt/cisco/install/bin/progmeter failed (1)|<LVL::Error>
08/17/2011 17:51:51 appmanager.sh|Internal Error, File:/usr/local/bin/base_scripts/appmanager.sh:155, Function: install(), failed to install application components|<LVL::Critical>
08/17/2011 17:51:51 post_install|File:/opt/cisco/install/bin/post_install:869, Function: install_applications(), /usr/local/bin/base_scripts/appmanager.sh -install failed (1)|<LVL::Error>
08/17/2011 17:51:51 post_install|Exiting with result 1|<LVL::Info>
08/17/2011 17:51:51 post_install|INSTALL_TYPE="Basic Install"|<LVL::Debug>
08/17/2011 17:51:51 post_install|File:/opt/cisco/install/bin/post_install:570, Function: check_for_critical_error(), check_for_critical_error, found /common/log/install/critical.log, exiting|<LVL::Error>
08/17/2011 17:51:52 post_install|(CAPTURE) Mail notification cancelled - smtp server address for email not found! [/usr/local/platform/conf/platformConfig.xml]|<LVL::Debug>
08/17/2011 17:51:52 display_screen|Arguments: "Critical Error" "The installation has encountered a unrecoverable internal error. For further assistance report the following information to your support provider.

"/opt/cisco/install/callmanager/scripts/cm_msa_post.sh install PostInstall 8.6.1.10000-43 8.6.1.10000-43 /usr/local/cm/ /usr/local/cm/ /common/log/install/capture.txt " terminated. Exceeded max time (360)

The system will now halt.


Continuing will allow you to dump diagnostic information before halting." "Continue"|<LVL::Debug>

I have this problem too.
1 vote
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
gmgarrian Thu, 08/18/2011 - 11:59

I am not sure about supported platforms nor can I make heads or tails of the log file.  But, I've you've already verified the media, I've had repeated install failures on an ESXi CUCM vm because I had an invaild NTP setting.  Giving it a legit NTP IP or just using the internal clock fixed this.

Just figured I'd throw that out there.

seanc@opentext.com Thu, 08/18/2011 - 12:31

Thanks for the input gmgarrian.  I saw another thread last night about installing on VMs and saw other people had resolved install problems using the same fix. 

I was able to successfully configured networking, including external NTP server.  I wish that's all that was a problem for me!

Thanks again,

Sean C

Justin Brenton Thu, 08/18/2011 - 14:09

Hi Sean,

Unfortunately ESXi is required for 8.5+, You can get 8.0 to work in your environment.  You will also need a Intel processor in your ESXi Server.

HTH,

Justin

www.ucintegrations.com

markj-lloyd Sun, 12/11/2011 - 14:35

Hi Sean, Justin

Getting the same issue when installing 8.6.1.20000-1 on EXSi and Intel proc

Did you end up finding a resolution for your issue Sean?

seanc@opentext.com Mon, 12/12/2011 - 05:21

I was unable to get a successful install on my original hardware, so we installed on hardware that met the spec.

Funny thing is that I copied that VM to the box where install failed and was able to run the VM.

Sent from my iPhone

vsergeyev Mon, 12/12/2011 - 23:03

Hi,

I had the same problem.

Decision: Use FLEXIBLE Network Adaper for VM  - ONLY!

For example, try to find another VM wit flexible Network adapter and clone it.

Deanomeara Thu, 01/26/2012 - 01:34

Hi,

Has anyone found a fix for this?

I am trying to run call manager 8.6.1 on the following enviroment

VMware ESXI 4.1

4GB of RAM

80 GB HDD Space

I have allocated the VM one CPU

In regards to vsergeyey reponse I have checked the network adapter and this is flexible.

I have run the OVA template firstly before mounting the image

I have tried installing numerous times.

Each and every time near the "Installing Database Component" I get the following error;

seanc@opentext.com Thu, 01/26/2012 - 06:45

I recently had problems and was able to get CUCM 8.5.1 and 8.6.2a installed by using both VMWare Workstation 7 and VMWare ESX Server 3i.

But the trick for me was to install on a machine with VTX support on the host CPU. One machine was dual core Xeon and the other was an I7 CPU.

Once I did that I could copy the vm to a machine with older processor and run successfully. I am using VMware Server 2.0. I have not tried it on ESXi 4 yet.

Client VM spec was 2 core, 3gb RAM, 80gb drive size (expanding not fixed).

Deanomeara Thu, 01/26/2012 - 06:54

Thanks Sean.

Will give this ago and report back my results.

id12001200 Tue, 07/24/2012 - 22:34

Hi all,

I've encountered the same issue as this on my own environment and resolved it with the following method by myself:

   -I've replaced the older CPU Intel Core-i7 2600S (Ivy Bridge, LGA1155, TDP65W) with the newer CPU

    Core-i7 3770S on my own hardware.

It would be happy if this information could help anyone troubleshoot it.

Regards,

Takao

Dileep NR Sat, 09/27/2014 - 02:08

Hi I faced the similar issue.

Just dont be panic, close the web page and see the progress in Vsphere console tab of the particular sub/Pub. Still you can see the call manager upgrade status bar.

The issue is because, sometimes the server web page stop responding while upgrade. Server shows the last status when it was connected to the server.

Actions

Login or Register to take actions

This Discussion

Posted August 17, 2011 at 11:42 PM
Stats:
Replies:11 Overall Rating:
Views:10316 Votes:1
Shares:0

Related Content

 
 

Discussions Leaderboard

Rank Username Points
1
rob.huffman
6,150
2
David Hailey
3,008
3
Chris Deren
2,324
4
Tommer Catlin
1,882
5
Ginger Dillon
1,756
Rank Username Points
Terry Cheema
60
Aman Soi
58
Aaron Harrison
44
rob.huffman
40
tonyperla
20