ASR9k A9K-iVRF-LIC license Question

Answered Question
Aug 23rd, 2011

Hi.

I'm having problems with the vrf license in ios-xr. I have installed the VRF license and it seems to be working. But when i commit the vrf config the following error message appears in the logbuffer;

%LICENSE-ASR9K_LICENSE-2-INFRA_VRF_NEEDED : 1 VRF(s) are configured without a valid license / license configuration A9K-iVRF-LIC in violation of the S...

Some outputs from the router;

sh license

FeatureID: A9K-iVRF-LIC (Slot based, Permanent)

  Total licenses 1

  Available for use         1

  Allocated to location     0

  Active                    0

  Store name             Permanent

  Store index               1

    Pool: Owner

      Total licenses in pool: 1

      Status: Available     1    Operational:    0

sh license log administration

#ID     :SDR     :FeatureID       :NodeID    :Time:   Log

1       :Owner   :None            :0/RSP0/CPU0:Thu May 19 14:16:07 2011:   License add successful for feature(s): "A9K-iVRF-LIC"  License command "license add disk0:/xxx.lic sdr Ow

sh license log operational

29      :Owner   :A9K-iVRF-LIC    :0/1/CPU0  :Tue Aug 23 10:52:12 2011: license_acquire: opaque_string (null), result('License Manager' detected the 'warning' condition 'No such license')

I really dont understand what the trouble is all about. Any ideas?

Regards

Andreas


I have this problem too.
0 votes
Correct Answer by xthuijs about 2 years 7 months ago

hi andreas,

in releases after 40x you need to manually assing the license to the slot.

from your output it seems that you have not assigned that lic yet, as it shows avaiable.

these are the steps:

RP/0/RSP0/CPU0:A9K-BNG#admin

Tue Aug 23 12:34:52.569 EDT

RP/0/RSP0/CPU0:A9K-BNG(admin)#conf

Tue Aug 23 12:34:53.678 EDT

RP/0/RSP0/CPU0:A9K-BNG(admin-config)#license NAME location ?

  0/0/CPU0     Fully qualified location specification

  0/1/CPU0     Fully qualified location specification

  0/RSP0/CPU0  Fully qualified location specification

  0/RSP1/CPU0  Fully qualified location specification

  WORD         Fully qualified location specification

  all          all locations

RP/0/RSP0/CPU0:A9K-BNG(admin-config)#license NAME location

Xander Thuijs, CCIE #6775

Sr. Tech Lead ASR9000

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (1 ratings)
Correct Answer
xthuijs Tue, 08/23/2011 - 09:36

hi andreas,

in releases after 40x you need to manually assing the license to the slot.

from your output it seems that you have not assigned that lic yet, as it shows avaiable.

these are the steps:

RP/0/RSP0/CPU0:A9K-BNG#admin

Tue Aug 23 12:34:52.569 EDT

RP/0/RSP0/CPU0:A9K-BNG(admin)#conf

Tue Aug 23 12:34:53.678 EDT

RP/0/RSP0/CPU0:A9K-BNG(admin-config)#license NAME location ?

  0/0/CPU0     Fully qualified location specification

  0/1/CPU0     Fully qualified location specification

  0/RSP0/CPU0  Fully qualified location specification

  0/RSP1/CPU0  Fully qualified location specification

  WORD         Fully qualified location specification

  all          all locations

RP/0/RSP0/CPU0:A9K-BNG(admin-config)#license NAME location

Xander Thuijs, CCIE #6775

Sr. Tech Lead ASR9000

Carlos A. Silva Mon, 12/10/2012 - 10:17

Hi, Xander:

I'm having trouble adding a license to a slot for VRF. After adding the license to admin-config, shouldn't it appear as 'active'. Can you please help?

Thanks in Advance!
c.

RP/0/RSP0/CPU0:R01#admin

Mon Dec 10 18:14:35.004 UTC

RP/0/RSP0/CPU0:R01(admin)#show license

Mon Dec 10 18:14:38.019 UTC

FeatureID: A9K-MOD80-AIP-SE (Slot based, Permanent) 

  Total licenses 2

  Available for use         2

  Allocated to location     0

  Active                    0

  Store name             Permanent

  Store index               1

    Pool: Owner

      Total licenses in pool: 2

      Status: Available     2    Operational:    0

RP/0/RSP0/CPU0:R01(admin)#show run

Mon Dec 10 18:14:40.970 UTC

Building configuration...

!! IOS XR Admin Configuration 4.2.3

username cisco

group root-system

secret 5 XXXX

!

end

RP/0/RSP0/CPU0:R01(admin)#conf t

Mon Dec 10 18:14:44.462 UTC

RP/0/RSP0/CPU0:CE.HTCHP.RPE01(admin-config)#license A9K-MOD80-AIP-SE location $

RP/0/RSP0/CPU0:R01(admin-config)#commit

Mon Dec 10 18:15:10.406 UTC

RP/0/RSP0/CPU0:R01(admin-config)#exit          

RP/0/RSP0/CPU0:R01(admin)#show license

Mon Dec 10 18:15:19.396 UTC

FeatureID: A9K-MOD80-AIP-SE (Slot based, Permanent) 

  Total licenses 2

  Available for use         2

  Allocated to location     0

  Active                    0

  Store name             Permanent

  Store index               1

    Pool: Owner

      Total licenses in pool: 2

      Status: Available     2    Operational:    0

RP/0/RSP0/CPU0:R01(admin)#

xthuijs Mon, 12/10/2012 - 10:23

few requirements:

1) there needs to be an interface in a vrf configured on that linecard

2) the license needs to be assigned to the slot

RP/0/RSP0/CPU0:A9K-BNG(admin-config)#license X location 0/0/CPU0

3) the right linecard needs to be present in the slot that you assign the license to. It needs to match the linecard type for the license applied.

xander

Carlos A. Silva Mon, 12/10/2012 - 10:35

All those things are correct:

RP/0/RSP0/CPU0:R01#show diag summ

Mon Dec 10 18:27:54.429 UTC

NODE module 0/RSP0/CPU0  ASR9K Route Switch Processor with 440G/slot Fabric and 12GB

NODE module 0/RSP1/CPU0  ASR9K Route Switch Processor with 440G/slot Fabric and 12GB

NODE module 0/0/CPU0  80G Modular Linecard, Service Edge Optimized

SPA 0/0/0 : ASR 9000 20-port 1GE Modular Port Adapter

NODE module 0/1/CPU0  80G Modular Linecard, Service Edge Optimized

SPA 0/1/0 : ASR 9000 20-port 1GE Modular Port Adapter

RP/0/RSP0/CPU0:R01#

RP/0/RSP0/CPU0:R01(admin)#license add disk0:FOX1643GG6U_201212091241520450.lic

Mon Dec 10 18:32:51.573 UTC

Info: License add successful for feature(s): "A9K-MOD80-AIP-SE"

License command "license add disk0:FOX1643GG6U_201212091241520450.lic sdr Owner" completed successfully.

RP/0/RSP0/CPU0:R01(admin)#conf t                                             

Mon Dec 10 18:32:57.960 UTC

RP/0/RSP0/CPU0:R01(admin-config)#commit

Mon Dec 10 18:33:00.438 UTC

No configuration changes to commit.

RP/0/RSP0/CPU0:R01(admin-config)#license A9K-MOD80-AIP-SE

RP/0/RSP0/CPU0:R01(admin-config-feat)# location 0/0/CPU0

RP/0/RSP0/CPU0:R01(admin-config-feat)#commit

Mon Dec 10 18:33:06.099 UTC

RP/0/RSP0/CPU0:R01(admin-config-feat)#exit

RP/0/RSP0/CPU0:R01(admin-config)#exit

RP/0/RSP0/CPU0:R01(admin)#exi

RP/0/RSP0/CPU0:R01#sh license

Mon Dec 10 18:33:16.104 UTC

FeatureID: A9K-MOD80-AIP-SE (Slot based, Permanent) 

  Total licenses 2

  Available for use         2

  Allocated to location     0

  Active                    0

  Store name             Permanent

  Store index               1

    Pool: Owner

      Total licenses in pool: 2

      Status: Available     2    Operational:    0

RP/0/RSP0/CPU0:R01#

Carlos A. Silva Mon, 12/10/2012 - 10:41

1) there needs to be an interface in a vrf configured on that linecard

never mind. thanks a lot!!!!

xthuijs Mon, 12/10/2012 - 10:41

I see the outputs confirming 2 and 3.

but do you have an interface on LC0 in a vrf with an addr assigned?

xander

fernandesdb Wed, 07/10/2013 - 17:56

Hello Alexander, how are you?

I'm having the same issue with the module ASR9000V, I have applied the license to all locations but It doesnt show up as operational, could you give me a hand?

RP/0/RSP0/CPU0:Jul 10 18:37:18.415 : dsc[183]: %LICENSE-ASR9K_LICENSE-2-SAT_NEEDED : 3 Satellite(s) are remotely connected without a valid license / license configuration for A9K-NVSAT5-LIC in violation of the Software Right To Use Agreement. This feature may be disabled by the system without the appropriate license. Contact Cisco to purchase the license immediately to avoid potential service interruption. 

RP/0/RSP0/CPU0:router#show license

Wed Jul 10 18:52:59.923 GMT

FeatureID: A9K-NVSAT1-LIC (Slot based, Permanent) 

  Total licenses 3

  Available for use         3

  Allocated to location     0

  Active                    0

  Store name             Permanent

  Store index               1

    Pool: Owner

      Total licenses in pool: 3

      Status: Available     3    Operational:    0

FeatureID: A9K-iVRF-LIC (Slot based, Permanent) 

  Total licenses 1

  Available for use         0

  Allocated to location     0

  Active                    1

  Store name             Permanent

  Store index               2

    Pool: Owner

      Total licenses in pool: 1

      Status: Available     0    Operational:    1

      Locations with licenses: (Active/Allocated) [SDR]

              0/0/CPU0        (1/0) [Owner]

RP/0/RSP0/CPU0:router#

RP/0/RSP0/CPU0:router(admin-config)#show run

Wed Jul 10 18:53:37.825 GMT

Building configuration...

!

license A9K-iVRF-LIC

location all

!

license A9K-NVSAT1-LIC

location 0/RSP0/CPU0

location 0/RSP1/CPU0

location 0/0/CPU0

location 0/1/CPU0

!

end

RP/0/RSP0/CPU0:router(admin-config)#

Thanks in advance.

Renato Reis

xthuijs Thu, 07/11/2013 - 08:10

Renato,

this may be a bit hard to fix via the support forums, I think it might be best to open a case with XR TAC for some dedicated assistence.

I see one lic is tied to LC0, which is good, where and how are the other satellites conected with their uplinks?

cheers!

xander

fernandesdb Thu, 07/11/2013 - 08:53

HI Alexander,

Actually the lisence that is applied to L0 is another lisence (

A9K-iVRF-LIC). The uplinks are trough a

A9K-24x10GE-TR LC.

Tks.

Renato

fernandesdb Sat, 07/13/2013 - 10:24

Hello Alexander,

Do you have any idea if the message below is due to the fact that the license is not active? I can't bundle interface from the ASR9000V.

RP/0/RSP0/CPU0:router#conf t

RP/0/RSP0/CPU0:router(config)#interface bundle-ether 60

RP/0/RSP0/CPU0:router(config-if)#exit

RP/0/RSP0/CPU0:router(config)#interface gigabitEthernet 200/0/0/21

RP/0/RSP0/CPU0:router(config-if)#bundle id 60 mode on

RP/0/RSP0/CPU0:router(config-if)#exit

RP/0/RSP0/CPU0:router(config)#interface gigabitEthernet 200/0/0/43

RP/0/RSP0/CPU0:router(config-if)#bundle id 60 mode on

RP/0/RSP0/CPU0:router(config-if)#exit

RP/0/RSP0/CPU0:router(config)#commit

Sat Jul 13 10:28:24.495 GMT

% Failed to commit one or more configuration items during a pseudo-atomic operation. All changes made have been reverted. Please issue 'show configuration failed' from this session to view the errors

RP/0/RSP0/CPU0:router(config)#show configuration failed

Sat Jul 13 10:28:32.213 GMT

!! SEMANTIC ERRORS: This configuration was rejected by

!! the system due to semantic errors. The individual

!! errors with each failed configuration command can be

!! found below.

interface GigabitEthernet200/0/0/21

bundle id 60 mode on

!!% 'CfgMgr' detected the 'fatal' condition 'This configuration has not been verified and can not be accepted by the system.'

!

interface GigabitEthernet200/0/0/43

bundle id 60 mode on

!!% 'CfgMgr' detected the 'fatal' condition 'This configuration has not been verified and can not be accepted by the system.'

!

end

Thanks in advance,

Renato

xthuijs Sat, 07/13/2013 - 10:29

fortunately, if a license is not installed or applied, the functionality is still there. the lic is not hard enforced.

what the issue might be what you're having is that we can only have bundle as link between the 9k and the sat

OR bundles on the sat interfaces (and not between host and sat).

Do you have a bundle configured as ICL ?

xander

fernandesdb Sat, 07/13/2013 - 10:44

Yes, I have 3 bundle congigured as ICL and what I'm trying to do is to configure a bundle with the satellite's interface that will connect another router. Is there any place (documentation) where I can't find that I can't do that?

thanks !

Renato

fernandesdb Sat, 07/13/2013 - 10:58

I guess I already found it, now I need to find a workaround for this.

Restrictions of the Satellite nV System

These are some of the software restrictions of the satellite nV system:

•The inter-chassis link redundancy is supported only through the static EtherChannel, and not through LACP based link bundles. Minimum and maximum link commands are not applicable when ICL is a bundle.

•If a satellite system is operating in redundant ICL mode, then you cannot configure link bundles of any form (with or without LACP) on the access ports of that same satellite switch.

•If a satellite system is operating in redundant ICL mode, then Ethernet OAM features are not supported on the access ports of that satellite.

•Multi-chassis Link Aggregation is supported if there are two independent Cisco ASR 9000 Series Routers acting as the POA (Point of Attachment), each with its own satellite switch, and the DHD (Dual Homed Device) connecting through each of the satellite switches. However, MC-LAG is not supported with a single satellite switch that connects two separate Cisco ASR 9000 Series Routers through an ICL LAG.

•The Cisco Discovery Protocol (CDP) is not supported on a bundle Inter Chassis Link (ICL) between the Cisco ASR 9000 Series Router and satellite.

•Cisco ASR 903 Router is not supported on RSP2 Route Processor due to the image size.

Link: http://www.cisco.com/en/US/docs/routers/asr9000/software/asr9k_r4.3/interfaces/configuration/guide/hc43satl.html#wpxref96483

Tks

Renato

xthuijs Sat, 07/13/2013 - 11:08

Hi Renato,

yeah cool you found the reference. This restriction will be lifted in XR 5 dot something (dunno the precise release), just fyi.

You could static pin the satellite interfaces you want to bundle to a single 10G uplink maybe? and leave the remainder that dont need to be bundled in an ICL bundle of 3?

regards

xander

fernandesdb Sat, 07/13/2013 - 11:52

Could you provide a sample of this configuration because I don't think I got your point.

Thank you !

xthuijs Sat, 07/13/2013 - 13:55

Ok, lets say you want to use ports 0-9 on your satellite to create bundles, which means they can't be part of an ICL bundle. Then do the following:

router(config)# interface TenGigabitEthernet 0/1/0/0
router(congig)# ipv4 point-to-point
router(config)# ip unnumbered Loopback 1000
router(config)# nv satellite-fabric-link satellite 100
router(config)#    remote-ports GigabitEthernet 0/0/0-9

So now we have static pinned the ports 0 to 9 to tengig 0/1/0/0, which menas we can bundle the sat ports 0-9

as normal.

Now we can take 3 other tengigs and make them a 3 member bundle:

router(config)# interface TenGigabitEthernet 0/2/0/1
router(config)# bundle id 10 mode on

Under the bundle ethernet we define the other sat ports to be linked:

router(config)# interface Bundle-Ethernet 10
router(config)# ipv4 point-to-point
router(config)# ip unnumbered Loopback 1000
router(config)# nv satellite-fabric-link satellite 200
router(config)#    remote-ports GigabitEthernet 0/0/0/10-39

fernandesdb Sat, 07/13/2013 - 14:17

I see,  that could be a solution but it also means that I'm wasting a 10-GE interface and if this interface goes down, my bundle interface will also go down, right?

Thank you

xthuijs Sat, 07/13/2013 - 14:20

Correct indeed Renato, if the Ten 0/1/0/0 goes down then you lose all those ports it serves, there is no ICL redundancy in that case.

One thing though is that I am recofnirming with our SAT development we can do bundled and non-bundled ICL as that was a restriction in XR42.1 when SAT came out. I'll let you know when I have confirmation on that.

regards

xander

xthuijs Sun, 07/14/2013 - 04:44

Hi Renato, confirmed, you can do this trick of bundled with non bundled ICL's starting XR4.3.0.

cheers

xander

fernandesdb Mon, 07/15/2013 - 06:27

Thank you Alexander for your help, I'm gonna test it today ! Do you have any ideia when Cisco will realease the IOS-XR with a fix to this problem?

[]'s

Renato

fernandesdb Tue, 07/16/2013 - 16:52

Hello Alexander,

I would like to thank you for all your help ! I tested the configuration you recommended and it worked fine.

[]'s

Renato Reis

xthuijs Tue, 07/16/2013 - 20:15

hi renato,

thanks very much for confirming, generally I dont hear when things work, so it is very awesome to hear that the trick did the trick

cheers!

xander

fernandesdb Tue, 07/23/2013 - 17:21

Hello Alexander,

It's me again ! Have you ever tested if the interfaces go down when you change the remote ports range?

thanks !

Renato

xthuijs Wed, 07/24/2013 - 05:31

Hi Renato,

yes this is expected, the ports that are (un)configured will have a state change. Example:

Start:

interface TenGigE0/2/0/0

nv

  satellite-fabric-link satellite 100

   remote-ports GigabitEthernet 0/0/0-43

Changing the range to 0-9 will down all ports 10-43.

Changing the range back to 0-43 will enable all ports 10-43 and puts them in admin down state.

regards

xander

Actions

Login or Register to take actions

This Discussion

Posted August 23, 2011 at 2:45 AM
Stats:
Replies:26 Avg. Rating:5
Views:7775 Votes:0
Shares:0
Tags: license, asr9k, ios-xr
+

Related Content

Discussions Leaderboard