OSPF load balancing on multi link NSSA

Answered Question
Aug 24th, 2011

Dear fellas I need some help on this pls

I have a CE connected to my PE via two leased lines of equal BW and costs for load balancing and sharing. OSPF is running b/w the two in area 2020 such that the two Leased lines are treated as seperate paths and neighbourship establishes on both against the ruter ID which is the Lo0 int.

The issue is that if I configure the network b/w the PE and CE as NSSA then ospf only shows one path to routes learned from each other.

If nssa command is removed then both paths are seen for the routes and traffic is load balanced.

I apologise for my ill-letracy.

Regards

Kashif

I have this problem too.
0 votes
Correct Answer by Giuseppe Larosa about 2 years 7 months ago

Hello Saeed,

when you set area type to NSSA the following happens:

node CE becomes an NSSA ASBR and generates LSA type 7 that are confined to the NSSA area ( area scope)

node PE becomes an NSSA ABR that performs LSA translation from type 7 to type 5 according to the rules described in OSPF NSSA RFC

http://www.faqs.org/rfcs/rfc3101.html

section 3

if you remove the NSSA option area 2020 becomes a standard area, CE node a standard ASBR that generates LSA type 5 diretly, PE node becomes a standard ABR and the type 5 LSA is flooded unchanged in the OSPF domain

In adddition to this using 0.0.0.0 wildcard has specific effects on the forwarding address field

http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a008009405a.shtml#topic1

you can try the following:

use network command + passive interface instead of redistribute connected

OR

change wildcard mask to 0.0.0.3 aligned to subnet mask in network commands describing p2p links CE-PE

Hope to help

Giuseppe

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (1 ratings)
boss.silva Wed, 08/24/2011 - 10:17

Hello,

Can you please post a sanitized running-configuration of your CE and PE routers?

Regards,

Bruno Silva.

saeedkhalid Thu, 08/25/2011 - 00:03

Dear here is the config:

CE

interface FastEthernet0/1/0

description ***       ***

ip address x.x.x.2 255.255.255.252

load-interval 30

!

interface FastEthernet0/1/1

description ***      ***

ip address x.x.x.6 255.255.255.252

load-interval 30

router ospf 2020

router-id x.x.x.105

log-adjacency-changes

redistribute connected metric 100 metric-type 1 subnets tag 2020

area 2020 nssa

network x.x.x.2 0.0.0.0 area 2020

network x.x.x.6 0.0.0.0 area 2020

!

ip classless

PE

interface GigabitEthernet1/0/1

no switchport

ip address x.x.x.1 255.255.255.252

!

interface GigabitEthernet1/0/2

no switchport

ip address x.x.x.5 255.255.255.252

router ospf 35457

router-id x.x.x.115

log-adjacency-changes detail

auto-cost reference-bandwidth 1000

area 0 authentication message-digest

redistribute connected metric 100 metric-type 1 subnets tag 222

area 2020 nssa default-information-originate

  network x.x.x.1 0.0.0.0 area 2020

network x.x.x.5 0.0.0.0 area 2020

Correct Answer
Giuseppe Larosa Thu, 08/25/2011 - 06:36

Hello Saeed,

when you set area type to NSSA the following happens:

node CE becomes an NSSA ASBR and generates LSA type 7 that are confined to the NSSA area ( area scope)

node PE becomes an NSSA ABR that performs LSA translation from type 7 to type 5 according to the rules described in OSPF NSSA RFC

http://www.faqs.org/rfcs/rfc3101.html

section 3

if you remove the NSSA option area 2020 becomes a standard area, CE node a standard ASBR that generates LSA type 5 diretly, PE node becomes a standard ABR and the type 5 LSA is flooded unchanged in the OSPF domain

In adddition to this using 0.0.0.0 wildcard has specific effects on the forwarding address field

http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a008009405a.shtml#topic1

you can try the following:

use network command + passive interface instead of redistribute connected

OR

change wildcard mask to 0.0.0.3 aligned to subnet mask in network commands describing p2p links CE-PE

Hope to help

Giuseppe

saeedkhalid Sun, 08/28/2011 - 03:35

Dear Gluseppe

THNX a lot for your help its now working with the network commands

The issue is that it treats the network as LSA7 when useing the redistribute command as its importing from connected or static.

The links you refered are excelent.

Actions

Login or Register to take actions

This Discussion

Posted August 24, 2011 at 5:17 AM
Stats:
Replies:4 Avg. Rating:5
Views:1280 Votes:0
Shares:0
Tags: ospf, nssa
+
Categories: Routers
+

Related Content

Discussions Leaderboard