Cannot log into RV042

Unanswered Question
Aug 29th, 2011

Hi.  I have a RV042 router (Ser#: NKS10462300, HW V3) running Firmware version v4.0.2.08-tm (Jan 14 2011 22:08:38) set up as a gateway.  Right after it boots I am able to long into its web interface but shortly after that if I try to log into it I go through a very log time out while the web page is waiting the router to respond and then eventually IE comes back and says it 'cannot display the web [age'.  Any help on this would be apriciated - Thanks, Stephen

Attachment: 
I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (1 ratings)
Sonnenberg-SKENDEIT Thu, 09/01/2011 - 05:18

I have exactly the same problem with two RV042 at two different customer sites.

Both RV042 are HW V3 with latest Firmware.

After a reboot or a change in one or both of the internet connections the router wouldn't let me log in via webinterface.

Every implemented Service (advanced routing, DHCP, DNS, NAT, a.s.o.) works fine but HTTP-administration doesn't.

Is there a bugfix planned to that issue?

Regards

Christian

spmckeon1 Thu, 09/01/2011 - 07:57

So, yesterday I upgraded my firmware to 4.04.02-tm and had the same results, could not log in after I exited my first session.  I then changed usr name and owds back to the factory settings and I have been able to log in since.  Go figure, this does not make sense...

Stephen

raszytko15 Wed, 07/11/2012 - 05:11

I'm having the same problem, so that the said Stephen has to use the default login, I will test.

André Szytko

Paolo Bevilacqua Wed, 07/11/2012 - 06:55

Wrong forum, post in "small business - routers". You can move your post using the actions panel on the right.

raszytko15 Thu, 07/12/2012 - 06:11

To me this discussion forum is "Small Business Support Community - Small Business Routers - Discussion," is right.

André Szytko

raszytko15 Fri, 08/10/2012 - 03:49

Actually, I went back to the default login and gave no error. Question how to block access to the remote management via wan leaving only via lan, not to block other remote access and SSH as TS passing through the router?

André Szytko

dondersconsulting Thu, 09/06/2012 - 12:10

You have to specifically enable remote management, so to "block" Remote Management, just disable it on the Firewall page.  This has nothing to do with other services.

raszytko15 Tue, 08/14/2012 - 03:50

Problem, a week later, even with the default login error continues, I will upgrade to new firmware that came v4.2.1.02 and see if it resolves.

André Szytko

raszytko15 Thu, 09/06/2012 - 04:58

Also updated the firmware to v4.2.1.02-20120118-RV0XX-code, and the problem continues. Interesting how we are forum Cisco and Cisco nobody speaks anything.

André Szytko

dondersconsulting Thu, 09/06/2012 - 12:12

since updating, have you reverted the router to factory defaults and then reprogrammed it?   The RV0xx models occasionally require this sort of attention.

Also, see my reply above about remote management question.

raszytko15 Thu, 09/06/2012 - 12:20

I did this procedure.

The problem was with the factory firmware, then upgrade to v4.1.1.01, and again with the update v4.2.1.02, and even leaving the factory login (admin / admin) the problem happens, either by logging wan as the lan.

André Szytko

raszytko15 Thu, 09/06/2012 - 12:22

And every time I need to access the RV042 after a while I have to turn off and on.

André Szytko

peter@zwaanvof.nl Fri, 09/07/2012 - 01:29

Thanks for the feedback guys.

Why would Remote Management affect access to the router from the LAN? Strange.

Router has been on this firmware for some time now and I only ran into this logon problem a couple of days ago.

Have been messing around with QuickVPN for some time, never got it to work properly and after the threads I found in this forum I guess I never will. I'll try to re-program the thing today although I don't consider that a lasting solution...

We were looking for a reasonably priced small business router with VPN functionality to deploy at our clients sites, considering the trouble we're having even with basic functionality I guess this is not it.

Any Cisco techs who would like to comment?

dondersconsulting Fri, 09/07/2012 - 09:12

If it makes any difference, here is my experience with RV042 and  RV082.  I standardized on them for my clients in 2005, so have been  using them for almost 8 years now.  There have been times that I have  loved them and times that I have hated them, but overall, I am still  comfortable using them.

** pertaining to the web admin login issue: you may have bad hardware - get it replaced under warranty.  I can  verify that the latest V3 firmware works reliably for RV042 and RV082  (same version).  With that said, it can be quirky.  I just had this problem with the RV082 running an earlier firmware version (4.1.somehting)  After upgrading firmware the router has been running for a week with no issue, and I just tested remote login again.  As a last resort before you RMA, use the reset button (hold for 10-15  seconds) to wipe the config and return to factory defaults, then flash  the latest firmware using IE, not Firefox.  To be safe, go into the web  management and return to factory defaults again.   As a last step  before programming, go to the VPN Client Access page and Generate a new  certificate.  This will replace the SSL certificate for the entire  device, not just QuickVPN (which we are ignoring).  Now reboot and  reprogram.

IN GENERAL:

Biggest problems: 

1) QuickVPN is a horrible tease.  You could take it on a  month-long romantic getaway in the Carribean and never get any action.   Just pretend it doesn't exist, which is easy because the other 3 VPN  options work great. 

2) RV042 hardware issues present as sporadic internet issues,  looks like problems with the ISP, but it's not.  The only true test is  to replace with new or known-working hardware and see if there is a  difference.  I keep a spare on-hand.

3) RV042 configuration can get corrupted and require resetting to  factory defaults, then reprogramming.  Not sure of cause but can happen  after firmware upgrades.  SSL certificate gets corrupted, and hard to  find if you don't know where it is - have to reset it in the QuickVPN  page (OF ALL PLACES!!!!)

4) Also, RV082 V2 firmware is  BROKEN.  There is an underlying bug that is hard to nail down but causes  internet slowness and outages.  If you have V2 hardware, get it RMA'd for a V3 unit, if you have V1 hardware, downgrade to the latest V1 firmware.

Historically, at under $300, the RV082 is the cheapest  rackmountable router I have found, especially with the 2nd WAN/DMZ port  and internal power supply.  The RV042 is easily the cheapest router of  its feature set avaliable.  I find both models to be HIGHLY reliable as  normal routers.  For the most part, they run as intended for many years  and do not require rebooting.  Right now I have about 50% of my clients  on each model.  I have 9 RV042's in service and 8 of those are still V1  hardware.  Only one is V3, and it does run noticeably faster than the  others, especially the management GUI.  I have not tried the new RV042G.

The RV042 V3 is running firmware v4.2.1.02   I have  not accessed it in about a month, and just logged into it remotely with  no issue.  I have never had any troubles with this unit.  I installed it  a couple months ago, and when I did, I reset it to defaults, upgraded  the firmware, reset to defaults again, and then programmed.

I also checked a handful of the RV042 V1 units and no  problems logging in there either, some I haven't touched since last  year.  They are running firmware 1.3.12.19-tm.   I think I tried the 1.3.13.x and had problems, can't remember.

I have had some issue with failures of the RV042 V1  hardware, but only after many years of reliable use.  The only symptoms  are internet outages that look like ISP issues, and the routers develop a  "singing" sound from an inductor coil in the power supply section of  the mainboard.  I have tried replacing the caps in this section as there  are many articles on this issue, but no luck.  At the price of these,  it's better to just get a new V3 unit and enjoy the new GUI.

Good luck!!

raszytko15 Fri, 09/07/2012 - 09:56

I even thought it might be problem on my machine, but I saw that other people have the same access problem. Whenever I reset the firmware change the settings, by the way should be a hardware design problem.

I just think that because this is a forum of CISCO, should have someone in charge of the company to give us an answer

André Szytko

peter@zwaanvof.nl Mon, 09/10/2012 - 07:46

Thanks for the tips and experiences, I followed advice and reset the RV042V3 to factory defaults, re-applied the latest  firmware, re-set again and then configured the access rules, firewall and VPN settings.

I can login the web interface for now,  only thing I've changed compared to the previous setup is that HTTPS is enabled. We'll see if it holds...

peter@zwaanvof.nl Tue, 09/11/2012 - 05:40

Nope, it doesn't...

I just finished adding some rules to the firewall and changed the alert log settings, logged off and now I can't get in.

Page keeps loading and eventually times out. Sigh..

peter@zwaanvof.nl Wed, 09/12/2012 - 00:40

Yes I did, right after the second re-set to factory settings, before configuring anything.

I've opened a call with Cisco for support.

dondersconsulting Wed, 09/12/2012 - 06:37

If you are able to discover what part of your programming is causing the issue, we'd all love to know.  I'm especially curious because I had this problem with earlier v4.0 firmware but not with the newest version. (well, not YET, anyway)

Cisco support is good, but the downside is they will want you to troubleshoot according to their checklist and you're tired of that by now.  If you do get an RMA, they are quick with turnaround.

peter@zwaanvof.nl Wed, 09/12/2012 - 07:07

You're right about the support part, she started with telling me that the firmware was not up-to-date because she failed to notice that the release date June 2012, is not the same as the code date Jan 18 2012

After pointing this out to her she changed the MTU on the WAN port. What that has to do with accessing the web interface from the LAN is beyond me...I'll let them be, they're taking the issue into the lab to see if they can reproduce it.

I'll keep the community posted on the results...

peter@zwaanvof.nl Fri, 09/21/2012 - 05:12

Cisco decided that replacing the device maybe a better option.

I've installed the new hardware today, so far so good.....

peter@zwaanvof.nl Mon, 10/01/2012 - 07:42

That didn't take long, within 2 days after replacing the hardware the problem is back, the logon screen hangs and we need to reboot the device.

We've pulled the plug on the RV042 and went back to our old hardware for now, my support contact at Cisco says they're escalating the issue. We'll see.....

dondersconsulting Mon, 10/01/2012 - 07:45

maybe you will get them to produce a worthwhile firmware update.   It looks like I now have an RV082 suffering the same fate  (same firmware).

vismarkcisco Thu, 12/20/2012 - 15:05

Here I am on Dec 20, 2012 with the SAME issue - I am surprised that it is still going on. I have RESET back to Factory and can login once then BAN login hangs.

peter@zwaanvof.nl Fri, 12/21/2012 - 00:35

For what its worth, these where the last words of Cisco support before we told them that we would not spend any more time troubleshooting their devices by capturing wireshark logs etc.;

"In the meantime we have replicated  the issue in the lab and we have wireshark capture ourside.."

That would suggest that they know for some time now there's an issue and apparently didn't escalate.

ixto.admin Tue, 08/20/2013 - 01:30

Hi all,

I had the same problem (after some uptime, i can open the login-page, input my credentials, but do not get any further).

After some testing, I found out that it must be some kind of Memory-Problem:

The amount of time after a reboot, until this behaviour occurs, depends on the amount of alterts being logged.

If you disable logging of the firewall-rules, and clear the log every day, you will be running for quite a while, without this problem.

I have opened a supportcase with cisco, and they are aware of my findings.

If this will lead to an official solution, well.....

Cheers, sean

jamessorensen Tue, 10/22/2013 - 10:00


I have been using RV042 devices for 8+ years. I recently began to experience this login problem with one of 3 I have installed at a customer site (I currently have 17 in use around the country). I moved all vpn tunnels from the problem unit to a second unit on a different T1 circuit 2 weeks ago - no problems until today. Seems the problem is following the vpn connections. 2 of the 5 tunnels stopped working as well.

The third RV042 at this site has firmware v1.3.9 dated Apr. 24th 2007 - been working flawlessly for many years. Currently running 6 VPN tunnels.

The other 2 are using v4.0.3 & v4.2.1.

Actions

Login or Register to take actions

This Discussion

Posted August 29, 2011 at 2:53 PM
Stats:
Replies:32 Avg. Rating:5
Views:4724 Votes:0
Shares:0
Tags: login, r042
+

Related Content

Discussions Leaderboard