UCCX 8.5.1 - Agent Email not sending

Unanswered Question
Sep 7th, 2011

Hi guys,

I'm working on a UCCX 8.5.1 install and I've configured agent email and am receiving emails fine. However, when I reply to emails from CAD the emails are never getting to their destination. In CSD the emails show as sent. I can telnet to the SMTP server on the SMTP port and can send an email using telnet commands fine from the UCCX server subnet so that all looks ok. The Exchange 2007 admin has assured me that the SMTP handler is configured as per the CAD install guide.

There is a firewall between the UCCX and the Exchange server and port 25 is open between them however, port 25 isn't open from the desktops to the Exchange server. From my understanding though it's the EEM service on the UCCX server that's doing the sending isn't it? I can't seem to see very much in the logs. The CAD logs seem to say the email is sent. The debug logs from the EEM service don't really seem to show a great deal from what I can make of them when the agent replies to the email.

Any thoughts?

Cheers,

Nathan

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
hoahuynh Mon, 09/12/2011 - 04:32

Hi Nathan

Can you see from the SMTP connection on the exhange that the UCCX has a connection established?

The SMTP account your using is enabled for sending mail on behalf of the alias?

Do you have the EEMjava logs from the server on debug for a quick look.

When the agents respond, the mail should be placed in a randomly generate folder on the exchange.

You can map this with the agent debugging.

Hoai

b.eman Wed, 11/02/2011 - 10:21

Were you able to resolve your issue?  I have the same problem and not able to find a solution.


Thanks,

daking2 Wed, 11/02/2011 - 13:19

Hey b.eman

Is this a new installation/configuration? Are you also running Exchange '07?

The EEM logs should actually show the EXACT error that is happening, however an easy way to figure this out is to log into the CCX email account through outlook, thunderbird, OWA, etc. and actually look at what folder that outgoing message is being sent to.

If the messages aren't actually being sent, take a look at the "Not Sendable" folder in the IMAP account and see if your messages are being moved there. If this is the case, the UCCX email account does not have rights to send with the address configured in CDA for that specific email queue.

Here is the CAD Troubleshooting guide that explains this issue. Pg 93. "

Agent e-mail responses are not sent back to customers"

http://www.cisco.com/en/US/docs/voice_ip_comm/cust_contact/contact_center/crs/express_8_5/troubleshooting/guide/cad85ccxtg-cm.pdf

Basically - you will have to run the following command on the CLI of the exchange server to give the UCCX email user proper send rights. (Again, this is only for Exchange 2007).

"Add-ADPermission -Identity -User -2 -AccessRights extendedright

-ExtendedRights "send as""

Let me know if this is the culprit. If you continue to have issues, please open up a TAC case.

b.eman Wed, 11/02/2011 - 13:29

Thanks for the reply.  This is a new install and yes you are correct the items end up in the "Not Sendable" folder.

I am running Exchange 2010 so I would guess the command is a little diffrent formated. 

"Add-ADPermission -Identity -User -2 -AccessRights extendedright

-ExtendedRights "send as""

Do you know what the 2010 format is by chance?

I tried this but still didn't work.  Set-DistributionGroup "" -GrantSendOnBehalfTo

Also will anything on exchange and or UCCX need restarted after this change is made?

Thanks!

daking2 Thu, 11/03/2011 - 12:13

Unfortunately I don't know the 2010 command. I did a quick google search and found the same syntax for 2010. What is the error message when running that command?

http://technet.microsoft.com/en-us/library/bb124403.aspx lists the example command for 2010:

Add-ADPermission -Identity "Ellen Adams" -User AaronPainter -AccessRights ExtendedRight -ExtendedRights "send as"

You might have to put the -User field in the domain\user syntax. However I'm certainly no Exchange expert.

- Dave

RickEveleigh Mon, 10/28/2013 - 02:54

The 2010 syntax in Dave's post worked for me on Exchange Server 2013.

Thanks!

Actions

Login or Register to take actions

This Discussion

Posted September 7, 2011 at 1:12 AM
Stats:
Replies:6 Avg. Rating:
Views:1523 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard