Reason 442: Failed to Enable Virtual Adapter - Windows 7 64 bit

Endorsed Question
Aug 30th, 2011

Some details about the issue.

I'm trying to connect to my client's network using VPN Client version 5.0.07.0290. The user authetication is done by providing RSA SecureID token value. After entering proper credentials, the client window gets struck at 'Securing Communication Channels...' message in status bar and reports 'Reason 442: Failed to Enable Virtual Adapter' error after few mintues. I have confirmed that this version works for other people in my team , so I'm guessing it has something to do with my system settings than the client itself.

Below are the trobleshooting tips that I have already tried.

1. Uninstall and Reinstall the client.

2. Enable WinXP SP2 compatability for ipsecdialer.exe and vpngui.exe.

3. Clicking 'Diagnose' on the Citrix Virtaul Adapter connection in Networks and Sharing centre, reports no issues.

4. Enabling Network sharing for Local Area Network and disaling Wireless Networks

I'm running Windows 7 64 bit Enterpise OS.

Appreciate any suggestions to resolve this issue.

Thanks,

PVNSKC

Update: 9/7/2011

OK, things look much better after a good vacation, always!!!

I tried to connect today by reinstalling the client after a weekend shutdown (I don't believe the cold reboot stuff, but hey, worth a try! ) and it did work. The only change I did today was to disable the Wireless Connection adapter in Networks Connections. I'm not sure whether that fixed or not cause I had tried that already. Anyway, below is my current configuration which is working for now!

1. Below executables are running in the XP compatability mode.

cvpnd.exe, VAInst64.exe, vpngui.exe

2. Local Area Connection is allowed for 'Sharing'

3.  Registry is updated with below entry.

HKLM\System\CurrentControlSet\Services\Tcpip\Parameters /v ArpRetryCount /t REG_DWORD /d 0 /f

4. Wireless Connection is disabled.

Thank you all for the responses.

PVNSKC

I have this problem too.
3 votes
Cisco Endorsed by amutreja
Margresse about 5 months 3 days ago

I had the same problem. Here's what I did to make it work:

Start-> Run-> services.msc *Enter*

Look for Internet Connection Sharing (ICS) in the list. Doubleclick.

Change startup type to Disabled.

Below Service Status, press Stop.

Then press Ok, to close dialog. Restart VPN client, and it worked again this time. Woohoo.

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (6 ratings)
Parminder Sian Wed, 08/31/2011 - 00:51

Hi,

Duplicate IP Address Triggers Error 442 on Windows 7 and Vista

The following error "Reason 442: failed to enable virtual adapter"  appears after Windows 7 and Vista reports a duplicate IP address  detected. Subsequent connections fail with same message, but the OS does  not report a duplicate IP address detected.

To work around error 442, do the following steps:

Step 1 Open "Network and Sharing Center".

Step 2 Select "Manage Network Connections".

Step 3 Enable the Virtual Adapter ("VA"—Cisco VPN Adapter).

Step 4 Right-click on Cisco VPN Adapter and select "Diagnose" from the context menu.

Step 5 Select "Reset the network adapter Local Area Connection X".

If this procedure does not work, run the following command from cmd:

reg add HKLM\System\CurrentControlSet\Services\Tcpip\Parameters /v ArpRetryCount /t REG_DWORD /d 0 /f

Then reboot.

This resolves the issue until the OS reports a duplicate IP address again. Follow the preceding steps to resolve it again.

If that doesn't work, you might have UAC enabled. If so, you must run  cmd as administrator and repeat the previous registry workaround.

NOTE: You mentioned step 4 already, try the whole sequence again, if the steps does not work then try the registry key.

Hope this helps,

Sian

Pvnskc1983 Wed, 08/31/2011 - 14:11

Parminder Sian,

Thanks for your reply.

I have re-tried the steps in the same order mentioned above, however, I don't see a option 'Reset network adpter.... ' upon clicking on Diagnose. It just returns that there were no issues found. I have also added the Registry entry mentioned above using the Admin privilages. Now, when I rebooted the machine and tried to connect again. It errors out with 'Error 56: The Cisco Systems, Inc. VPN Service has been not started. Please start this service and try again'. I see that this service is set to start Automatically but not started. So, I did start it manually. When I try to run the vpngui.exe again, the serivce is stopped and the same error is returned.

Are there any other suggestions to try out? 

Thanks,

PVNSKC

McMagnusB Thu, 09/01/2011 - 12:57

Hi

I can report exactly the same problem. I've had this problem for quite a while but as PVNSKC reports, I don't see any reset option when diagnosing he connection. Nor did the registry change work. After reboot, I still have exactly the same issue. Same version, 5.0.07.0290.

It will probably work tomorrow, and possibly after several reboots and/or powering off/on, but it's extremely persistent whenever it does happen.

Let me know if I can help with analysis.

McMagnusB Thu, 09/01/2011 - 22:42

Another thing, when I shut down (sleep or hibernate) my laptop without disconnecting the VPN connection first, the problem is more likely to occurr.

After that, it may work once or twice, but after that, it will seem to work, but there's no internet and the diagnose dialog will report that there's no DNS.

And after that, it will show the 442 problem again. And as I said before, it's extremely hard to get it working again. This morning, after having the problem last night, it's still impossible to connect. And I *really* need to get some work done today...

Support@galaxya... Tue, 09/06/2011 - 12:05

I had the same problem as you guys and followed all the same troubleshooting steps.  What fixed it for me was checking for inernet sharing on each of my connections.  I was tinkering around with sharing my blackberry's internet connection with a local router and needed to enable this to get it to work.  Of course i forgot all about it and I started having problems with my vpn.  Once I unchecked this option on the connection i created it worked first time no problem.  Give it a shot.

mijoffe Fri, 11/18/2011 - 22:48

My issue seems to pop up every time there is a windows update install. For this go around, I wound up re-installing (not fixing) the client, then going to virtual adapter-->> selecting the sharing option-->> apply-->> go back in and uncheck-->> apply-->> restart just for sport-->> launch client.

That worked last night and is still fine today.

rebekahdawson Wed, 11/07/2012 - 18:09

Hi-

I have Windows 7 running VPN Client 5.0.07.0290 on a Dell laptop. I get the Reason 442 error. I have tried all of the fixes that I can find on the internet, as listed below. I still get the error.

1. Disabled ICS (stopped VPN, disabled ICS, restarted VPN)

2. reg add HKLM\System\CurrentControlSet\Services\Tcpip\Parameters /v ArpRetryCount /t REG_DWORD /d 0 /f

3. restarted VPN network adapter

after each of these I have rebooted the computer and it still does not fix the error.

I also have made sure that the cvpnd.exe, VAInst64.exe, vpngui.exe are all in XP compatability mode (SP3 or SP2 - neither fixes it).

What else can I try?  I have another computer at home using the SAME modem, with Windows 7, and the VPN works just fine. I'm very frustrated so would appreciate any help!

Thanks!

akivadotan Wed, 01/18/2012 - 06:58

Let me add to this somewhat old thread that I was running into this exact problem with an employee's Win 7 laptop.  Like in Walter's and Michael's cases, the solution for me was to break a NIC share.  I am not sure why the wireless adapter on her laptop was shared to begin with but unchecking the Share option for the wireless NIC seems to have done the trick.

I hope that helps.

junguo Thu, 01/19/2012 - 19:00

I met the same problem, sometimes when we established a private wireless network probably enable the Internet Connection Sharing, this would cause the error "Reason 442: Failed to Enable Virtual Adapter - Windows 7 64 bit" on VPN client.

Thanks akivadotan.

ej_villagran Sat, 11/24/2012 - 04:04

Thanks, I just stop the service

internet connection sharing and then it is working.

ksilvaol Thu, 04/10/2014 - 05:39

I was having the same issue. When I unchecked the "share" option, the VPN client started working again. Thanks for the help! smiley

philippe.cousineau Fri, 06/29/2012 - 11:49

I had that problem with windows 7 32bit with cisco vpn client v 5.0.0.7...

to fix it, I just stop the service

internet connection sharing ics service

/ and remove the startup option.

then I restart my computer and it was working.

tonewtown Sat, 01/26/2013 - 18:28

When I get this error, i've noticed that the virtual adapter fails to enable.  If I manually enable the adapter and then retry the VPN connection, it always works.  I'm trying to figure out why the VPN client no longer automatically enables the connection.  You may want to try enabling the adapter manually and reconnecting.  Workaround, not a solution....yet.

Farrukh Haroon Wed, 05/22/2013 - 00:19

Guys I was having the same problem, and disabling the Internet Connection Sharing did the trick.

If the connnection you are using to go out to the Internet has ICS enabled, this problem might occur, You don't have to disable any wireless adapters, in fact right now my LAN is disconnnected and I am using wireless to go out (and this had ICS on).

Regards

Farrukh Haroon

CCIE-SEC, JNCIE-SEC

ali_syndrome Thu, 06/20/2013 - 12:02

Thanx Mr Farruk Haroon disabling ICS has solved my issue.

Regards

Mohammed Ali Dalvi

Margresse Sat, 11/09/2013 - 13:27

I had the same problem. Here's what I did to make it work:

Start-> Run-> services.msc *Enter*

Look for Internet Connection Sharing (ICS) in the list. Doubleclick.

Change startup type to Disabled.

Below Service Status, press Stop.

Then press Ok, to close dialog. Restart VPN client, and it worked again this time. Woohoo.

jeffreyritz Tue, 11/12/2013 - 08:19

I had recently enable Internet Connection Sharing on my Windows 7 system, and earlier today when I attempted to connect to one of my Cisco VPN profiles, I was encountering the Error "Reason 442: Failed to Enable Virtual Adapter" error after few mintues". 

I spent sometime reviewing and attempting some of the troubleshooting steps identifier in the Support Forum (E.G. https://supportforums.cisco.com/thread/2102064) threads resolving similar issues.  Yet it came to me I recently setup my wireless adapter (primary used adapter) to share it's internet connection with my Ubuntu v12.x system over a Local Area Connection (Ethernet).  After I disabled the Internet Connection Sharing on my Wireless Adapter, it resolved my problem and I was able to authenticate and login to the VPN server.

My issue is resolved, thank you for all the postings to guide me. 

cisco@amundo.org Sun, 01/05/2014 - 11:53

I had the same problem (Windows 7 Pro x64).

Starting the "Routing and Remote Access" service (which for some reason was disabled) fixed the issue for me.

Actions

Login or Register to take actions

This Discussion

Posted August 30, 2011 at 5:04 PM
Stats:
Replies:20 Avg. Rating:5
Views:283904 Votes:3
Shares:3
Tags: No tags.

Discussions Leaderboard