Unity Connection 7.1.5 restore failing

Answered Question
Sep 8th, 2011

I have a physical server on CUC Version 7.1.5.30000-117 I take a DR Backup 100% fine.

I have built a new VM and installed CUC Version 7.1.5.30000-117, it has the same name and IP address,

when I attempt to restore the DR I get an error on

Connection_Database Failure at 60%

and

Connectio_Message_Unitymbxdb1at 5%

The error log file says 

"Physical restore failed - could not fork server copnnection, SQLCODE -25596"

and

"Phython C API version mismatch for module iproduct: This python has API version 1013, module iproduct has version 1012"

I have attempted the restore twice with identical results.

Any ideas ??

Thanks

James

I have this problem too.
0 votes
Correct Answer by Aaron Harrison about 2 years 7 months ago

Hi

I've not done this. But... there is a chapter in the Reconfig and Upgrade guide for v8 that describes what you are trying to do:

http://www.cisco.com/en/US/docs/voice_ip_comm/connection/8x/upgrade/guide/8xcucrug025.html

I would guess that perhaps your VM has disks that are smaller than your physical server. Did you use the OVA file to deploy? What size disks do you have on your physical source and virtual server?

Regards

Aaron

Please rate helpful posts...

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (7 ratings)
keanej Fri, 09/09/2011 - 06:26

I use freeFTPd Version 1.0.11

I have used it for a long time, I use it to backup all the Call Managers without problems.

Please note I am not having a problem backing up - just a problem with restoring.

Also I am restoring a DR Backup from an appliance to a VM.

keanej Tue, 09/13/2011 - 03:00

I installed Titan and did a backup with Titan, I then restored with Titan. Same Failure.

I have a hunch this is related to backing up on a MCS Server and restoring to a C210 Host VM.

Anyone done this ??

keanej Wed, 09/14/2011 - 01:43

Can I rephrase this question in the hope that someone takes interest !

Can you take a backup of 7.1.5 CUC on MCS and restore it to a VM on 7.1.5 ?

Has anyone does this ?

Correct Answer
Aaron Harrison Wed, 09/14/2011 - 01:57

Hi

I've not done this. But... there is a chapter in the Reconfig and Upgrade guide for v8 that describes what you are trying to do:

http://www.cisco.com/en/US/docs/voice_ip_comm/connection/8x/upgrade/guide/8xcucrug025.html

I would guess that perhaps your VM has disks that are smaller than your physical server. Did you use the OVA file to deploy? What size disks do you have on your physical source and virtual server?

Regards

Aaron

Please rate helpful posts...

keanej Wed, 09/14/2011 - 02:54

The MCS server is a 7845H2 with two XEON processors @ 2333 and 4mb of RAM

The Discs are setup in two logical 72gb drives which map to two sets of Raid 0+1 (mirror) - so it maps to four discs.

The OVA Template I used was - CUC_5000_user_v1.0_v1.0_vmv7.ova

I believe this has 2xprocessors with 4gb of memory and a 200gb hard-drive.

I run the VM on a C210M2 (beast of a host from Cisco)

I believe the MCS uses Active and Standby Partitions - whereas the VM's dont use this. However this wasnt a problem with CUCM which installed fine.

I suppose I could build again with two discs - I probably dont need to build with the 5000 user one as I only have 980 user licenses - I thought I would have a better chance of restoring with bigger provisioned discs.

The document you quoted does suggest matching your existing hardware as much as possible.

I will let you know how I get on.

Aaron Harrison Wed, 09/14/2011 - 03:30

Hi

Well - 2x 72 = 144, which is theoretically what your total storage is on your real box.

It would be worth checking what disks have been provisioned from within vSphere, as 200 would sound like enough according to that doc.

You still have active/standby partitions in VMs, nothing has changed there... but those partitions obviously exist within the physical limits of storage already on your physical box..

Aaron

keanej Wed, 09/14/2011 - 05:01

I have configured the discs as per recommended and set them to be independent-persistent mode - as per below

If the physical server has more total available disk space than the virtual machine: Change the VMware virtual machine hardware configuration so the Connection virtual machine has as much as or more total available disk space than the physical server.

Total available disk space is the amount of disk space usable by Connection after accounting for the RAID configuration. (For example, two 146-GB hard disks configured as RAID 1 provide only 146 GB of total available disk space.)

In the VMware vSphere Client, configure the virtual disks that are assigned to the Connection virtual machine in independent-persistent mode. This provides the best storage performance.

No change - still fails at 60%

Any ideas ?

Perhaps there is some sort of issue with the backup data itself ?

keanej Thu, 09/15/2011 - 06:55

Ok I rebuilt the VM

Did the 1000 ova option -

I reset the discs to match my backup - 2 X 72gb

Set the discs to Independent - Persistent Mode

set the VMCI to unrestricted

Tried a restore with TITAN, failed again at 60%

I cant see how I am going to get my VM version any more like the original hardware.

Beginning to think I have an issue with the database itself.

Not getting a warm and fuzzy feeling with this upgrade to 8.5 at all. Actually I am quite nervous that I wont be able to restore back to my orginal.

I will probably use the mirrors as my regression path in the event of failure.

ie

Power down

remove discs 2 & 4

Power up

Verify normal functionality

upgrade to 8.5

test -

Take backup

restore backup onto VM.

cross fingers !!!

In the event of roll back-

power down

remove discs 1 & 3

insert discs 2 & 4

power up

Verify normal functionality

should be back at 7.1.5

keanej Mon, 09/26/2011 - 04:30

I attempted the hardware upgrade from 7.1.5 to 8.5.1 - I think no one is responding to this as its marked as answered -

I'll open the whole thing again.

saagniho Mon, 09/26/2011 - 04:39

Well, I don't know if you have considered COBRAS Export or not....

If you still have the Unity Connection running on MCS server, take a COBRAS Export on the Unity Connection and then try to restore the same on the Unity Connection server on the UCS.

The advantage with COBRAS is that it can be restored on any Unity version equal to or higher than the version from where the Export was taken. It also free from any constraints like same ip address or hostname.

If COBRAS Export is a possible option, I would highly recommend you to try it!!!

HTH!!!

Regards,

Saurabh Agnihotri

keanej Mon, 09/26/2011 - 04:58

So are you saying I could take a COBRAs backup of 7.1.5 and restore this directly to 8.5.1 ??

Is there any issues about the HA (subscriber) box.

saagniho Mon, 09/26/2011 - 07:59

Yes, you can take COBRAS export from CUC version 7.1.5 and import it directly on CUC version 8.5.1

Here is the link for further reading:

http://ciscounitytools.com/Applications/General/COBRAS/Help/COBRAS_Briefcase/COBRAS_Briefcase.htm

As far as the HA is concerned, you just need to perform the COBRAS Export on the Publisher server. dbreplication will take care of pushing all the data onto the Subscriber.

Please rate helpful posts.

Regards,

Saurabh Agnihotri

toormehdi Wed, 10/12/2011 - 10:26

I think your problem might be the same I am running into.

Essentially the DRS needs a proper license to create exact number of ports etc during the restore.

That means you would need a license file on the UCS/VMware platform with license MAC.

Unfortunately the file licensing team provides which you request for have it rehosted based on the new licence MAC doesnt work and give tag errors when installing.

I had similar issue with CUCM, but that licensing team was able to resolve it. The way they do it is to have following line in the license file

HOSTID=HOSTNAME=65910AF71E2B instead of just HOSTID=65910AF71E2B.

Licensing team says, its doabble for CUCM but not for CUC as they dont get option to insert the parameter HOSTNAME.

Now I am hoping Saurabh or BU can assist us here with having the HOSTNAME parameter in the rehosted license file from MCS to UCS.

Saurabh, please help.

Thanks

Toor

keanej Fri, 10/14/2011 - 03:47

Prehaps this is a license issue.

I am attempting to restore to a box with the demo license installed.

Can you let me know how you get on ??

keanej Mon, 10/17/2011 - 01:40

I got a resolution to this issue - the DNS servers MUST be available and reachable for the restore to work.

It was as simple as that.

twin-turbo Wed, 02/06/2013 - 03:39

Just had the above issue.

I was using dummy DNS values just to get running, after putting in a real server that had an entry for unity it worked.

THANKS

Rob

Actions

Login or Register to take actions

This Discussion

Posted September 8, 2011 at 6:28 AM
Stats:
Replies:17 Avg. Rating:5
Views:2419 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard