Call drop when transfering from one CME to another CME

Answered Question
Sep 13th, 2011

Hi,

I have this scenario:

PSTN  ---- E1/T1 card -- CME 2811 <--- H323  --- > CME 2851

Incoming and outgoing calls work just fine in CME2811 and I just added CME2851 which I can make internal and external calls fine but when getting a call from pstn it drops.. I mean  the phones registered in CME2851 ring when I call from the PSTN but when I answer the call  it drops...

CME2811(Version 12.4(20)T1)

CME2851( Version 15.0(1)M6)

  I got some debugs from CME2851 but I just get Cause Code=41   but I dont find anythig related to it.. the extension I´m trying to get is 548 which is in CME2851 ..

I attached the debug and the config from each CME..

Any ideas ??  Appreciate your help..

Regards.

I have this problem too.
0 votes
Correct Answer by Steven Smith about 2 years 7 months ago

Those debugs weren't the H225 and H245 debugs I was looking for.  Try running all of these for the call.

debug voip ccapi inout

debug h225 q931

debug h225 asn1

debug h245 asn1

debug h225 events

debug h245 events

debug cch323 all

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (1 ratings)
Carlo Poggiarelli Tue, 09/13/2011 - 12:51

Hi.

Please post a sh voice call status during an incoming call and post the output of a debug voip dialpeer inout.

Thanks.

Regards.

Carlo.

adavila03 Tue, 09/13/2011 - 13:08

Hi Carlo here it is:

2851-CM#sh voice call status

CallID     CID  ccVdb      Port        Slot/DSP:Ch  Called #   Codec    MLPP Dial-peers

0x531      2508 0x49D5B6A0 50/0/4.0                *548        None      2/20005

1 active call found

I also tried adding the codec g711ulaw under dial-peer voice 2 voip and tried adding voice class with different codecs.. but same thing when the party answers I get busy signal..

I also attach debug h225 ,h245 and debug voip dialpeer inout ...

Steven Smith Tue, 09/13/2011 - 12:56

H225 and H245 debugs would be useful as well, but here is my guess.

dial-peer voice 3004 voip

translation-profile outgoing did1504

destination-pattern 154.

session target ipv4:172.17.4.250

dtmf-relay h245-alphanumeric

codec g711ulaw

Dial-peers on the other side don't have codec assigned.  Incoming peer is 2.

dial-peer voice 2 voip

description Calls to CME2811

destination-pattern 9T

session target ipv4:172.17.10.250

dtmf-relay h245-alphanumeric

Not probably the one you were expecting to match as the incoming peer, but the one that was matched.

I would suggesting using voice class codec configuration.

adavila03 Tue, 09/13/2011 - 13:15

I also tried adding the codec g711ulaw under dial-peer voice 2 voip and tried adding voice class with different codecs.. but same thing when the party answers I get busy signal..

Steven Smith Tue, 09/13/2011 - 14:16

Could you get H225 and H245 debugs?  Those are going to be required to see what is wrong here.

Correct Answer
Steven Smith Tue, 09/13/2011 - 14:34

Those debugs weren't the H225 and H245 debugs I was looking for.  Try running all of these for the call.

debug voip ccapi inout

debug h225 q931

debug h225 asn1

debug h245 asn1

debug h225 events

debug h245 events

debug cch323 all

Steven Smith Tue, 09/13/2011 - 15:44

The 2811 is disconnecting the call.  Not sure why yet.  Need the same debugs on that gateway.

Also, could you get all all of the debugs in 1 file?

adavila03 Tue, 09/13/2011 - 15:54

Sure Steven let me get them... but how did you realize that it was the 2811 ?

thanks again!

Steven Smith Tue, 09/13/2011 - 16:01

Several messages indicate that the release is received in the trace.  Without posting the 225 messages, which are big, here are some small ones that show it as well.

*Sep 13 21:45:03.896: //-1/xxxxxxxxxxxx/H323/cch323_h225_receiver: Received msg of type RELEASEIND_CHOSEN

*Sep 13 21:45:03.896: //1394/DC20D5A999B5/H323/release_ind: Disconnect cause 41 location code 0

Carlo Poggiarelli Tue, 09/13/2011 - 16:44

Hi.

Try to add this dialpeer to your 2851 config

dial-peer voice 548 voip

incoming called-number 548

codec g711ulaw

dtmf-relay h245-alphanumeric

Let me know.

HTH

Regards

Carlo

adavila03 Tue, 09/13/2011 - 16:53

Hi Carlo,

I try adding the dial-peer 548 but same thing  the call drops when the party answers...

thanks!

Carlo Poggiarelli Tue, 09/13/2011 - 17:51

Hi

Please post the output of a show voice call status on and a debug  ccapi on 2811?

Thanks again.

Carlo

Actions

Login or Register to take actions

This Discussion

Posted September 13, 2011 at 10:54 AM
Stats:
Replies:16 Avg. Rating:5
Views:928 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard