About ASR9010

Unanswered Question
Sep 26th, 2011

Now, I will upgrade two 6509 devices to ASR9010,but I don,t know some problem

Can I migrate the switching configuration to the ASR9010 ?

ASR9010 with the A9K-40GE-B line card

Can I Create vlan interface in the ASR9010.

Can I type the switching configuration on the ASR9010 ?

for example

vlan xxx

interface g0/0/0/0
switchport

switch mo access

swithc acc vlan xxx

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
Chenjiannan Mon, 09/26/2011 - 01:18

There are many L2 trunk port on the 6509,

can i mirate below configuration to the A9K?

interface GigabitEthernet6/2

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 2-7,9-12,14-20,22,24-26,31-39,51-149,151-204,206

switchport trunk allowed vlan add 207,209-708,711-717,719-733,737-741,743

switchport trunk allowed vlan add 745-747,750,751,756,758,759,761,763-768

switchport trunk allowed vlan add 770-779,782-784,786,788-791,794,795,901-959

switchport trunk allowed vlan add 961-1019,1021-1102,1104,1105,1108,1109

switchport trunk allowed vlan add 1111-1113,1123,1125-1127,1129,1130,1132

switchport trunk allowed vlan add 1134-1136,1141,1142,1144-1200,2005-2050

switchport trunk allowed vlan add 2052-2060,2066-2070,2104-2110,2117-2119

switchport trunk allowed vlan add 2121-2130,2144-2150,2152-2170,2174-2191

switchport trunk allowed vlan add 2193-3020,3022,3023,3025-3100,3105,3109-3203

switchport trunk allowed vlan add 3205,3206,3209,3210,3212-3900,3902-3999

switchport mode trunk

speed nonegotiate

udld port aggressive

dragoljubspasojevic Mon, 09/26/2011 - 01:41

Yes it is possible but configuration will be huge.

I think that ASR maybe is not best solution for your needs.

dragoljubspasojevic Mon, 09/26/2011 - 01:04

There is no classical L2 ports on ASR (IOS XR) platform.

You can use next configuration for access ports with etherchannel:

interface BVI1

description servers

ipv4 address xx.xx.xx.xx xx.xx.xx.xx

interface GigabitEthernet0/0/0/2

description server1 #1

bundle id 11 mode active

interface GigabitEthernet0/0/0/3

description server1 #2

bundle id 11 mode active

interface GigabitEthernet0/0/0/4

description server2 #1

bundle id 12 mode active

interface GigabitEthernet0/0/0/5

description server #2

bundle id 12 mode active

l2vpn

bridge group servers

  bridge-domain servers

   interface Bundle-Ether11

   !

   interface Bundle-Ether12

   !

   routed interface BVI1

  !

!

!

Access port configuration is :

l2vpn

bridge group NAME

  bridge-domain 2

   interface GigabitEthernet0/0/0/5.2

     description bh-mgt

     encapsulation dot1q 2

     rewrite ingress tag pop 1 symmetric

Trunk port configuration is :

l2vpn

bridge group NAME

  bridge-domain 2

   interface GigabitEthernet0/0/0/5.2

     description bh-mgt

     encapsulation dot1q 2

Bryan Garland Tue, 09/27/2011 - 11:17

So are you saying you need the equivalent of a inteface vlan for all these as well?  Or are you trying to make these just l2 ports through the A9k? 

As already mentioned the config example will work.  It will be a lot of config work to get this for all those vlans.  Is it not possible to terminate L3 on this port for those vlans or do you need multiple ports in those vlans, thus needing IRB?

Just becuase you are replacing a 6500 (switch) with an A9k (router) doesn't mean you can't change the over all design to leverage the capabilities of the newer platform. 

The below doc describes how IRB adn the EVC model works in XR. 

https://supportforums.cisco.com/docs/DOC-15556

Thanks,

Bryan

Actions

Login or Register to take actions

This Discussion

Posted September 26, 2011 at 12:33 AM
Stats:
Replies:4 Avg. Rating:
Views:1887 Votes:0
Shares:0
Tags: asr9010
+

Related Content

Discussions Leaderboard