DHCP issue with WS-C3560G-24PS

Unanswered Question
Sep 28th, 2011

Hi ,

DHCP relay not working in switch WS-C3560G-24PS

image details -

c3560-ipservicesk9-mz.122-55.SE.bin

its working if i keep DHCP server in same vlan as user ., wireshark says DHCP offer packets are currupted and there is no client ip (0.0.0.0 0.0.0.0 ) .

shark.jpeg

Thanks 4 reply

---------------------

----------

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
cadet alain Thu, 09/29/2011 - 00:57

Hi,

Could you post the wireshark capture file filtering only DHCP.

Provide sh run | s dhcp.

Also do a debug ip dhcp server events and debug ip dhcp server packets on the switch doing relay.

Regards.

Alain.

shehinpm1 Thu, 09/29/2011 - 01:45

Hi saqar,

i hope u hv configured "ip helper-address" in all other vlan interfaces.

Thx

shehin.pm

Sagar Rane Thu, 09/29/2011 - 06:38

Hi Alain ,

Here is the capture attached .

Thanks 4 reply

----------------------

cadet alain Thu, 09/29/2011 - 06:54

Hi,

I was talking about the modified pcap showing only dhcp not a screenshot.

Can you also picture your topology with HSRP, DHCP server, DHCP pools and provide output of sh run | be dhcp on the switch.

Where was the capture taken? where is located DHCP server, is it router, w2k3,linux?

Regards.

Alain.

Sagar Rane Thu, 09/29/2011 - 07:19

Hi Alain ,

This is windows server , switch 3560 acting as relay .Before switch was working as IOS DHCP and now I want it to configure as relay agent only .

In same vlan its working fine but on diff vlans its not .

I m not able to attach wireshark capture here , not able to find option   what most i can say DHCP offer packet is currupt with 0.0.0.0 in client address .

please let me know if any thing you can suggest me .

Thanks 4 reply

------------------------

cadet alain Thu, 09/29/2011 - 07:40

Hi,

provide a picture of topology and post running of the 3560 .

Just use the attached file at the bottom of window to attach pcap file.

Regards.

Alain.

Sagar Rane Thu, 09/29/2011 - 11:13

Hi Alain ,

            wireshark attached 4 during the issue .

           topology is simple as both server and clients connected on same switch which is working as relay between two vlans .

Thanks 4 ur early repluy

--------------------------------------

Sagar Rane Thu, 09/29/2011 - 11:17

foget to add - full config I m not able to past here but here is the vlan for which i did wireshark capture -

!

interface Vlan100

description <<< A_Corp >>>

ip vrf forwarding A_VRF

ip address 10.107.170.2 255.255.255.192

ip access-group A_Corp in

ip helper-address 10.107.170.228

no ip redirects

no ip unreachables

no ip proxy-arp

standby 100 ip 10.107.170.1

standby 100 timers 5 10

standby 100 preempt

standby 100 authentication md5 key-string 7 052D423960666E3039

!

cadet alain Thu, 09/29/2011 - 13:32

Hi,

I've never configured DHCP relay agent with vrf so I'll lab it up to see if this is the vrf which may be causing the problem.

Regards.

Alain

Actions

This Discussion