vlan status up down

Unanswered Question
Sep 30th, 2011

hello!

I created vlan management in switch 2950.

I craeted vlan in layer 2 and I defined Ip address.

The status of the vlan was up down.

When I access a port to this vlan the status was up up (the status of the port was connected).

This vlan is for managemen.

What to do?

I don't need a port in this vlan.

There special commands?

thanks...

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
Reza Sharifi Fri, 09/30/2011 - 14:48

Hi,

On your 2950 you need to create layer-2 vlan and also the svi

in this example I am using vlan 10

layer-2 vlan

config t

vlan 10

name mgmt

layer-3 vlan

interface vlan 10

ip address 10.10.10.1 255.255.255.0

desc mgmt vlan

then you need to add this vlan (vlan 10) to your trunk connecting your 2950 to other switches

no need to add physical port to this vlan

HTH

erinixon Fri, 09/30/2011 - 15:04

In order for the L3 SVI to show up/up, the VLAN needs to be defined in the VLAN database, there needs to be an active port forwarding for that VLAN in spanning-tree either access or trunk port, and then of course the IP address of your SVI so you can reach the box for management remotely.

show vlan brief ( make sure your vlan is in the vlan db , and your access port is assigned to this vlan if using access port)

show int trunk ( make sure your vlan is allowed on the trunk) should be allowed by default

show spanning-tree vlan 10 (make sure you have an active forwarding port in that VLAN)

-Erik

oded-levi Fri, 09/30/2011 - 15:16

1.The VLAN defined in the VLAN database (vlan.dat , flash)

2.the trunk conigured:

switchport trunk encapsulation dot1q

switchport mode trunk

3.I dont use stp.

oded-levi Fri, 09/30/2011 - 15:05

Hi Reza,

1.thanks.

2.What is the command for the SVI?

"then you need to add this vlan (vlan 10) to your trunk connecting your 2950 to other switches"

3.Do you mean if I have trunk port, I need to add the vlan (switchport trunk allowed vlan 10,-----)?

Reza Sharifi Fri, 09/30/2011 - 15:09

3.Do you mean if I have trunk port, I need to add the vlan (switchport trunk allowed vlan 10,-----)?

yes, exactly

.2.What is the command for the SVI?

SVI and layer-3 vlan are the same thing

here is the config for SVI or layer-3 interface

interface vlan 10

ip address 10.10.10.1 255.255.255.0

desc mgmt vlan

HTH

oded-levi Fri, 09/30/2011 - 15:23

3. why I dont need to configure:

switchport trunk encapsulation dot1q

switchport mode trunk

4. If I have one switch , and the I want to creat int vlan (layer 3) without access port, it is possible?

Reza Sharifi Fri, 09/30/2011 - 16:14

3. why I dont need to configure:

switchport trunk encapsulation dot1q

switchport mode trunk

If you have an uplink port (trunk) then you have to add this vlan to the trunk, but if you just configure the commands above then all vlans are allowed You need to have an active port in the vlan in order for it to come up.

4. If I have one switch , and the I want to creat int vlan (layer 3) without access port, it is possible?

In this case if you only have one switch then you need to configure later-2 and layer-3 vlan and add a physical port as an access port  to this vlan.  Then you can connect your PC to that port and that will bring up the vlan

here is an example

interface GigabitEthernet1/0/10

switchport access vlan 10

switchport mode access

spanning-tree portfast

HTH

Actions

Login or Register to take actions

This Discussion

Posted September 30, 2011 at 2:32 PM
Stats:
Replies:7 Avg. Rating:
Views:3497 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard

Rank Username Points
1 15,007
2 8,150
3 7,725
4 7,083
5 6,742
Rank Username Points
165
82
70
69
55