ASA memory requirement 8.0 & 8.2 code

Unanswered Question
Oct 3rd, 2011

Hi,

We have ASA 5520 with currently code 7.2 running on it with 512 MB default memory. If we need to upgrade the code to 8.0 or 8.2 is this default RAM of 512 MB sufficient to run the new 8.0 or 8.2 code?

Or do should upgrade to 2 GB upgrade kit is it a mandatory requirement?

Searched following links not sure if ASA will work with default 512 MB of RAM

http://www.cisco.com/en/US/docs/security/asa/asa80/release/notes/asarn80.html#wp37821

http://www.cisco.com/en/US/docs/security/asa/asa82/release/notes/asarn82.html#wp37821

Please share the requirement.

Thanks

Subodh

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (1 ratings)
varrao Mon, 10/03/2011 - 06:28

Hi Subodh,

For version 8.2 you should atleast have 1 GB of memory on ASA 5520. With ASA 8.0 I guess 512 MB shoudl also do. It actually depends on the code, if you move up the ladder, there are new features and processes that eat up more memory so, 1 GB should be an optimum value.

Thanks,

Varun

dariogustin Thu, 06/14/2012 - 14:16

Hello Varun,

Which is the flash memory requirement to upgrade from ASA5520 v8.0 to 8.2? I have a 256MB internal flash memory.

Regards,

Darío

patoberli Fri, 06/15/2012 - 04:33

Hi,

Our 5520 is running 8.2 and has (original) 512 MB of RAM and 256 MB of Flash.

With currently 70 Mbit/s combined traffic, 20-30 connections per second and around >3000 access rules we hit 257 MB RAM and 36% cpu load.

Your configuration is absolutely supported. Only when switching to 8.3+ is a memory upgrade required!

pato

Actions

Login or Register to take actions

This Discussion

Posted October 3, 2011 at 6:11 AM
Stats:
Replies:4 Avg. Rating:5
Views:702 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard

Rank Username Points
1 7,861
2 6,140
3 3,165
4 1,473
5 1,446