Installing Informix ODBC drivers on 64-bit OS

Unanswered Question
Oct 5th, 2011
User Badges:

I'm trying to install the Informix ODBC drivers on Windows 7 64-bit so I can run the Wallet Card Wizard. I am getting the following error:


"Prerequisite verification checks failed

InstallAnywhere has detected that you are installing the 32 bit product on a 64 bit machine

Prefix path with C:\Windows\SysWOW64 and restart the installer."


There is a BAT file included with the installer that prefixes C:\Windows\SysWOW64 to the path and runs the installer for you, and I've also tried manually doing it via command prompt. Either way, I still get the error.


Has anyone else run into this or found a workaround? Attached is a screenshot of the error.

Attachment: 
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.8 (7 ratings)
Loading.
lindborg Sat, 10/08/2011 - 13:53
User Badges:
  • Cisco Employee,

All connection tools are compiled exclusively for 32 bit - therefore you want to stick to the 32 bit version of the driver even if you're running on a 64 bit OS...

ross.parker Mon, 03/04/2013 - 14:17
User Badges:

I know this is an old question, but I did not see an answer.


  1. Run the command prompt as an administrator.
  2. From the command prompt, go to the ODBC driver install directory and enter the following commands.

     set PATH=%windir%\sysWOW64;%PATH%

     installclientsdk.exe


Worked for me.

pwoll Fri, 10/04/2013 - 17:50
User Badges:

Thank you Ross.  Your reminder to run the command prompt as administrator solved my similar problem.

admin.smbtech Tue, 02/02/2016 - 10:36
User Badges:

One thing to add: if you're installation directory is on a network share, this won't work. I guess it has to do with the relative path of the installer EXE to the target destination. Not exactly sure I'm wording this right. You'll need to copy the installation dir to your local machine, append the PATH var and it should work.

lindborg Tue, 02/04/2014 - 13:12
User Badges:
  • Cisco Employee,

Not sure why following those instructions would work for you but the above would not - they're identical other than they have you making the change to the path in settings instead of in a command window - the process is identical. 


The fact that IBM puts up a page with such details and has refused to address the problem with a proper install option in 4 years now is maddening... but that aside, I actually put a TOI video together of me doing this entire process on x64 install of Windows 8 - you can get to it off the SDK download page here:


http://www.ciscounitytools.com/Applications/CxN/InformixODBC/InformixODBC.html


I'd be deeply puzzled as to why you couldn't make that work but you could follow the IBM page - that doesn't make much sense.  We've done this process on Vista, Windows 7, Windows 8, Windows 8.1, Server 2008R2 and Server 2012R2 installs for x64 bit installs and all work...

apollara1 Mon, 07/14/2014 - 06:23
User Badges:

I was running into the same problem. I logged into my Windows 7 PC with an administrative account, I set the PATH variable through the command prompt, and I would start the installation from the command prompt. I would get the same exact error. What I had to do was to run the command prompt as an administrator. I assumed that if I was logged in with an account that had administrative privileges within the command prompt but I did not.

 

According to Microsoft’s web site only the actual administrator account has administrative privileges by default in the command prompt. All other accounts have standard user permissions and have to use the “Run as Administrator” option. Here is Microsoft’s site that details this - http://technet.microsoft.com/en-us/library/cc947813%28v=ws.10%29.aspx. I hope this helps.

zephynator Mon, 08/11/2014 - 11:09
User Badges:

Just wanted to +1 this comment. I was running into the same issue after entering the path as recommended per all of the other instructions. Running the command prompt as administrator solved the issue for me as well.

Richard Simmons Wed, 06/24/2015 - 06:15
User Badges:
  • Bronze, 100 points or more

I know this is an old post but i've just been struggling with this, for some reason my environment variable was called 'Path' once I changed this to 'PATH' with 'C:\Windows\SysWOW64 added it then allowed me to progress with the installation.

Regards,

Richard

Actions

This Discussion

Related Content