VG224 fax problems since switching to T.38

Unanswered Question
Oct 9th, 2011

We are going to be implementing a fax server (FOIP) and needed to implement T.38 Fax relay.  However, since we have done that, we are having a lot of problems with our analog fax machines (connected via VG224 analog gateways).  note:  analog phones on those VG224 make voice calls just fine.  The faxes will connect but then either get a "comm error" or remote side disconnect.   We are using CUCM 7.1(5). 
These are the commands that Cisco helped me perform:

 

1.   Change each VG224 gateway that we currently use to “enable T.38 Fax Relay” within Call Manager.

2.   Change our two gateways (Cisco 2811’s) that are gateways to our Telecommunications provider to “enable T.38 Fax Relay”.

3.   Telnet to each of the gateways in steps one and two and do the following:
     a.     Configuring CA-Controlled MGCP T.38 Fax Relay
          i.    Use the following steps to configure CA-controlled MGCP T.38 fax relay.
          ii.    SUMMARY STEPS
                    1.     enable
                    2.     configure terminal

                    3.     no mgcp fax t38 inhibit
                    4.     mgcp package-capability fxr-package
                    5.     mgcp default-package fxr-package.
                    6.     –after exiting run “no mgcp” and “mgcp” to restart MGCP.

Ever since we did the above we've seen numerous problems. 

This is what part of our VG224 config looked like prior to the above changes (sorry - i don't have the current config but can get it if needed).

ccm-manager mgcp

no ccm-manager fax protocol cisco

ccm-manager music-on-hold

ccm-manager config server 10.0.0.176

ccm-manager config

ccm-manager config dialpeer-prefix

ccm-manager download-tones

!

mgcp

mgcp call-agent 10.0.0.176 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

no mgcp package-capability res-package

mgcp package-capability sst-package

no mgcp package-capability fxr-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 inhibit

mgcp rtp payload-type g726r16 static

mgcp bind control source-interface FastEthernet0/0

mgcp bind media source-interface FastEthernet0/0

!

Any thoughts on things we can change/modify to help our issues.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
acampbell Mon, 10/10/2011 - 05:18

Hi,

Gateway config changes look OK to me

Just a thought

On your CUCM have you changed the Gateway config page to support Fax Mode -- FAX RELAY

HTH

Alex

hoffmann.marc Mon, 10/10/2011 - 05:38

Hi,

I have also a VG224 in my environment.

I have also a fax machine and a FoIP server connected to it. I have declared my VG224 as SCCP and so I do not have the MGCP configuration part.

Here is an extract of my configuration:

stcapp ccm-group 1

stcapp

!

voice service voip

  fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback pass-through g711ulaw

  modem passthrough nse codec g711alaw

!

ccm-manager config server 1.2.3.4

ccm-manager sccp local FastEthernet0/0

ccm-manager sccp

!

mgcp profile default

!

sccp local FastEthernet0/0

sccp ccm 1.2.3.4 identifier 10 priority 1 version 3.1

sccp ccm 1.2.3.5 identifier 11 priority 2 version 3.1

sccp

!

sccp ccm group 1

associate ccm 10 priority 1

associate ccm 11 priority 2

registration timeout 3

keepalive timeout 3

connect interval 3

!

Please feel free to try this.

Marc

acampbell Mon, 10/10/2011 - 05:47

Hi,

No not on the VG224 (your settings look correct) but on the I/C O/G MGCP gateway.

Regards

Alex

Actions

Login or Register to take actions

This Discussion

Posted October 9, 2011 at 4:48 PM
Stats:
Replies:4 Avg. Rating:
Views:1185 Votes:0
Shares:0

Related Content

Discussions Leaderboard

Rank Username Points
1 21,026
2 15,047
3 10,314
4 7,999
5 4,856
Rank Username Points
135
90
72
66
55