Unknown protocol drops are increasing

Unanswered Question
Oct 10th, 2011

Hello,

What is unknown protocol drops because i have a 7200 series router connected to the 4500 series switch and i am able to see these unknown protocol drops getting increased once every 30 sec.

Router -21>sh int gi0/1

GigabitEthernet0/1 is up, line protocol is up

    5 minute input rate 7418000 bits/sec, 6212 packets/sec

  5 minute output rate 10991000 bits/sec, 5264 packets/sec

    1643435459 packets input, 2165307555 bytes, 0 no buffer

    Received 28581 broadcasts, 0 runts, 0 giants, 0 throttles

    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

    0 watchdog, 330098 multicast, 0 pause input

    0 input packets with dribble condition detected

    1510539932 packets output, 4224476290 bytes, 0 underruns

    0 output errors, 0 collisions, 0 interface resets

    19009 unknown protocol drops

    0 babbles, 0 late collision, 0 deferred

    0 lost carrier, 0 no carrier, 0 pause output

    0 output buffer failures, 0 output buffers swapped out

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
andrew.prince@m... Mon, 10/10/2011 - 10:40

Is the route connected to a switch? Is the switch port configured not to send bpdu's, does the switch port have DTP enbabled??

Unknown protocol drops are exactly just that, the router is receiving stuff it just does not understand, nothing to worry about.

Richard Burts Mon, 10/10/2011 - 20:28

I agree that unknown protocol drops are usually not a cause for alarm, especially when a layer 3 device like a 7200 is connected to a switch which may be sending various layer 2 protocols which the router does not understand. DTP is a good possibility, as are VTP and some other layer 2 protocols.

HTH

Rick

sathyasav Tue, 10/11/2011 - 08:00

@Andrew,

Thanks for ur reply.Yes the router is directly connected to the switch and the is port connected to the router is access port and it is configured to the vlan 10.will the switch send BPDU'S on the access port? if it will then how to disable it? Then how to check whether DTP is enabled on the switch. is it autonegotiation for trunk?

Please reply ASAP.

@Richards,

Thanks for ur response.I not sure about DTP and other layer 2 protocol but i am sure that VTp couldnt be an issue since the port is configured as access port.

andrew.prince@m... Tue, 10/11/2011 - 08:26

A swichport place into "portfast" disables the sending of BPDU's, and enabling BPDU filtering.

DTP is disabled by issuing the command "switchport nonegotiate"

sathyasav Tue, 10/11/2011 - 10:38

So if we enable portfast on any interface then it will automatically enable the BPDU filtering without any separte commads right?Then what is the command to check weather BPDU filter is disabled or enabled apart from running configuration?Is there any interface mode command for this.

Is DTP enabled default?

andrew.prince@m... Tue, 10/11/2011 - 10:49

No portfast brings the interface straight up forwarding and stops the switch from sending BPDU's out the interface, it can still rececive - that is why if you connect a switch to another switch with portfast enabled - you will have a spanning tree loop, and kill the network.  BPDU Filtering is the next generation if you will, it will stop sending BPDU''s on the interface, bring the interface straight up forwarding BUT if it recevies a BPDU it will shut the interface and then put the interface to listening/learning etc.

DTP is enabled by default on ALL switchports.

HTH>

sathyasav Tue, 10/11/2011 - 11:06

So you mean to say that enabling Port fast stops sending BPDUs on the interface but still it receives BPDU.But BPDU filter is a different term which stops sending the BPDU and makes the port shut down if it recieves the BPDU ion the configured interface.is that right.if that is right thenwhat is BPDU guard.

And please answer my below question too,

Then what is the command to check whether BPDU filter is disabled or enabled apart from running configuration?Is there any interface mode command for this.

andrew.prince@m... Tue, 10/11/2011 - 12:01

BPDU Guard allows the switch to receive BPDU's but just drops the frame, not disable the port.

"show spanning-tree summary"

sathyasav Tue, 10/11/2011 - 12:09

I think you are explaning about the behaviour of BPDU filter.Because BPDU guard upon the reception of BPDu will shut the port down.

And for my second question  apart from this "show spanning-tree summary" command is there any other interface related command is there tocheck the status.Because show spanning-tree summary" command gives the global statistics for BPDU filter not per interface.

Richard Burts Tue, 10/11/2011 - 12:19

I do not agree with my colleague Andrew about what happens with portfast. According to Cisco documentation it is not true that portfast stops the sending of BPDUs. Here is a quote from one of the docs: "When configured for PortFast, a port is still running the spanning tree protocol." Here is theURL if you want to see more detail:

http://www.cisco.com/en/US/docs/switches/lan/catalyst6500/ios/12.2SX/configuration/guide/stp_enha.html#wp1052988

Here is what a different document says about BPDU guard: "The PortFast BPDU guard feature prevents loops by  moving a nontrunking port into an errdisable state when a BPDU is  received on that port. " Here is the URL if you want more detail:

http://www.cisco.com/en/US/docs/switches/lan/catalyst4000/7.4/configuration/guide/stp_enha.html

HTH

Rick

sathyasav Tue, 10/11/2011 - 12:43

Richard,

I gone through the link you mentioned above but i dont understand the below thing which i read from the site which you gave.

A PortFast enabled port can immediately transition to the blocking state if necessary (this could happen on receipt of a superior BPDU).

can you explain this line

Richard Burts Tue, 10/11/2011 - 13:30

I must admit that I am not entirely clear about what it means. This is my understanding of the meaning. It has to do with whether the switch port is still running Spanning Tree when portfast is enabled. If the port stopped running Spanning Tree (and running Spanning Tree is essentially whether it sends and receives BPDUs) then the switch port could never transition to a blocked state. But since the port is still running Spanning Tree (which means that it is sending and receiving BPDU) then if the switch port receives a BPDU which indicates an alternate path to the root bridge (the superior BPDU) then the switch port will transition to the blocked state.

So whether the switch port is portfast or not it will still send BPDU. And perhaps BPDU is one type of frame which would be unknown protocol to the 7200 interface

HTH

Rick

andrew.prince@m... Tue, 10/11/2011 - 13:24

Thank you Rick, for correcting my errors, and reminding me I have been away from the books for to long!

Sent from Cisco Technical Support iPad App

andrew.prince@m... Tue, 10/11/2011 - 13:22

Yeah I get them turned around every now and again!

I'm not sure to be honest, I will have a look when I have access to a switch

Sent from Cisco Technical Support iPad App

sathyasav Wed, 10/12/2011 - 08:52

Rick/Andrew,

i tried configuring the command switchport nonegotiate on the interface which is connected to the router and i am getting the belor error and the interface is not taking the command.Please advice what could be thwb cause and how to overcome this.

error message: conflict between nonegotiate and dynamic status

Please reply ASAP...

Richard Burts Wed, 10/12/2011 - 08:59

In an early post in this thread you say that the switch port is configured as an access port in vlan 10. But you have given us no other detail about the interface. Perhaps you can post the configuration of the port and the output of show interface on the switch?

I associate the nonegotiate command with etherchannel/trunking. I wonder if the issue might be trying to use that command on an access port?

HTH

Rick

andrew.prince@m... Wed, 10/12/2011 - 09:05

To echo Rick,

You need to loo at the output of "show interface <> switchport

hopefully you will see something like

Switchport: Enabled

Administrative Mode: static access

Operational Mode: static access

Administrative Trunking Encapsulation: negotiate

Negotiation of Trunking: Off

sathyasav Wed, 10/12/2011 - 10:22

Rick/Andrew,

still i am saying that this port is configured as a access port and connected to the router.Please find the switch configuration below.

ASB-BAN-SW21#sh run int fa2/48
Building configuration...

Current configuration : 162 bytes
!
interface FastEthernet2/48
description $$ Connection to WAN-Router $$
switchport access vlan 10
speed 100
duplex full
spanning-tree bpdufilter enable
end

ASB-BAN-SW21#sh run int vl
ASB-BAN-SW21#sh run int vlan 10
Building configuration...

Current configuration : 105 bytes
!
interface Vlan10
description $$  Router-Connectivity $$
ip address 172.18.159.1 255.255.255.248
end

ASB-BAN-SW21#

ASB-BAN-SW21#sh int fa2/48
FastEthernet2/48 is up, line protocol is up (connected)
  Hardware is Fast Ethernet Port, address is 5475.d09a.441f (bia 5475.d09a.441f)
  Description: $$ Connection to WAN-Router $$
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 16/255, rxload 30/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, link type is auto, media type is 10/100BaseTX
  input flow-control is unsupported output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:58, output never, output hang never
  Last clearing of "show interface" counters 15:32:37
  Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 12007000 bits/sec, 5132 packets/sec
  5 minute output rate 6448000 bits/sec, 6057 packets/sec
     184969319 packets input, 79402366610 bytes, 0 no buffer
     Received 1026 broadcasts (1026 multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     183063997 packets output, 35048261337 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
ASB-BAN-SW21#sh int fa2/48 sw
ASB-BAN-SW21#sh int fa2/48 switchport
Name: Fa2/48
Switchport: Enabled
Administrative Mode: dynamic auto
Operational Mode: static access
Administrative Trunking Encapsulation: negotiate
Operational Trunking Encapsulation: native
Negotiation of Trunking: On
Access Mode VLAN: 10 (Router-Connectivity)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL

Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none
ASB-BAN-SW21#

andrew.prince@m... Wed, 10/12/2011 - 10:45

Your issue:-

Administrative Mode: dynamic auto

Operational Mode: static access

Negotiation of Trunking: On

Configure

!

interface FastEthernet2/48

switchport mode access

switchport noneg

sathyasav Wed, 10/12/2011 - 11:27

Ok Andrew i will do this configuration tommorrow Off production hours and let you know the result.But gefore that one basic question the default switchport mode is dynamic desirable right?then why it is showing dynamic auto in my case.And the next question is why is it necessary to configure the switchport nonegiate on the access port  since the access port dont send DTP.

Sathya

andrew.prince@m... Wed, 10/12/2011 - 12:56

These various modes are configured using the switchport mode interface command

Switch trunk interfaces support different trunking modes.

Access

Dynamic desirable (default mode on Catalyst 2950 and 3550)

Dynamic auto

Trunk

Non-negotiate

dotq-tunnel (Not an option on the Catalyst 2950.)

switchport mode access - This command puts the interface (access port) into permanent nontrunking mode. The interface will generate DTP frames, negotiating with the neighboring interface to convert the link into a nontrunk link. The interface becomes a nontrunk interface even if the neighboring interface does not agree to the change.

switchport mode dynamic desirable - This command makes the interface actively attempt to convert the link to a trunk link. The interface becomes a trunk interface if the neighboring interface is set to trunk, desirable, or auto mode. This is the default mode for all Ethernet interfaces. If the neighboring interface is set to the access or non-negotiate mode, the link will become a non-trunking link.

switchport mode dynamic auto – This command makes the interface willing to convert the link to a trunk link if the neighboring interface is set to trunk or desirable mode. Otherwise, the link will become a non-trunking link.

switchport mode trunk – This command puts the interface into permanent trunking mode and negotiates to convert the link into a trunk link. The interface becomes a trunk interface even if the neighboring interface does not agree to the change.

switchport nonegotiate – Prevents the interface from generating DTP frames. You can use this command only when the interface switchport mode is access or trunk. You must manually configure the neighboring interface as a trunk interface to establish a trunk link, otherwise the link will be a non-trunking link.

sathyasav Wed, 10/12/2011 - 13:06

Hi Andrew,

here you mentioned the port will become non-trunk.

do you mean it is access(non-trunk)

switchport mode dynamic desirable - This command makes the interface actively attempt to convert the link to a trunk link. The interface becomes a trunk interface if the neighboring interface is set to trunk, desirable, or auto mode. This is the default mode for all Ethernet interfaces. If the neighboring interface is set to the access or non-negotiate mode, the link will become a non-trunking link.

switchport mode dynamic auto – This command makes the interface willing to convert the link to a trunk link if the neighboring interface is set to trunk or desirable mode. Otherwise, the link will become a non-trunking link.

sathyasav Thu, 10/13/2011 - 06:17

It should be a access port....I asked just like that..LOL

Any way it is a very deep discussion....very much useful for me...so one final question.Cant we enable the command switchport nonegiate on the port on which switchport mode dynamic auto and switchport mode dynamic desirable is set already?

SATHYA...

Actions

Login or Register to take actions

This Discussion

Posted October 10, 2011 at 10:24 AM
Stats:
Replies:24 Avg. Rating:
Views:2585 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard

Rank Username Points
1 15,007
2 8,150
3 7,730
4 7,083
5 6,742
Rank Username Points
165
82
70
69
55