×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Wireless 7925G registration through 3rd party WAP

Unanswered Question
Oct 12th, 2011
User Badges:

Trying to integrate UC560 (no wireless) with customer existing TrendNet TEW-637AP.

Setup (7925G)----->wireless------->(TEW-627AP)-------------->LAN------->UC560.

The 7925G will be on a different IP subnet than the Voice VLan for the UC560.

In reading CME documentation I understand that phone registration cannot be across the WAN.

I read that to mean across subnets.  Will this scenario work?  I do not see how the phone can register with the UC560.

I would hardcode the TFTP server in 7925G, still not seeing how this would work.

As always thanks for any help.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
ADAM CRISP Wed, 10/12/2011 - 14:00
User Badges:
  • Silver, 250 points or more

You should be OK, just make sure you have fixed up the following:


1. Sort the IP routing, making sure that the default gateway of the wireless network (if not the UC560) routes to the UC560 when trying to reach the SCCP listener interface (typically 10.1.1.1)

To confirm check for this command under telephony-services

ip source-address 10.1.1.1 port 2000


Also make sure the UC560 can route to the WLAN subnet.


2. Configure the DHCP server on the WLAN to offer option150 (and possibly 66) pointing towards the UC560.


3. The IP address you choose in 2. above is an IP interface on the UC560 that offers TFTP files. Somtimes CCA restricts this to a single interface and therefore IP address, so you may need to remove this restriction (or use the appropriate IP address)

eg

UC_560#show run | incl ip tftp

ip tftp source-interface vlan100

UC_560#


You're OK routing SCCP - but avoiding NAT is advised!


Adam

David Trad Wed, 10/12/2011 - 15:41
User Badges:
  • Gold, 750 points or more
  • Cisco Designated VIP,

    2013 Small Business

Hi There,


On-Top of what Adam has advised, it should be pointed out that you will not get any support for this type of topology, for starters the Wireless AP you are using may not support VLANing and work with the QoS that the 7925 would be expecting.. Second of all you should not expect to not get any troubles with this type of setup, it might work smoothly for a while, but I suspect that it will run into troubles and one of them is frequent drop-outs or the phone not registering properly, or call quality issues.


Given that the an AP541 is not that expensive it would have been cheaper and less of a headache to try and sell one of those and have the client run in a supported environment.


Cheers,



David.

tknapp Fri, 10/14/2011 - 07:29
User Badges:

THank you for the replies.  I have set it up, but I am getting one way audio.  Messed with port forwarding.

Wireless phone gets dial tone and will ring when called.  Wireless phone has no other audio.  Audio from Wireless phone can be heard on remote phone.  Again thanks for the help!

ADAM CRISP Fri, 10/14/2011 - 08:53
User Badges:
  • Silver, 250 points or more

Hi,

This is probaably because your wired IP telephones can't route traffic to the Wireless subnet,

If you don't want to fix the IP routing, then a quick workaround would be to mark the wireless phone as "teleworker" if using cca - or add the MTP keyword to the ephone in CLI.


Adam

tknapp Fri, 10/14/2011 - 11:15
User Badges:

MTP command broke audio from Wireless to Wired phones.  Also from wired to wireless phone.

To test routing issue.  I took a spare 508A and put it on the Data vlan only (192.168.10.x).  This is the network that the Wireless phone uses to get to UC560.  The wired phone on the 192.168.10.x works with wired phones on the 10.1.1.x network.  I get Audio both ways.   I also created another Wireless phone on the wireless network.  BOTH wireless phones work.  Audio bother ways.  You mentioned changing routing.  Could you please elaborate?  Either way thanks for the help.

ADAM CRISP Fri, 10/14/2011 - 11:28
User Badges:
  • Silver, 250 points or more

Ok. This surprises me a little.

Please can you let us know what the ip address ranges you are using?

I assume you have 10.1.1.0/24 for vlan 100 and 192.168.10.0/24 as the data vlan . What is the Ip subnet if the WLAN, and the ip addresses of the WLAN router ?

Please can you look to see whether there are ip access lists on vlan 100?

Adam


Sent from Cisco Technical Support iPhone App

tknapp Fri, 10/14/2011 - 12:08
User Badges:

Frst of all thank you for help with this ONE OFF.  I am actually learning more on this product than I thought possible.

Data is 192.168.10.x/24   Voice is 10.1.1.x/24.  The Wireless is across Data and on subnet 198.168.1.x.

This Data IP address of the WLAN router is 192.168.10.5, it is hard coded. The IP address of the Wireless section is 192.168.1.1 for the WLAN router. I just finished building IRB and Bridging the voice and data networks.  This just gave me the same condition. NO access list on VLAN 1 or 100.  I do not have Firewall feature turned on the UC5xx.  I have not saved the IRB config and will reboot the UC to get it back to the original config for customer.

ADAM CRISP Fri, 10/14/2011 - 12:51
User Badges:
  • Silver, 250 points or more

OK. I'm not sure where you're seeing the one way media. Was this working from wired to wireless, or the other way around ?

You shouldn't need to have to enable a IRB scenario.


On the UC, you should have a route statement, something like this


ip route 192.168.1.1 255.255.255.255 192.168.10.5

This means the UC knows how to reach 192.168.1.1 via 192.168.10.5


and on your Wireless router (192.168.1.1), you need to add a route the equivalent of

ip route 10.1.1.0 255.255.255.0 192.168.10.1


In order for this to work. 192.168.1.1 should be the default gateway for the wireless phone.

Configuring the MTP statement on the ephone of the Wireless phone should have sorted you out. This makes the media always bounce off the UC560, rather than allowing direct media flow between phones. We know that IP routing must be reasonable OK here, as you've managed to get the Wireless phone to register, Odd,


Make sure you Switch off NAT on the Wireless router for traffic from wireless phones to the 10.1.1.X network.......

tknapp Fri, 10/14/2011 - 12:57
User Badges:

Just got it working 5 minutes ago.

I moved the cable on the WLAN from INTENET to a regular port.  I also turned off the DHCP on the WLAN.  So now I just have a wireless hub on the network.  It works Great!   The INTERNET port has some firewall settings on it by default.  you cannot see them but they are there.   With the unit not working as a router I have full audio.  Again Thank you very much for all your help. 

ADAM CRISP Fri, 10/14/2011 - 13:03
User Badges:
  • Silver, 250 points or more

Phew!


Sent from Cisco Technical Support iPhone App

Actions

This Discussion