Supervisor monitor and recording intermittent CCX8.5

Unanswered Question
Oct 13th, 2011

System version: 8.5.1.11001-35  HA

New Call Center. No problems encountered during testing.

Today, 1st day of full call center activity. Desktop Monitoring.

Silent Monitoring seemed ok earlier, but now we mostly cannot do silent monitoring. Multiple Supervisors effected.

It appears to be intermittent, as we can jump in and out to monitor a certain agent for a period of time, then it will not allow us to do so anymore.

Closed and restarted CAD and CSD. Restarted Monitor service. Can't find rhyme or reason as to when/why it fails.

During failure, it can either sit there like it's in monitoring mode but there is no audio, or a message pops up after a short pause, indicating The Silent Monitor session failed and to check for proper IP phone, NIC card compatability etc. We know this is good, since we can Silent Monitor at times.

This occurs with every agent and Supervisor. Most times we cannot monitor (or record,) but sometimes we can.

The question is - why is this intermittent and what can we check?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (1 ratings)
frzhang Mon, 10/17/2011 - 12:15

Suggest:

1. patch the UCCX to 8.5(1)SU2 as many monitoring recording related defects were fixed in there.

2. make sure CSD/CAD are the correct version

3. no shared lines on IPCC extension or non-IPCC extension (this is fixed in SU2)

metalium2007 Mon, 12/12/2011 - 07:06

Hello,

I've got the same problem as David.

1. Already patched to 8.5(1)SU2;

2. CSD and CAD from server;

3. I've got no shared lines on this solution.

Any news about this?

(Some agents get monitored well in the morning, then stop in the afternoon...intermittent stuff like this)..

Thank you!

met

Andrei Fokin Mon, 12/12/2011 - 07:28

I see this problem too at my lab UCCX. Silent monitoring don't work.

UCCX version 8.5.1.11002-22

davidblair Tue, 01/10/2012 - 08:07

I just did a new install with a customer that is experiencing dead air on recording/monitoring.

I also have another customer that was on 8.5.1.110002-22 with working recordings, I upgraded them with the critical patch to resolve an issue with scripts being able to save files, and it knocked out their recording and monitoring.

My lab environment is on the same version but might not be a good test case, I see that the RecMonFixes patch and the crit patch for SU1 are still on the active partition despite being on SU2 now.

I checked the bug toolkit but didn't see anything matching. Wondering if this is a known issue and not open to the public or what...

jsantos61 Tue, 02/07/2012 - 15:08

Anyone got any update on this? I'm running into the same issue with a customer. CSDs can monitor agents sometimes but not always.

anchoudh Tue, 02/07/2012 - 21:28

Please see if you have two NIC cards configured in the CSD box, if so select the correct NIC (or ip address) which is daisy-chianed with the ip phone.

On the CSD box, go to

C:\Program Files\Cisco\Desktop\bin, open the "PostInstall.exe", make sure that the primary and secondary UCCX have the correct ip addresses incase of UCCX HA deployment, click OK than under VOIP monitor service select the proper ip which is used for daisy chaining with the ip phone.

Hope it helps.

Anand

davidblair Wed, 02/08/2012 - 06:21

I'm going to reply back to this with all the scenarios I've encountered in the latest version (8.5.1 SU2) and what to watch for. It's a shame there's so many places where a point of failure can occur and there's no tool that can check connectivity between two points and tell you where the break might be...

In a monitoring scenario you're looking at:

Gateway Call -> Agent Phone -> Agent PC NIC -> Agent Desktop Software -> Dynamically Created Port on Agent PC -> Dynamically Created Port on Supervisor PC.

The only major difference on recording is the audio traffic is sent to the CCX server instead of the Supervisor's PC.

Things I've encountered (going left to right on the flow above):

  • Make sure the call isn't in g722. CCX cannot monitor or record these, they will become dead air. Double click the info button on the agent phone during a call and see if the rtp stream is in a good format.
  • No shared lines on the agent phone. frzhang says that SU2 fixes an issue so that you can use shared lines for the non-ACD line, but I haven't tried it.
  • Make sure "PC Voice VLAN Access" is enabled on the phone config page in Call Manager.
  • Agent PC plugged directly into Agent IP Phone.
  • Do what Anand says and use PostInstall.exe to make sure the correct network card is being monitored on the Agent PC.
  • Use a tool like PromiscDetect to make sure the Agent PC NIC is going into promiscuous mode during monitoring. (older NICs seem to have this issue, not seeing it much anymore)
  • Make sure there's nothing on the Agent PC or Supervisor PC blocking CAD/CSD from creating dynamic ports. My three big culprits are always Windows Firewall missing the CAD exception, Cisco VPN Stateful Firewall, AT&T Stateful Firewall. (The last two come with VPN products and will look like network connectivity issues while you're troubleshooting, on Supervisor machines they'll make Agents blink in and out of existence on the software)
  • On the Supervisor in the Record Viewer, make sure the sound is turned up on the slider at the top of the window. (It's true)
  • On the CCX server under Desktop Administrator (the web interface) make sure that a default Recording server is selected. I have found that applying the SU2 crit cop file after having this set will blank it back out, so you'll need to reselect it. (my message earlier in the thread was this issue)

That should cover just about everything. If this helps at least one person, I'll be happy.

DB

jsantos61 Wed, 02/15/2012 - 17:28

Thanks for the recommendations but I did have eveything setup as needed.  I did eventually open up a TAC case and got it fixed for now. It turned out to be a bug and the fix was to get some DLL and the agent.exe files from Cisco and put those in place of the ones on the agent PCs and that seemed to have fixed it. Good thing this customer didn't have that many agents. TAC says it'll be on the next patch/update...

davidblair Thu, 02/16/2012 - 05:09

Ugh. Psuedo-patching. Sorry to hear that. I question if Calabrio will ever get this product stable...

Rendy.Kumala Sun, 02/19/2012 - 20:53

Hi jsantos, can you share the files you got from TAC? i got into the same issue after migrated to 8.5(1)SU2.

rgonzalez@landa... Thu, 11/22/2012 - 03:24

Hlello Could you tell me the number of the case that you opened in cisco for this problem?

I have the same problem with ccx 8.5.1 su3 and I would like reference to your case so the engineer could use like clue.

Thanks a lot

atulkaul1985 Fri, 03/08/2013 - 03:25

Hi,

I am facing the same issue after migrating CXX to 8.5.1 SU2. Can you please share the files (DLL and the agent.exe files)?

Looking forward for your reply.

atulkaul1985 Fri, 03/08/2013 - 03:42

Hi,

Actually my issue is a bit different. When I try to see recording files from CSD, it gives me the error that "No recorded files for this day". Please find the screenshot below.

If you share the files that you got from the TAC, I will try uploading the same. It might be the same fix as you.

Erick Bergquist Fri, 03/15/2013 - 07:33

David,

Do you happen to know the port ranges that are used for the dynamic ports used for silient monitoring between agent and supervisor PC?   I had the cisco document for that at one point, but can't find it at the moment and am having similar intermintent issues somewhere. The document I recall might have been for older version to and not 8.5 and I believe there are some port changes between older versions and 8.x.

Thanks

Erick Bergquist Mon, 03/18/2013 - 08:23

Thanks David, for some reason I could locate that the other day.

Ever run across this one,

UCCX 8.5.1 SU3 w/CUCM 8.6.2 SU2. 7942G model phones with 9-2-3S firmware.

Phones set up right. 1st line is personal line, 2nd line agent line. No shared lines.

Firewalls already uninstalled amd windows firewall disabled on PCs for now.

Supervisors can't monitor some agents, get pop up error dialog sometimes. Some agents they can monitor now and then, but not the next call. Some agents they can't monitor at all on some days but if they close CAD and restart CAD then those agents can be monitored.

The PCs are Windows 7 32 bit, and CAD version is correct. Wireshark shows RTP stream captured on their network card, the promiscous detect tool shows network card is in that mode when monitoring.

Ever seen where quiiting CAD and re-runnning CAD fixes this issue?

The threshold setting in the config file is set to TRACE also.

I've gone through everything that can cause these problems, unless there is something in SU3 I'm not aware of. Thinking about trying SU4 but not seeing really anything there that is fixed monitoring/recording wise to cause this problem compared to earlier 8.5 releases.

UPDATE: Looks like this is bug CSCty92494 or CSCuc58786, both fixed in 8.5.1 SU4

davidblair Mon, 03/18/2013 - 10:51

I was gonna say, I have a customer that has intermittent monitoring, but they are running 64 bit Windows 7 which TAC told me was unsupported for Mon/Rec. I'm not sure how accurate that is though. I never thought to try having them restart agent.

What I do know is that Calabrio fixes things that don't show up in the Release Notes, and they have made quite a few fixes to Rec/Mon in SU3 that aren't listed. I'd suspect SU4 also has unlisted fixes.

SU4 has been very stable for my customers. I've had one that had to manually restart their mail subsystem, but that's been it.

Erick Bergquist Mon, 03/18/2013 - 11:51

Hmm, that is odd. I know in UCCX 8.0.2 64-bit Windows 7 isn't supported. The footnotes in the compatibility matrix state that. I haven't had TAC tell me that about windows 7 64 bit, and I've been through my share of TAC Cases on these issues on early 8.5 systems. The restarting of the agent is something this client found on their own that fixed the monitoring for awhile. The 8.5 mon/rec issues were so buggy early on, I made my own 8.5 mon/recording document to keep track of what all to do, check, and could be wrong.

Anyway, working on scheduling SU4 update at this customer.Hopefully it fixes it else I'll be updating this post with more info later.

Actions

Login or Register to take actions

This Discussion

Posted October 13, 2011 at 2:02 PM
Stats:
Replies:19 Avg. Rating:
Views:3146 Votes:0
Shares:0

Related Content

Discussions Leaderboard