ASA 5520 refuses to load 8.x code

Unanswered Question
Oct 18th, 2011

Hello,

As the subject suggests I have a ASA here that refuses to load 8.x code. I do not have an issue loading 7.x code at all. When I power on the ASA it does not pass the fsck.

Loading /asa842-k8.bin... Booting...
Platform ASA5520

Loading...
IO memory blocks requested from bigphys 32bit: 20848
dosfsck 2.11, 12 Mar 2005, FAT32, LFN

I have tried 8.0, 8.2, 8.3, 8.4 codes. I have also swapped RAM and flash.

Has anyone seen this before?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
mirober2 Fri, 10/21/2011 - 07:45

Hello,

Have you tried breaking into ROMMON and loading the image Via TFTP? When you do this the image is loaded directly from TFTP into memory, so if that works there may be a problem with the flash.

Also, double check the release notes and make sure your ASA meets the system requirements for the image you are trying to load:

http://www.cisco.com/en/US/products/ps6120/prod_release_notes_list.html

Hope that helps.

-Mike

kylerossd Sat, 11/05/2011 - 07:33

Thanks for the reply,  

I was also thinking that it could have been related to the flash, so I tried booting from TFTP.  This only produced the same result, and it hangs at dosfsck.

All of this still does not explain how it can still boot 7.x code from flash...

eliebassil Tue, 02/21/2012 - 01:17

Hello,

I am facing the same problem, were you able to solve yours?

kylerossd Tue, 02/21/2012 - 07:08

Hello Elie,

Unfortunately I was not able to resolve this issue.

Marvin Rhoads Tue, 02/21/2012 - 21:10

Have you tried some maintenance on the unused flash space? I'd have a go at the suggestions here (as applicable).

If that's to no avail, then a fresh download from cisco.com of the ASA software, preferably using a different system than the one you are curently using  - both for the download and tftp (or ftp). Since you've said you replaced the CF card, it's looking to be a problem further upstream.

Actions

Login or Register to take actions

This Discussion

Posted October 18, 2011 at 1:04 PM
Stats:
Replies:5 Avg. Rating:
Views:788 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard

Rank Username Points
1 7,866
2 6,140
3 3,170
4 1,473
5 1,446