Routed interface and vlan propagation

Answered Question
Oct 21st, 2011

Hi,

I'd like to configure a temporary design and I have somes questions about vlan utilization

I use 2 x 6500 chassis linked together and on each I have a link that goes to L2 switches.

                         6500-1 -----------------6500-2

                             |                        |

                             |                        |

                             |                        |

                         SW1-------------------SW2

Between the two chassis, I have a L2 interface with trunk.

On the first chassis, I have a etherchannel subinterface that is routed This interface is linked to the SW1. Here is the configuration:

interface Port-channel2.3061

description "Interco PFI-VPN ST"

encapsulation dot1Q 3061

ip vrf forwarding QUALIF

ip address 10.160.88.84 255.255.255.248

no ip proxy-arp

standby 61 ip 10.160.88.86

standby 61 timers 1 2

standby 61 priority 120

standby 61 preempt

arp timeout 300

On the second chassis, I have an SVI for the vlan 3061. The conf :

interface Vlan3061

description "Interco PFI-VPN ST"

ip vrf forwarding QUALIF

ip address 10.160.88.85 255.255.255.248

no ip proxy-arp

standby 61 ip 10.160.88.86

standby 61 timers 1 2

standby 61 preempt

arp timeout 300

end

The goal is to have a communication between both chassis on the vlan 3061 (with HSRP ).

On the 1st chassis, when I try to declare the vlan, I have the message :

VLAN id: 3061 is an internal vlan id - cannot use it to create a VTP VLAN.

An idea?

Thanks a lot!

Angelique

I have this problem too.
0 votes
Correct Answer by Jon Marshall about 2 years 6 months ago

Angelique

Okay, assuming the L2 switches are interconnected via a L2 trunk as well you should be able to -

6500_1 = core switch 1 (left hand side of your diagram)

6500_2 = core switch 2 (right hand side)

1) on the 6500_2 switch shutdown the port-channel interface. As long as the L2 switches are interconnected via trunk link then all the clients on the L2 switches will simply use 6500_1

2) create all your SVIs on the 6500_2 and configure the link to sw2 as a normal L2 etherchannel trunk.

3) bring up this L2 etherchannel trunk. HSRP messages should then be able to flow from 6500_2 via sw1 -> sw1 -> 6500_1

4) shutdown the port-channel on 6500_1. HSRP should now failover to 6500_2.

5) create L3 SVIs on 6500_1 and configure the link to sw2 as a normal L2 etherchannel trunk.

6) bring up the this L2 etherchannel trunk.

Note that once you have done this the HSRP messages will now go across the interconnect between the 2 6500 switches ie. they no longer need to go via sw1 -> sw2.

All of the above depends on there being a L2 trunk between sw1 and sw2 which i'm assuming there must be for HSRP to work as it is.

Jon

Correct Answer by Jon Marshall about 2 years 6 months ago

Angelique

This is to do with global vlan usage on the 6500/7600 switches. Basically you cannot have a vlan in the vlan database and use it on a dot1q interface. See this thread for more details -

https://supportforums.cisco.com/message/3447368#3447368

But i am confused by your config. Why are you using a subinterface on one 6500 and a L3 SVI on the other ?

Jon

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (2 ratings)
nkarpysh Fri, 10/21/2011 - 04:03

Hello,

When you created int po2.3061 it automatically assigned VLAN 3061 it as internal VLAN. Each L3 should have internal VLAN associated for forwarding logic. You can see that doing command "show vlan internal usage". I guess now to configure regular VLAN on first chassis you need to delete Po2.3061 first to release internal VLAN 3061.

Hope This Helps,

Nik

angedibartolo Fri, 10/21/2011 - 05:01

Hi,

Thanks for your reply.

But when I created first the vlan 3061 and then I declare the Po2.3061, I also have an error :

Command rejected: VLAN 3061 not available

Correct Answer
Jon Marshall Fri, 10/21/2011 - 05:46

Angelique

This is to do with global vlan usage on the 6500/7600 switches. Basically you cannot have a vlan in the vlan database and use it on a dot1q interface. See this thread for more details -

https://supportforums.cisco.com/message/3447368#3447368

But i am confused by your config. Why are you using a subinterface on one 6500 and a L3 SVI on the other ?

Jon

angedibartolo Fri, 10/21/2011 - 06:20

Hi Jon,

I have 2 different configurations because I'd like to do a migration, so it's just for few days.

Actually, I have on both chassis a etherchannel that goes to the switches and on it I have a lot of sub interfaces (port-channel subinterfaces). I use HSRP on theses etherchannels

During the migration, I'd like first to break one link between a chassis and a switch and plug a new link with SVI instead of port channels subinterfaces and I need to maintain HSRP through the link between the chassis.

Have you another idea?

Thanks

Jon Marshall Fri, 10/21/2011 - 06:31

Angelique

Actually, I have on both chassis a etherchannel that goes to the switches and on it I have a lot of sub interfaces (port-channel subinterfaces). I use HSRP on theses etherchannels

Not sure i follow. Each 6500 has an etherchannel trunk to it's respective L2 switch. And you run sibinterfaces with HSRP on these trunks ?

So how did you create the L3 SVI on the 2nd chassis from your config example above. Surely you would have got the same error message as you did on the first ?

Sorry if i'm being a bit slow

Jon

angedibartolo Fri, 10/21/2011 - 06:35

Not sure i follow. Each 6500 has an etherchannel trunk to it's  respective L2 switch. And you run sibinterfaces with HSRP on these  trunks ?

==> yes, I have HSRP on sub interfaces so the HSRP communication is through the L2 switches

So how did you create the L3 SVI on the 2nd chassis from your config  example above. Surely you would have got the same error message as you  did on the first ?

==> I just want to unokug the link, so delete the port-channel with the subinterfaces and to create SVI instead.

Sorry if i'm being a bit slow

==> It's difficult for me to explain and the exercise is harder for me because I'm french

Correct Answer
Jon Marshall Fri, 10/21/2011 - 06:45

Angelique

Okay, assuming the L2 switches are interconnected via a L2 trunk as well you should be able to -

6500_1 = core switch 1 (left hand side of your diagram)

6500_2 = core switch 2 (right hand side)

1) on the 6500_2 switch shutdown the port-channel interface. As long as the L2 switches are interconnected via trunk link then all the clients on the L2 switches will simply use 6500_1

2) create all your SVIs on the 6500_2 and configure the link to sw2 as a normal L2 etherchannel trunk.

3) bring up this L2 etherchannel trunk. HSRP messages should then be able to flow from 6500_2 via sw1 -> sw1 -> 6500_1

4) shutdown the port-channel on 6500_1. HSRP should now failover to 6500_2.

5) create L3 SVIs on 6500_1 and configure the link to sw2 as a normal L2 etherchannel trunk.

6) bring up the this L2 etherchannel trunk.

Note that once you have done this the HSRP messages will now go across the interconnect between the 2 6500 switches ie. they no longer need to go via sw1 -> sw2.

All of the above depends on there being a L2 trunk between sw1 and sw2 which i'm assuming there must be for HSRP to work as it is.

Jon

angedibartolo Sun, 10/23/2011 - 23:25

Hi Jon,

Thanks for your reply. I think that it's a good way to change my design. I just need to do it now.

Good job

Have a nice day.

Angélique

Actions

Login or Register to take actions

This Discussion

Posted October 21, 2011 at 2:28 AM
Stats:
Replies:8 Avg. Rating:5
Views:753 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard

Rank Username Points
1 15,012
2 8,155
3 7,745
4 7,088
5 6,752
Rank Username Points
135
88
80
74
38