Messaje error with IPPA

Answered Question
Oct 28th, 2011

Hello to all ,

I have a Cisco Contact Center Express witth IPPA ( there,s no PCs ) , the problem is with the new agents , they cant log in , the error message is below :

Unable to connect due to a configuration error (the phone is not associated with the user ID of the RM JTAPI provider)

I will appreciatte any help or advice !

Thanks and best regards

Hugo

I have this problem too.
0 votes
Correct Answer by Graham Old about 2 years 5 months ago

Hi Hugo

Just to confirm you have 9 phones for Agents to use and each phone has its own phone number.

When the Agent logs in to IP Phone Agent they use the phone number that is showing on the phone and it fails.

Graham

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (1 ratings)
hugomdbaez Fri, 10/28/2011 - 13:44

The version of UCCX is below

Cisco Application Administration - 7.0(2)_Build254

Package: Cisco Unified CCX Premium

Cluster: default

Copyright © 1999-2009 Cisco Systems, Inc.
All rights reserved.

Graham Old Sun, 10/30/2011 - 15:37

Login to UCCX appadmin

Go to Subsystems/RMCM then RmCm Provider, make a note of the user ID

Login to CUCM, goto User Management/Application User and find the user ID above.

Move the Agents phone from the list of "Available Devices" to "Controlled Devices" and click save.

The technical answer is UCCX can't control the Agents phone because it does not have permission as the Agents phone is not in the list of Controlled Devices

Graham

hugomdbaez Mon, 10/31/2011 - 05:25

Hello Graham ,

Thanks for the quick response . I am added the profiles to the application user and the error message still appears .

Do you know what the problem is ?

Thanks and best Regards

Hugo Baez

Graham Old Mon, 10/31/2011 - 05:34

Not the profile you must add the Agents phone by SEP..... name

Graham

hugomdbaez Mon, 10/31/2011 - 06:00

Hi Graham ,

Sorry but the error still appears

Thanks a lot !

Hugo Baez

hugomdbaez Mon, 10/31/2011 - 06:25
Hello Graham ,

I have some news , the new agents have only  a profile , no a Cisco IP Phone , If I must add a MAC ADDRESS to the RmCm  Provider I can not .

I have only one phone for the supervisor  agent  , I added this MAC ADDRESS and it is working .

The question is : The agent must  include a phone ?

Thanks and regards

Hugo Baez

Graham Old Mon, 10/31/2011 - 07:07

Hugo

The Agents must have a phone. Are they using the softphone IP Communicator?

When you added IP Communicator to CUCM you must have given it a name. You must add this name to the Rmcm user.

Graham

hugomdbaez Mon, 10/31/2011 - 07:35

Hi Graham ,

I will explain to you the situation :

I have 30 agents , with a new profile each , and only 9 Cisco IP Phones , with generic directory numbers .

The people that work here must log in ( there are a 7x24 site , there are day , and night shifts ) , the supervisor must take statistics about agents work .

I was realized a lot of test with a maqueta with 3 Cisco IP Phones , but with only a profile ( without phone ) does not work .

Can you help me ?

Thanks

Hugo Baez

Graham Old Mon, 10/31/2011 - 08:17

Hugo

So you have 9 physical phones and they are in the list of controlled devices for the RMCM user on CUCM

Are your Agents using Extension Mobility, do they first login to the phone so that their Directory Number shows on the phone?

Please confirm your Phone model and your UCCX version.

Graham

hugomdbaez Mon, 10/31/2011 - 10:21

Hi Graham ,

The service configured is Cisco IP Phone Agent ( IPPA ) , not extension mobility . whatever , I was realize some tests , with extension mobility and it was worked once , and no more .

I am trying to do again , and still fail .

The model of the testing Phone is Cisco 7942 , and the version of UCCX is

7.0(2)_Build254

Thanks

Hugo Baez

Correct Answer
Graham Old Tue, 11/01/2011 - 02:07

Hi Hugo

Just to confirm you have 9 phones for Agents to use and each phone has its own phone number.

When the Agent logs in to IP Phone Agent they use the phone number that is showing on the phone and it fails.

Graham

hugomdbaez Tue, 11/01/2011 - 08:28

Hello Graham ,

Each phone has your own generic number ( there are 9 ) . Each agent ( there are 30 , in day and night shifts , Its 7x24 schema  )  has a number ( a new number for each profile ) .

When I tried to log in with this new number and profile the log in fails .

Thanks for your help

Hugo

Graham Old Tue, 11/01/2011 - 08:49

Have you checked that all the "Allow Control of Device from CTI" Boxes are ticked on CUCM.

Phone, Device profile (on directory number) and on the user profile.

Also check that the rmcm application user has "Standard CTI Enabled" in the groups. Please double check that you are looking at the correct rmcm user ID.

Graham

brian1mcc Tue, 11/01/2011 - 09:37

Try adding device profiles to 'CTI Controlled Device Profiles' on the application user .. if they're not already there.

Brian

Actions

Login or Register to take actions

This Discussion

Posted October 28, 2011 at 12:51 PM
Stats:
Replies:15 Avg. Rating:5
Views:970 Votes:0
Shares:0

Related Content

Discussions Leaderboard