Show wrong time at 2811 router after every reboot

Answered Question
Oct 30th, 2011

I have configured 2811 router as ntp master.

But the router It self is not showing the proper time which i fixed up several times but after restarting the Voice Gateway it is becoming 10/20 minutes fast each time.

i have used those command at 2811

!

clock timezone BDT 6

ntp logging

ntp master

!

after that i set the clock time manualy.

so how can i fix this issue. Help needed.

Thanks

I have this problem too.
0 votes
Correct Answer by acampbell about 2 years 5 months ago

Hi,

On modern router you can fix the hardware clock.

Try this, just from the router enable prompt.

1)

clock set HH:MM:SS DD MMM YYYY

! This set the software clock to the time you want - usually the correct time where the router lives

2)

clock update-calendar

! This update the on board hardware clock to the time you have set in 1)

Now when you power off/on the router hopefully the clock in hardware should be reasonably accurate.

Loads of info re clocks etc here:-

http://www.cisco.com/en/US/docs/ios/12_2/configfun/configuration/guide/fcf012.html#wp1001598

HTH

Alex

Please rate useful posts

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (2 ratings)
barry@nettitude... Mon, 10/31/2011 - 01:53

Hi

Unless there is a good reason to run the gateway as an ntp master (i.e. you are using it to server time to other devices) I wouldn't configure it that way:

try:

no ntp master

ntp server

ntp server

Where x.x.x.x and y.y.y.y are available NTP Servers (e.g. Microsoft domain controllers or public Internet NTP Servers).

HTH. Barry

Correct Answer
acampbell Mon, 10/31/2011 - 03:23

Hi,

On modern router you can fix the hardware clock.

Try this, just from the router enable prompt.

1)

clock set HH:MM:SS DD MMM YYYY

! This set the software clock to the time you want - usually the correct time where the router lives

2)

clock update-calendar

! This update the on board hardware clock to the time you have set in 1)

Now when you power off/on the router hopefully the clock in hardware should be reasonably accurate.

Loads of info re clocks etc here:-

http://www.cisco.com/en/US/docs/ios/12_2/configfun/configuration/guide/fcf012.html#wp1001598

HTH

Alex

Please rate useful posts

Leo Laohoo Tue, 11/01/2011 - 21:58

Ummm ... I would never set any of my Cisco appliance as an authoritative NTP box.  The reason is the hardware is not designed to be one.  Setting up the clock, is OK but you'll see that the time will not be accurate.

You have two choices:

1.  Why not get a dedicated NTP server?  Not the ones that advertise themselves as an "ntp server" but requires an internet access.  I'm talking about a TRUE NTP server that synchronizes itself to the GPS.  That way this appliance is inside your secure network.

2.  How to configure an authoritative  time server in Windows XP;

How to configure an authoritative  time server in Windows Server;

Actions

Login or Register to take actions

This Discussion

Posted October 30, 2011 at 10:29 PM
Stats:
Replies:4 Avg. Rating:5
Views:658 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard

Rank Username Points
1 21,031
2 15,047
3 10,325
4 8,014
5 4,856
Rank Username Points
126
105
98
57
56