PFC configuration on Nexus 5000

Unanswered Question
Nov 4th, 2011

Hi,

I have a CNA in my server connected to cisco nexus 5000 interfcae. I Want to genearate pause frames for FCOE class of traffic using the default class class-fcoe and cos value 3, the firmware version running is 5.0(3) N1 (1b). Can anyone tell me how can i configure it ?

Thanks,

Manju

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
prkrishn Fri, 11/04/2011 - 10:42

PFC is something which gets negotiated automatically during initial LLDP handshake. Is it not happenning in your case?

mhosamani Mon, 11/07/2011 - 20:42

No its not happening and i dont see any configuration as such over the switch interface i am connected to, can you tell me how can i configure it manually ?

prkrishn Fri, 11/11/2011 - 06:18

I suggest that you focus on why its not negotiated via LLDP. Can you attach output of following commands from the switch which connects to the CNA?

show mod

show run

show system internal dcbx info interface ethernet x/y

Also if your switch is 55xx model, make sure you have FCOE QoS configured.

switch (config-sys-qos)# service-policy type qos input fcoe-default-in-policy

switch (config-sys-qos)# service-policy type queuing inputfcoe-default-in-policy

switch (config-sys-qos)# service-policy type queuing output fcoe-default-out-policy

switch (config-sys-qos)# service-policy type network-qos fcoe-default-nq-policy

mhosamani Thu, 12/01/2011 - 00:53

Sorry for the delayed response, Here is what you asked

Cisco-5020# sh mod

Mod Ports  Module-Type                      Model                  Status

--- -----  -------------------------------- ---------------------- ------------

1    40     40x10GE/Supervisor               N5K-C5020P-BF-SUP      active *

2    8      4x10GE + 4x1/2/4G FC Module      N5K-M1404              ok

Mod  Sw              Hw      World-Wide-Name(s) (WWN)

---  --------------  ------  --------------------------------------------------

1    5.0(3)N1(1b)    1.2     --

2    5.0(3)N1(1b)    1.0     20:41:00:0d:ec:b2:15:40 to 20:44:00:0d:ec:b2:15:40

Mod  MAC-Address(es)                         Serial-Num

---  --------------------------------------  ----------

1    000d.ecb2.1548 to 000d.ecb2.156f         JAF1303ACES

2    000d.ecb2.1570 to 000d.ecb2.1577         JAF1245AJLF

Cisco-5020#

Cisco-5020#

Cisco-5020# sh run

!Command: show running-config

!Time: Fri Oct 28 17:40:02 2005

version 5.0(3)N1(1b)

feature fcoe

feature npiv

feature telnet

feature lldp

username admin password 5 $1$v9Tm8Y77$ZSdbOfBxe1.Z9Oz1V9V2B0  role network-admin

no password strength-check

ip domain-lookup

hostname Cisco-5020

logging event link-status default

service unsupported-transceiver

class-map type qos class-fcoe

class-map type queuing class-all-flood

  match qos-group 2

class-map type queuing class-ip-multicast

  match qos-group 2

class-map type network-qos class-all-flood

  match qos-group 2

class-map type network-qos class-ip-multicast

  match qos-group 2

policy-map type network-qos jumbo

  class type network-qos class-fcoe

    pause no-drop

    mtu 2158

  class type network-qos class-default

    mtu 9216

system qos

  service-policy type network-qos jumbo

snmp-server user admin network-admin auth md5 0x2694501fdfbe5abed9e85d51e4e31038 priv 0x2694501fdfbe5abed9e85d51e4e31038 localizedkey

snmp-server host 138.239.198.184 traps version 2c public  udp-port 1163

snmp-server host 138.239.198.184 traps version 2c public  udp-port 1164

snmp-server host 138.239.198.200 traps version 2c public  udp-port 1163

snmp-server host 138.239.198.200 traps version 2c public  udp-port 1164

snmp-server host 138.239.200.118 traps version 2c public  udp-port 1163

snmp-server host 138.239.198.200 traps version 2c public  udp-port 1163

snmp-server enable traps entity fru

snmp-server community snmpv3 group network-operator

vrf context management

  ip route 0.0.0.0/0 10.192.207.254

vlan 1-2,8

vlan 10

  fcoe vsan 10

vlan 20

  fcoe vsan 20

vlan 30

vlan 35

  fcoe vsan 35

vlan 40,50

vlan 52

  fcoe vsan 52

vsan database

  vsan 20

  vsan 52

fcdomain fcid database

  vsan 52 wwn 10:00:00:00:c9:b1:e5:3d fcid 0x180000 dynamic

  vsan 52 wwn 10:00:00:00:c9:b1:e5:3b fcid 0x180001 dynamic

  vsan 52 wwn 10:00:00:00:c9:5b:4d:e3 fcid 0x180002 dynamic

  vsan 52 wwn 10:00:00:00:c9:5b:ab:ad fcid 0x180003 dynamic

  vsan 52 wwn 10:00:00:00:c9:ad:ac:41 fcid 0x180004 dynamic

  vsan 52 wwn 10:00:00:00:c9:ad:ac:b9 fcid 0x180005 dynamic

  vsan 52 wwn 10:00:00:00:c9:ad:ac:b5 fcid 0x180006 dynamic

  vsan 52 wwn 10:00:00:00:c9:f2:73:d1 fcid 0x180007 dynamic

  vsan 52 wwn 10:00:00:00:c9:5b:4d:e1 fcid 0x180008 dynamic

  vsan 52 wwn 10:00:00:00:c9:5b:ab:a9 fcid 0x180009 dynamic

  vsan 52 wwn 10:00:00:00:c9:f2:73:d5 fcid 0x18000a dynamic

  vsan 52 wwn 10:00:00:00:c9:b1:e5:5d fcid 0x18000b dynamic

  vsan 52 wwn 10:00:00:00:c9:5b:ab:9b fcid 0x18000c dynamic

  vsan 52 wwn 10:00:00:00:c9:5b:ab:99 fcid 0x18000d dynamic

  vsan 52 wwn 10:00:00:00:c9:b1:e5:5b fcid 0x18000e dynamic

  vsan 1 wwn 10:00:00:00:c9:f2:73:b3 fcid 0x050000 dynamic

  vsan 52 wwn 10:00:00:00:c9:ad:ac:47 fcid 0x18000f dynamic

  vsan 52 wwn 10:00:00:00:c9:5b:a7:93 fcid 0x180010 dynamic

  vsan 52 wwn 10:00:00:00:c9:91:f8:19 fcid 0x180011 dynamic

  vsan 52 wwn 10:00:00:00:c9:9c:e0:77 fcid 0x180012 dynamic

  vsan 52 wwn 10:00:00:00:c9:5b:a7:d3 fcid 0x180013 dynamic

  vsan 52 wwn 10:00:00:00:c9:5b:a3:bb fcid 0x180014 dynamic

  vsan 52 wwn 10:00:00:00:c9:97:3b:c5 fcid 0x180015 dynamic

  vsan 52 wwn 10:00:00:00:c9:f2:73:91 fcid 0x180016 dynamic

  vsan 52 wwn 10:00:00:00:c9:a4:00:91 fcid 0x180017 dynamic

  vsan 52 wwn 10:00:00:00:c9:f2:73:8d fcid 0x180018 dynamic

  vsan 52 wwn 20:0f:00:11:0d:7f:a8:00 fcid 0x180019 dynamic

  vsan 52 wwn 20:0f:00:11:0d:7f:a8:01 fcid 0x18001a dynamic

  vsan 52 wwn 10:00:00:00:c9:5b:a3:b7 fcid 0x18001b dynamic

  vsan 52 wwn 10:00:00:00:c9:5b:a5:27 fcid 0x18001c dynamic

  vsan 52 wwn 10:00:00:00:c9:5b:a3:53 fcid 0x18001d dynamic

  vsan 52 wwn 10:00:00:00:c9:bb:c8:37 fcid 0x18001e dynamic

  vsan 52 wwn 10:00:00:00:c9:5b:76:e5 fcid 0x18001f dynamic

  vsan 20 wwn 10:00:00:00:c9:5b:a3:83 fcid 0xd30000 dynamic

  vsan 52 wwn 10:00:00:00:c9:91:00:00 fcid 0x180020 dynamic

  vsan 52 wwn 10:00:00:00:00:91:f7:f1 fcid 0x180021 dynamic

  vsan 1 wwn 10:00:00:00:c9:5b:4d:e3 fcid 0x050001 dynamic

  vsan 52 wwn 10:00:00:00:c9:97:3b:0f fcid 0x180022 dynamic

  vsan 52 wwn 10:00:00:00:c9:3c:8e:21 fcid 0x180023 dynamic

  vsan 52 wwn 10:00:00:00:c9:97:3b:11 fcid 0x180024 dynamic

  vsan 20 wwn 10:00:00:00:c9:b1:e6:b7 fcid 0xd30001 dynamic

  vsan 52 wwn 10:00:f8:19:00:91:f8:19 fcid 0x180025 dynamic

  vsan 52 wwn 10:00:00:00:c9:5b:a3:8b fcid 0x180026 dynamic

  vsan 52 wwn 10:00:00:00:c9:b1:e4:ff fcid 0x180027 dynamic

  vsan 52 wwn 10:00:00:00:c9:3c:8e:25 fcid 0x180028 dynamic

  vsan 52 wwn 50:06:01:61:44:60:23:4f fcid 0x1800ef dynamic

  vsan 52 wwn 10:00:00:00:c9:5b:d6:b9 fcid 0x180029 dynamic

  vsan 52 wwn 10:00:00:00:c9:ad:ac:43 fcid 0x18002a dynamic

  vsan 52 wwn 20:01:00:00:c9:5b:ab:99 fcid 0x18002b dynamic

  vsan 52 wwn 20:02:00:00:c9:5b:ab:99 fcid 0x18002c dynamic

  vsan 52 wwn 50:06:01:60:44:60:23:4f fcid 0x1801ef dynamic

  vsan 52 wwn 10:00:00:00:c9:9d:1f:bf fcid 0x18002d dynamic

  vsan 52 wwn 10:00:00:00:c9:9d:1f:c1 fcid 0x18002e dynamic

  vsan 52 wwn 10:00:00:00:c9:f2:73:d3 fcid 0x18002f dynamic

  vsan 20 wwn 10:00:00:00:c9:bb:c8:37 fcid 0xd30002 dynamic

  vsan 52 wwn 10:00:00:00:c9:12:34:56 fcid 0x180030 dynamic

  vsan 52 wwn 10:00:00:00:c9:12:34:57 fcid 0x180031 dynamic

  vsan 52 wwn 10:00:00:00:c9:b1:ea:81 fcid 0x180032 dynamic

  vsan 52 wwn 10:00:00:00:c9:b1:ea:7f fcid 0x180033 dynamic

  vsan 20 wwn 10:00:00:00:c9:12:34:56 fcid 0xd30003 dynamic

  vsan 52 wwn 10:00:00:00:c9:b1:e5:1b fcid 0x180034 dynamic

  vsan 52 wwn 10:00:00:00:c9:b1:e5:1d fcid 0x180035 dynamic

  vsan 52 wwn 10:00:00:00:c9:bb:c7:8f fcid 0x180036 dynamic

  vsan 52 wwn 10:00:00:00:c9:bb:cb:8f fcid 0x180037 dynamic

  vsan 52 wwn 10:00:00:00:c9:bb:cb:93 fcid 0x180038 dynamic

  vsan 52 wwn 10:00:00:00:c9:bb:c7:93 fcid 0x180039 dynamic

  vsan 20 wwn 10:00:00:00:c9:12:34:57 fcid 0xd30004 dynamic

  vsan 52 wwn 10:00:00:00:c9:5b:ab:c4 fcid 0x18003a dynamic

  vsan 52 wwn 10:00:00:00:c9:bb:17:b7 fcid 0x18003b dynamic

  vsan 52 wwn 10:00:00:00:c9:a0:ce:2d fcid 0x18003c dynamic

  vsan 52 wwn 10:00:00:00:c9:91:f7:f1 fcid 0x18003d dynamic

  vsan 52 wwn 10:00:00:00:c9:5b:ab:c0 fcid 0x18003e dynamic

  vsan 52 wwn 10:00:00:00:c9:b1:e5:5f fcid 0x18003f dynamic

  vsan 52 wwn 10:00:00:00:c9:e3:06:89 fcid 0x180040 dynamic

  vsan 52 wwn 50:06:01:68:44:60:23:4f fcid 0x1802ef dynamic

  vsan 1 wwn 50:06:01:61:44:60:23:4f fcid 0x0500ef dynamic

  vsan 52 wwn 10:00:00:00:c9:d1:16:24 fcid 0x180041 dynamic

  vsan 52 wwn 10:00:00:00:c9:d1:16:25 fcid 0x180042 dynamic

  vsan 52 wwn 10:00:00:00:c9:d1:0a:6d fcid 0x180043 dynamic

  vsan 20 wwn 10:00:00:00:c9:d1:16:25 fcid 0xd30005 dynamic

  vsan 20 wwn 10:00:00:00:c9:d1:16:24 fcid 0xd30006 dynamic

  vsan 20 wwn ff:f2:00:00:c9:12:34:78 fcid 0xd30007 dynamic

  vsan 20 wwn ff:f2:00:00:c9:d1:16:46 fcid 0xd30008 dynamic

  vsan 52 wwn ff:f2:00:00:c9:d1:0a:8c fcid 0x180044 dynamic

  vsan 20 wwn ff:f3:00:00:c9:d1:16:46 fcid 0xd30009 dynamic

  vsan 52 wwn ff:f0:00:00:c9:d1:0a:8c fcid 0x180045 dynamic

  vsan 52 wwn 10:00:00:00:c9:d1:0a:6c fcid 0x180046 dynamic

  vsan 20 wwn ff:f2:00:00:c9:d1:0a:8c fcid 0xd3000a dynamic

  vsan 20 wwn 10:00:00:00:c9:d1:0a:6d fcid 0xd3000b dynamic

  vsan 52 wwn ff:f2:00:00:c9:d1:16:46 fcid 0x180047 dynamic

  vsan 20 wwn ff:f3:00:00:c9:12:34:78 fcid 0xd3000c dynamic

  vsan 52 wwn ff:f3:00:00:c9:12:34:78 fcid 0x180048 dynamic

  vsan 52 wwn 50:06:01:69:44:60:23:4f fcid 0x1803ef dynamic

  vsan 52 wwn ff:f3:00:00:c9:d1:16:46 fcid 0x180049 dynamic

  vsan 52 wwn 10:00:00:00:c9:12:34:5b fcid 0x18004a dynamic

  vsan 52 wwn 10:00:00:00:c9:12:34:5a fcid 0x18004b dynamic

  vsan 52 wwn ff:f2:00:00:c9:12:34:78 fcid 0x18004c dynamic

  vsan 52 wwn 10:00:00:00:c9:a5:ac:f3 fcid 0x18004d dynamic

  vsan 52 wwn 10:00:00:00:c9:a5:ad:15 fcid 0x18004e dynamic

  vsan 52 wwn 10:00:00:00:c9:a5:ac:f5 fcid 0x18004f dynamic

  vsan 52 wwn 20:01:00:00:c9:a5:ac:f3 fcid 0x180050 dynamic

  vsan 52 wwn 20:02:00:00:c9:a5:ac:f3 fcid 0x180051 dynamic

  vsan 52 wwn ff:f3:00:00:c9:12:34:85 fcid 0x180052 dynamic

  vsan 52 wwn 20:00:00:11:0d:77:9c:00 fcid 0x180053 dynamic

  vsan 52 wwn 20:01:00:11:0d:77:9d:00 fcid 0x180054 dynamic

interface port-channel3

interface vfc1

  no shutdown

interface vfc4

interface vfc9

  bind interface Ethernet1/9

  no shutdown

interface vfc10

interface vfc11

  bind interface Ethernet1/11

  no shutdown

interface vfc19

  bind interface Ethernet1/19

  no shutdown

interface vfc21

  bind interface Ethernet1/21

  no shutdown

interface vfc22

  bind interface Ethernet1/22

  switchport trunk allowed vsan 52

  no shutdown

interface vfc24

  bind interface Ethernet1/24

  switchport trunk allowed vsan 52

  no shutdown

interface vfc25

  bind interface Ethernet1/25

  switchport trunk allowed vsan 52

  no shutdown

interface vfc26

  bind interface Ethernet1/26

  switchport trunk allowed vsan 52

  no shutdown

interface vfc27

  bind interface Ethernet1/27

  no shutdown

interface vfc28

  bind interface Ethernet1/28

  no shutdown

interface vfc29

  bind interface Ethernet1/29

  no shutdown

interface vfc30

  bind interface Ethernet1/30

  switchport trunk allowed vsan 52

  no shutdown

interface vfc31

  bind interface Ethernet1/31

  shutdown

interface vfc32

  bind interface Ethernet1/32

  no shutdown

interface vfc33

  bind interface Ethernet1/33

  no shutdown

interface vfc34

  bind interface Ethernet1/34

  no shutdown

interface vfc35

  bind interface Ethernet1/35

  no shutdown

interface vfc36

  bind interface Ethernet1/36

  no shutdown

interface vfc37

  bind interface Ethernet1/37

  no shutdown

interface vfc38

  bind interface Ethernet1/38

  no shutdown

interface vfc39

  bind interface Ethernet1/39

  no shutdown

interface vfc40

  bind interface Ethernet1/40

  no shutdown

vsan database

  vsan 52 interface vfc1

  vsan 52 interface vfc9

  vsan 52 interface vfc11

  vsan 52 interface vfc19

  vsan 52 interface vfc21

  vsan 52 interface vfc22

  vsan 52 interface vfc24

  vsan 52 interface vfc26

  vsan 52 interface vfc27

  vsan 52 interface vfc28

  vsan 52 interface vfc29

  vsan 52 interface vfc30

  vsan 52 interface vfc31

  vsan 52 interface vfc32

  vsan 52 interface vfc33

  vsan 52 interface vfc34

  vsan 20 interface vfc35

  vsan 52 interface vfc36

  vsan 52 interface vfc37

  vsan 52 interface vfc38

  vsan 52 interface vfc39

  vsan 52 interface vfc40

  vsan 52 interface fc2/1

  vsan 52 interface fc2/2

  vsan 52 interface fc2/3

  vsan 52 interface fc2/4

interface fc2/1

  switchport trunk allowed vsan 1

  switchport trunk allowed vsan add 52

  switchport trunk mode auto

  no shutdown

interface fc2/2

  switchport trunk mode auto

  no shutdown

interface fc2/3

  no shutdown

interface fc2/4

  no shutdown

interface Ethernet1/1

interface Ethernet1/2

  speed 1000

interface Ethernet1/3

interface Ethernet1/4

interface Ethernet1/5

interface Ethernet1/6

interface Ethernet1/7

  switchport mode trunk

interface Ethernet1/8

interface Ethernet1/9

  switchport mode trunk

  switchport trunk allowed vlan 1,10,20,52

  flowcontrol receive on

  flowcontrol send on

interface Ethernet1/10

interface Ethernet1/11

  priority-flow-control mode on

  switchport mode trunk

  switchport trunk allowed vlan 1,52

  flowcontrol receive on

  flowcontrol send on

interface Ethernet1/12

  switchport mode trunk

interface Ethernet1/13

  switchport mode trunk

  flowcontrol receive on

  flowcontrol send on

interface Ethernet1/14

  switchport mode trunk

  flowcontrol receive on

  flowcontrol send on

interface Ethernet1/15

  switchport mode trunk

  flowcontrol receive on

  flowcontrol send on

interface Ethernet1/16

  switchport mode trunk

  flowcontrol receive on

  flowcontrol send on

interface Ethernet1/17

interface Ethernet1/18

  switchport mode trunk

  switchport trunk allowed vlan 1,30

interface Ethernet1/19

  switchport mode trunk

  switchport access vlan 10

  switchport trunk allowed vlan 1,52

  flowcontrol receive on

  flowcontrol send on

interface Ethernet1/20

  switchport mode trunk

  switchport access vlan 52

  switchport trunk allowed vlan 1,52

  flowcontrol receive on

  flowcontrol send on

interface Ethernet1/21

  switchport mode trunk

  switchport trunk allowed vlan 1,52

  flowcontrol receive on

  flowcontrol send on

interface Ethernet1/22

interface Ethernet1/23

  flowcontrol receive on

  flowcontrol send on

interface Ethernet1/24

  switchport mode trunk

  switchport access vlan 52

  switchport trunk allowed vlan 1,52

  flowcontrol receive on

  flowcontrol send on

interface Ethernet1/25

  switchport mode trunk

  switchport trunk allowed vlan 1,8,30,52

interface Ethernet1/26

  switchport mode trunk

  switchport access vlan 52

  switchport trunk allowed vlan 1,8,30,52

interface Ethernet1/27

  switchport mode trunk

  flowcontrol receive on

  flowcontrol send on

interface Ethernet1/28

  switchport mode trunk

  switchport trunk allowed vlan 1,8,30,52

  flowcontrol receive on

  flowcontrol send on

interface Ethernet1/29

  switchport mode trunk

  switchport trunk allowed vlan 1,52

  flowcontrol receive on

  flowcontrol send on

interface Ethernet1/30

  description line

  switchport mode trunk

  switchport access vlan 52

  switchport trunk allowed vlan 1,8,30,52

  flowcontrol receive on

  flowcontrol send on

interface Ethernet1/31

  switchport mode trunk

  switchport trunk allowed vlan 1,10,20,52

interface Ethernet1/32

  switchport mode trunk

  switchport trunk allowed vlan 1,10,52

  flowcontrol receive on

  flowcontrol send on

interface Ethernet1/33

  switchport mode trunk

  switchport trunk allowed vlan 1,52

  flowcontrol receive on

  flowcontrol send on

interface Ethernet1/34

  switchport mode trunk

  switchport trunk allowed vlan 1,52

  flowcontrol receive on

  flowcontrol send on

interface Ethernet1/35

  switchport mode trunk

  switchport access vlan 10

  switchport trunk allowed vlan 1,10,52

  flowcontrol receive on

  flowcontrol send on

interface Ethernet1/36

  switchport mode trunk

  switchport trunk allowed vlan 1,30,52

  flowcontrol receive on

  flowcontrol send on

interface Ethernet1/37

  switchport mode trunk

  switchport trunk allowed vlan 1,30,52

  flowcontrol receive on

  flowcontrol send on

interface Ethernet1/38

  switchport mode trunk

  switchport trunk allowed vlan 1,10,52

  flowcontrol receive on

  flowcontrol send on

interface Ethernet1/39

  shutdown

  switchport mode trunk

  switchport trunk allowed vlan 1,10,20,52

  flowcontrol receive on

  flowcontrol send on

interface Ethernet1/40

  switchport mode trunk

  switchport trunk allowed vlan 1,52

  flowcontrol receive on

  flowcontrol send on

interface Ethernet2/1

  switchport mode trunk

  flowcontrol receive on

  flowcontrol send on

interface Ethernet2/2

  switchport mode trunk

  flowcontrol receive on

  flowcontrol send on

interface Ethernet2/3

  switchport mode trunk

  flowcontrol receive on

  flowcontrol send on

interface Ethernet2/4

  switchport mode trunk

  flowcontrol receive on

  flowcontrol send on

interface mgmt0

  ip address 10.192.194.111/20

system default zone default-zone permit

system default zone distribute full

line console

line vty

boot kickstart bootflash:/n5000-uk9-kickstart.5.0.3.N1.1b.bin

boot system bootflash:/n5000-uk9.5.0.3.N1.1b.bin

interface fc2/1

interface fc2/2

interface fc2/3

interface fc2/4

zone default-zone permit vsan 20

zone default-zone permit vsan 52

zoneset distribute full vsan 1

zoneset distribute full vsan 20

zoneset distribute full vsan 52

!Full Zone Database Section for vsan 1

zone name bg-qa vsan 1

    member pwwn 10:00:00:00:c9:5b:ab:ca

    member pwwn 21:00:00:0c:50:c3:70:23

    member pwwn 21:00:00:0c:50:c3:70:22

    member pwwn 21:00:00:0c:50:c3:70:16

    member pwwn 21:00:00:0c:50:c3:70:1e

    member pwwn 22:00:00:0c:50:c3:70:26

    member pwwn 22:00:00:18:62:06:76:8a

    member pwwn 22:00:00:11:c6:17:68:c3

    member pwwn 22:00:00:0c:50:c3:70:1d

    member pwwn 22:00:00:0c:50:c3:6f:c2

    member pwwn 22:00:00:11:c6:17:68:dc

    member pwwn 21:00:00:0c:50:c3:6a:d0

    member pwwn 21:00:00:0c:50:79:92:90

    member pwwn 21:00:00:11:c6:17:69:a0

    member pwwn 21:00:00:0c:50:79:93:af

    member pwwn 22:00:00:0c:50:48:10:80

    member pwwn 22:00:00:11:c6:18:46:c6

    member pwwn 22:00:00:0c:50:32:2e:0f

    member pwwn 22:00:00:0c:50:48:10:74

    member pwwn 22:00:00:11:c6:18:46:f2

    member pwwn 21:00:00:00:87:13:cb:d1

    member pwwn 21:00:00:0c:50:79:91:0f

    member pwwn 10:00:00:00:c9:3c:8e:49

    member pwwn 10:00:00:00:c9:5b:ab:c2

    member pwwn 10:00:00:00:c9:5b:af:f3

zone name sf_RAM vsan 1

    member pwwn 10:00:00:00:c9:5b:af:c9

    member pwwn 21:00:00:0c:50:b4:8e:20

zone name anand vsan 1

    member pwwn 10:00:00:00:c9:65:69:31

    member pwwn 22:00:00:18:62:06:7f:f6

zone name syedzone vsan 1

    member fwwn 20:11:00:0d:ec:56:7b:40

    member pwwn 50:06:01:60:44:60:23:4f

zone name bg_qa vsan 1

zoneset name TOM vsan 1

    member bg-qa

zoneset name bg_dvt vsan 1

    member sf_RAM

zoneset name lancer vsan 1

    member anand

zoneset name bg-qa vsan 1

zoneset name syed vsan 1

    member syedzone

zoneset activate name lancer vsan 1

!Full Zone Database Section for vsan 20

zone name amrita_zone1 vsan 20

    member pwwn 10:00:00:00:c9:5b:a3:83

    member pwwn 22:00:00:04:cf:89:19:67

    member pwwn 22:00:00:0c:50:48:10:80

    member pwwn 22:00:00:11:c6:18:46:f2

    member pwwn 22:00:00:0c:50:79:93:ae

zone name amr_zset vsan 20

zoneset name amr_zset vsan 20

    member amrita_zone1

zoneset activate name amr_zset vsan 20

!Full Zone Database Section for vsan 52

zone name vinod vsan 52

    member pwwn 50:06:01:69:44:60:23:4f

    member pwwn ff:f3:00:00:c9:12:34:78

    member pwwn 10:00:00:00:c9:12:34:5b

    member pwwn 10:00:00:00:c9:12:34:57

zone name neha vsan 52

zone name siv1 vsan 52

    member pwwn 10:00:00:00:c9:ad:ac:43

    member pwwn 50:06:01:61:44:60:23:4f

    member pwwn 10:00:00:00:c9:ad:ac:47

zone name neha1 vsan 52

    member pwwn 10:00:00:00:c9:5b:ab:ad

    member pwwn 50:06:01:60:44:60:23:4f

zone name neha2 vsan 52

    member pwwn 50:06:01:60:44:60:23:4f

    member pwwn 10:00:00:00:c9:5b:ab:a9

zone name neha3 vsan 52

    member pwwn 10:00:00:00:c9:9d:1f:bf

    member pwwn 50:06:01:60:44:60:23:4f

zone name neha4 vsan 52

    member pwwn 50:06:01:60:44:60:23:4f

    member pwwn 10:00:00:00:c9:9d:1f:c1

zone name chetan vsan 52

    member pwwn 10:00:00:00:c9:f2:73:d3

    member pwwn 50:06:01:60:44:60:23:4f

    member pwwn 10:00:00:00:c9:ad:ac:47

zone name siv2 vsan 52

    member pwwn 10:00:00:00:c9:d1:0a:6d

    member pwwn ff:f2:00:00:c9:d1:0a:8c

    member pwwn 22:00:00:0c:50:79:93:af

    member pwwn 22:00:00:0c:50:79:92:90

    member pwwn 22:00:00:0c:50:79:91:0f

    member pwwn 20:01:00:11:0d:77:9d:00

zone name sroy vsan 52

    member pwwn 10:00:00:00:c9:b1:ea:7f

    member pwwn 50:06:01:60:44:60:23:4f

    member pwwn 10:00:00:00:c9:5b:ab:99

    member pwwn 10:00:00:00:c9:bb:cb:8f

    member pwwn 10:00:00:00:c9:5b:ab:c4

    member pwwn 10:00:00:00:c9:d1:16:25

    member pwwn 50:06:01:61:44:60:23:4f

    member pwwn 10:00:00:00:c9:a5:ac:f3

zone name manju vsan 52

    member pwwn 10:00:00:00:c9:bb:c7:8f

    member pwwn 50:06:01:61:44:60:23:4f

zone name ram vsan 52

    member pwwn 50:06:01:60:44:60:23:4f

    member pwwn 10:00:00:00:c9:a0:ce:2d

    member pwwn 10:00:00:00:c9:bb:17:b7

    member pwwn 10:00:00:00:c9:5b:a5:27

    member pwwn 10:00:00:00:c9:91:f7:f1

    member pwwn 10:00:00:00:c9:b1:e5:5f

zone name jana vsan 52

    member pwwn 10:00:00:00:c9:91:f7:f1

    member pwwn 50:06:01:60:44:60:23:4f

zone name priya vsan 52

    member pwwn 10:00:00:00:c9:e3:06:89

    member pwwn 50:06:01:60:44:60:23:4f

zoneset name IBMraptor vsan 52

    member vinod

    member siv1

    member neha1

    member neha2

    member neha3

    member neha4

    member chetan

    member siv2

    member sroy

    member manju

    member ram

    member priya

zoneset name ananda vsan 52

zoneset name vinod vsan 52

zoneset activate name IBMraptor vsan 52

no system default switchport shutdown san

Cisco-5020# sh system internal dcbx info interface ethernet 1/38

Interface info for if_index: 0x1a025000(Eth1/38)

tx_enabled: TRUE

rx_enabled: TRUE

dcbx_enabled: TRUE

DCX Protocol: CIN

Port MAC address:  00:0d:ec:b2:15:6d

DCX Control FSM Variables: seq_no: 0x1, ack_no: 0x0,my_ack_no: 0x0, peer_seq_no:

0x0 oper_version: 0x0,  max_version: 0x0 fast_retries 0x0

Lock Status: UNLOCKED

PORT STATE: UP

LLDP Neighbors

No DCX tlvs from the remote peer

6 Features on this intf for Protocol CIN(0)

3 Features on this intf for Protocol CEE(1)

6 Features on this intf for Protocol CIN(0)

Feature type LLS (6)sub_type FCoE Logical Link Status (0)

feature type 6(LLS)sub_type 0

Feature State Variables: oper_version 0 error 0 local error 0 oper_mode 0

     feature_seq_no 0 remote_feature_tlv_present 0 remote_tlv_aged_out 0

     remote_tlv_not_present_notification_sent 0

Feature Register Params: max_version 0, enable 1, willing 0 advertise 1

     disruptive_error 0 mts_addr_node 0x101 mts_addr_sap 0x1d9

Desired config cfg length: 1 data bytes:00

Operating config cfg length: 0 data bytes:

Peer config cfg length: 0 data bytes:

Feature type PFC (3)

feature type 3(PFC)sub_type 0

Feature State Variables: oper_version 0 error 0 local error 0 oper_mode 0

     feature_seq_no 0 remote_feature_tlv_present 0 remote_tlv_aged_out 1

     remote_tlv_not_present_notification_sent 0

Feature Register Params: max_version 0, enable 1, willing 0 advertise 1

     disruptive_error 0 mts_addr_node 0x101 mts_addr_sap 0x179

Desired config cfg length: 1 data bytes:08

Operating config cfg length: 0 data bytes:

Peer config cfg length: 0 data bytes:

Feature type App(Fcoe) (5)sub_type FCoE (0)

feature type 5(App(Fcoe))sub_type 0

Feature State Variables: oper_version 0 error 0 local error 0 oper_mode 0

     feature_seq_no 0 remote_feature_tlv_present 0 remote_tlv_aged_out 1

     remote_tlv_not_present_notification_sent 0

Feature Register Params: max_version 0, enable 1, willing 0 advertise 1

     disruptive_error 0 mts_addr_node 0x101 mts_addr_sap 0x179

Desired config cfg length: 1 data bytes:08

Operating config cfg length: 0 data bytes:

Peer config cfg length: 0 data bytes:

Feature type PriMtu (8)

feature type 8(PriMtu)sub_type 0

Feature State Variables: oper_version 0 error 0 local error 0 oper_mode 0

     feature_seq_no 0 remote_feature_tlv_present 0 remote_tlv_aged_out 1

     remote_tlv_not_present_notification_sent 0

Feature Register Params: max_version 0, enable 1, willing 0 advertise 1

     disruptive_error 0 mts_addr_node 0x101 mts_addr_sap 0x179

Desired config cfg length: 16 data bytes:24    00    24    00    24    00    08    6e    24    00    24    00    24    00    24    00

Operating config cfg length: 0 data bytes:

Peer config cfg length: 0 data bytes:

Feature type PriGrp (2)

feature type 2(PriGrp)sub_type 0

Feature State Variables: oper_version 0 error 0 local error 0 oper_mode 0

     feature_seq_no 0 remote_feature_tlv_present 0 remote_tlv_aged_out 1

     remote_tlv_not_present_notification_sent 0

Feature Register Params: max_version 0, enable 1, willing 0 advertise 1

     disruptive_error 0 mts_addr_node 0x101 mts_addr_sap 0x179

Desired config cfg length: 24 data bytes:32    32    00    00    00    00    00    00    00    0f    00    0f    00    0e    20    64    00    0e    00    0e

   00    0e    00    0e

Operating config cfg length: 0 data bytes:

Peer config cfg length: 0 data bytes:

Feature type LLS (6)sub_type LAN Logical Link Status (1)

feature type 6(LLS)sub_type 1

Feature State Variables: oper_version 0 error 0 local error 0 oper_mode 0

     feature_seq_no 0 remote_feature_tlv_present 0 remote_tlv_aged_out 1

     remote_tlv_not_present_notification_sent 0

Feature Register Params: max_version 0, enable 1, willing 0 advertise 1

     disruptive_error 0 mts_addr_node 0x101 mts_addr_sap 0xaf

Desired config cfg length: 1 data bytes:80

Operating config cfg length: 0 data bytes:

Peer config cfg length: 0 data bytes:

Traffic Counters

DCBX pkt stats:

    Total frames out: 20296

    Total Entries aged: 27

    Total frames in: 0

    DCBX frames in: 0

    Total frames received in error: 0

    Total frames discarded: 0

    Total TLVs unrecognized: 0

Cisco-5020#

Cisco-5020#

Cisco-5020#

I am new to this PFC, and first time trying to configure so you can see nothing being configured.

PrimergyQA Thu, 12/01/2011 - 23:38

Hi there,

you have configured Flow Control on quite a lot ports and if I can remember correctly this leads, and from the logical standpoint definitely has to lead, to non working PFC. The standard FC pauses traffic on a whole link wehereas PFC does this for dedicated CoS priorities only. In your case you simply have "overconfigured" (P)FC.

Unconfigure standard Flow Control from your interface, overload an interface and check the output of "show interface priority-flow-control". You should the see the PPP counter not being zero anymore.

Let me know if I was right ;-)

Actions

Login or Register to take actions

This Discussion

Posted November 4, 2011 at 1:46 AM
Stats:
Replies:5 Avg. Rating:
Views:1758 Votes:0
Shares:0
Tags: nexus, 5000
+

Related Content

Discussions Leaderboard