QOS on router Ethernet port

Answered Question
Nov 4th, 2011
User Badges:

My question is regarding assigning policy-maps to a interface.


Background:

The config I am posting is from a 2621 router. This routers Int fa0/0 connects to AT&Ts OPTEMAN 10Mbs Ethernet interface. The other end connects to our HQ router. At HQ is our PRIs and phone switches. I have configured QoS for this router, but don't I have to link them to the ingress interfacce (Int FA0/0)?


Here is the routers config:

sh run

Building configuration...


Current configuration : 1590 bytes

!

version 12.2

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname ACCESSRTR1

!

enable secret 5 $1$oKQI$9XtW3TrwSiaCB69qaw67T1

enable password 7 0505560A2F585C1048554653

!

ip subnet-zero

ip cef

!

!

no ip domain-lookup

!

call rsvp-sync

!

!

!

--More--                           !

!

!

!

class-map match-any Voice-Traffic

  match ip dscp ef

class-map match-any Voice-Signal

  match ip dscp cs3

  match ip dscp af31

class-map match-any Video

  match ip dscp af41

!

!

policy-map Voip

  class Voice-Traffic

    priority 20

  class Voice-Signal

   bandwidth percent 25

  class Video

  class class-default

policy-map OPTEMAN10M

  class class-default

   shape average 100000000 40000 0

--More--                              service-policy Voip

!

!

!

interface FastEthernet0/0

description OPTEMAN ERS Interface

ip address 10.10.10.2 255.255.255.248

duplex auto

speed 10

!

interface FastEthernet0/1

description Access LAN Interface

ip address 10.133.22.1 255.255.254.0

speed 100

full-duplex

!

router eigrp 1

network 10.0.0.0

auto-summary

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.10.10.1

ip route 10.133.1.0 255.255.255.0 10.10.10.1

--More--                           ip route 10.133.2.0 255.255.255.0 10.10.10.1

ip route 10.133.3.0 255.255.255.0 10.10.10.1

no ip http server

!

snmp-server community mccmh RO

snmp-server enable traps tty

!

dial-peer cor custom

!

!

!

!

line con 0

password 7 1107490019061915557A7A65

line aux 0

password 7 04555B0301355E5758495456

line vty 0

password 7 06085F24425A1B005447434A

login

line vty 1

password 7 130B4717051816337A747972

login

line vty 2 4

--More--                            password 7 130E1E1C0C4B50

login

!

end


ACCESSRTR1#



-Thanks for the help

in and out is relative to the router. In this case you want to apply the policy to the traffic going out of the router toward your HQ. On the HQ end you want another policy applied out toward your remote site. You don't need a policy inbound on either router because the bottleneck is not at the router ( it is the speed of your wan).


Sent from Cisco Technical Support iPhone App

Correct Answer by Joseph W. Doherty about 5 years 9 months ago

Disclaimer


The    Author of this posting offers the information contained within this    posting without consideration and with the reader's understanding that    there's no implied or expressed suitability or fitness for any  purpose.   Information provided is for informational purposes only and  should not   be construed as rendering professional advice of any kind.  Usage of  this  posting's information is solely at reader's own risk.


Liability Disclaimer


In    no event shall Author be liable for any damages whatsoever  (including,   without limitation, damages for loss of use, data or  profit) arising  out  of the use or inability to use the posting's  information even if  Author  has been advised of the possibility of such  damage.


Posting



interface FastEthernet0/0
service-policy Voip out (or it might be out Voip)
Correct Answer by cadet alain about 5 years 9 months ago

Hi,


of course you have to apply this policy-map to an interface otherwise it will serve no purpose.

You must apply outbound on WAN interface as you are shaping. As Joseph remarked above shaping is done if you can send at a rate higher than the access rate or CIR and the ISP is policing traffic above that rate.

Is it the case for you?

setting the bandwidth of an interface  won't refrain it to send at the access rate.


Regards.


Alain

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
Joseph W. Doherty Fri, 11/04/2011 - 12:33
User Badges:
  • Super Bronze, 10000 points or more

Disclaimer


The   Author of this posting offers the information contained within this   posting without consideration and with the reader's understanding that   there's no implied or expressed suitability or fitness for any purpose.   Information provided is for informational purposes only and should not   be construed as rendering professional advice of any kind. Usage of  this  posting's information is solely at reader's own risk.


Liability Disclaimer


In   no event shall Author be liable for any damages whatsoever (including,   without limitation, damages for loss of use, data or profit) arising  out  of the use or inability to use the posting's information even if  Author  has been advised of the possibility of such damage.


Posting


If your WAN connection is only 10 Mbps and your LAN connection is 100 Mbps, you'll likely only need QoS on F0/0 egress.


PS:

If you get the full 10 Mbps on the WAN facing Ethernet there's no need to shape at 10 Mbps.

mccmhtac1 Fri, 11/04/2011 - 12:37
User Badges:

I will get full 10Mbs on the WAN facing Ethernet, that is why I set it's port speed to 10Mbs.



Do I need to apply andy of this to an interface:


class-map match-any Voice-Traffic

  match ip dscp ef

class-map match-any Voice-Signal

  match ip dscp cs3

  match ip dscp af31

class-map match-any Video

  match ip dscp af41

!

!

policy-map Voip

  class Voice-Traffic

    priority 20

  class Voice-Signal

   bandwidth percent 25

  class Video

  class class-default

policy-map OPTEMAN10M

  class class-default

   shape average 100000000 40000 0

Correct Answer
cadet alain Fri, 11/04/2011 - 13:24
User Badges:
  • Purple, 4500 points or more

Hi,


of course you have to apply this policy-map to an interface otherwise it will serve no purpose.

You must apply outbound on WAN interface as you are shaping. As Joseph remarked above shaping is done if you can send at a rate higher than the access rate or CIR and the ISP is policing traffic above that rate.

Is it the case for you?

setting the bandwidth of an interface  won't refrain it to send at the access rate.


Regards.


Alain

mccmhtac1 Fri, 11/04/2011 - 16:45
User Badges:

Based on the config I provided, what commands will I use to correctly apply the policies?

Correct Answer
Joseph W. Doherty Fri, 11/04/2011 - 17:54
User Badges:
  • Super Bronze, 10000 points or more

Disclaimer


The    Author of this posting offers the information contained within this    posting without consideration and with the reader's understanding that    there's no implied or expressed suitability or fitness for any  purpose.   Information provided is for informational purposes only and  should not   be construed as rendering professional advice of any kind.  Usage of  this  posting's information is solely at reader's own risk.


Liability Disclaimer


In    no event shall Author be liable for any damages whatsoever  (including,   without limitation, damages for loss of use, data or  profit) arising  out  of the use or inability to use the posting's  information even if  Author  has been advised of the possibility of such  damage.


Posting



interface FastEthernet0/0
service-policy Voip out (or it might be out Voip)
mccmhtac1 Fri, 11/04/2011 - 18:17
User Badges:

pardon me for not understanding. but wouldn't that policy be 'in' not 'out'?

Joseph W. Doherty Sat, 11/05/2011 - 04:30
User Badges:
  • Super Bronze, 10000 points or more

Disclaimer


The     Author of this posting offers the information contained within this     posting without consideration and with the reader's understanding  that    there's no implied or expressed suitability or fitness for any   purpose.   Information provided is for informational purposes only and   should not   be construed as rendering professional advice of any kind.   Usage of  this  posting's information is solely at reader's own risk.


Liability Disclaimer


In     no event shall Author be liable for any damages whatsoever   (including,   without limitation, damages for loss of use, data or   profit) arising  out  of the use or inability to use the posting's   information even if  Author  has been advised of the possibility of  such  damage.


Posting


If f0/0 is the MPLS connection, out is correct.

cadet alain Sat, 11/05/2011 - 09:33
User Badges:
  • Purple, 4500 points or more

Hi,


you can't apply a QoS policy with shaping or CBWFQ config inbound, it must be outbound and in your case on the interface towards MPLS.


Alain

Correct Answer

in and out is relative to the router. In this case you want to apply the policy to the traffic going out of the router toward your HQ. On the HQ end you want another policy applied out toward your remote site. You don't need a policy inbound on either router because the bottleneck is not at the router ( it is the speed of your wan).


Sent from Cisco Technical Support iPhone App

Actions

This Discussion

Related Content