This discussion is locked

Ask the Expert: SIP-based Small Business IP Phones and Analog Telephone Adaptors

Unanswered Question
Nov 4th, 2011

Patrick Born

Welcome to the Cisco Support Community Ask the Expert conversation. This is an opportunity to learn about resolving usage, configuration, and troubleshooting of SPA phones and ATAs.Patrick Born is a Technical Marketing Engineer for the Small Business Technology Group (SBTG). His responsibilities include SPA3xx, SPA5xx, and SPA9xx IP Phones, WIP 3xx IP Phones, and SPAxxx ATAs including the SPA2102, SPA3102, PAP2T devices.

Remember to use the rating system to let Patrick know if you have received an adequate response. 

Patrick might not be able to answer each question due to the volume expected during this event. Remember that you can continue the conversation on the Small Business sub-community discussion forum shortly after the event.   This event lasts through November 18, 2011. Visit this forum often to view responses to your questions and the questions of other community members.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (3 ratings)
reuben.farrelly Fri, 11/04/2011 - 22:12

Hi Patrick

Can you outline plans for IPv6 support going forward across this line of phones?  Current firmware 7.4.9c doesn't include support..

Thanks,

Reuben

Patrick Born Mon, 11/07/2011 - 07:43

Hi Reuben,

IPv6 is on our roadmap for 2012. I'm researching and will get back with more detail.

Regards,

Patrick

----------

Patrick Born Mon, 11/07/2011 - 13:35

Hi Reuben,

[I previously responded but had mangled the message. To eliminate confusion, I've deleted my previous post.]

I can confirm that IPv6 is being investigated for the SPA30x, SPA50x, and SPA525G2 IP phone roadmap.

Regards,

Patrick

----------

dale@dr-notes.com Sun, 11/06/2011 - 21:35

You might be able to help me with my issue.  I have a small office with 10 phones 5 at 2 sites.  The current configuration consists of a RV016 connected to a RV082 VPN routers.  We have a Asterisk Box and SPA942 phones.  The current network works nicely.

We decided to upgrade to a 2911 with a 24 port POE switch in it from the RV082 since we are going to be routing multiple IP addresses,  Soon as we replace and setup the 2911 all RTP traffic drops from the network.  On the local site the PBX is hooked up directly to the Switch, that has a base address in the 192.168.1.x range, the remote site is through a VPN and is the 192.168.0.x range.

I am not a noobie when configuring the 2911, but I must be missing something.  Truthfully, I do not care about the call manager or any of the advanced features.  All i need is to route 3 outside addresses in the local office and have the remote site connect with the PBX.  Data communications work fine, but all voice traffic from the remote site is dropped or ignored.

I have some questions about the 2911 and I pray that you can help.  I am at the end of my rope here.  I have spoken with 25 different reps, and only 1 seems to really care about the issue. 

I have tried the following:

Port forwarding:

Deny the 192.168.0.x subnet from the nat

Creating access lists for UDP ports 5060 and 10000-20000

Everything in Cisco Document 5162

No ip nat inside service voip 5060 (Disable ALG)

Kicking the router!

1) Does the 2911 default to not allowing RTP traffic to pass if you do not have a firewall set?

2) Do I have to use the CME with a asterisk box?

3) How can I setup this router to be in dumb mode turn everything off and not anaylize traffic?
4) What would you recommend doing.  I am so burnt out on this I can't begin to tell you....Please please help.

We use SPA-942 phones with the G711ulaw codec.  Might you recommend using another, if possible.  Is there any special settings we need to have setup for the traffic.  Please let me know thank you.

Dale

Patrick Born Mon, 11/07/2011 - 08:09

Hi Dale,

I'm no 2911 or IOS expert so can't offer specific help with this.

One new variable new to the mix could be that the 2911 and / or switch may be supporting the Cisco Discovery Protocol (CDP).

The easiest way to test if this is a factor is to disable CDP on the SPA942 phones either via the phone's web-UI or through their configuration file.

There is no need to supplement Asterisk with any other call control.

There is no real need to move from G.711 ulaw to another CODEC.

Keep in mind that when a call is established, the SIP signaling path is usually not the same path that the RTP traffic will take. This makes me think that there may be stateful packet inspection being performed by a firewall which results in RTP not being expected and consequently dropped, resulting in no RTP / on-way audio.

In summary, I believe that you are facing two issues, CDP and a firewall.

Best of luck. Please share with the community and me, your progress,

Patrick

----------

john.ventura73 Wed, 11/09/2011 - 09:31

Hello Patrick, Do you know  how many call appearances per line does the SPA504 support?

Patrick Born Thu, 11/10/2011 - 07:23

Hi John,

The SPA504G has 4 line buttons in the form of multi-colored LED buttons.
Each line allows a unique SIP registration or can share a registration with another line.
The phone is capable as of firmware release 7.4.8 of supporting 10 call appearances across any of the line keys in any way you'd like.

For example, you may choose to only register line key 1 and you could be speaking to person 10 while persons 1 through 9 are on hold.

Great question, thanks for asking.

Regards,

Patrick

----------

   Patrick Born | Technical Marketing Engineer (TME) – SPA SIP Endpoints
           Use this reference document to locate SPA phone resources

tamkeen.asar Wed, 11/09/2011 - 23:21

hi sir

i have doubt i got a cisci id but its a 8 digit id i heard cisco id is total 12 digit is it true??

and i want to know how to check and verifiy about certifiction status???help me out

Patrick Born Thu, 11/10/2011 - 07:26

Hi syed,

I don't work with Cisco IDs or certifications.

What certification are you wanting? Perhaps I can direct you to someone who can help better than I can.

Regards,

Patrick

----------

Orilsingh_2 Thu, 11/10/2011 - 11:32

Hello Patrick,

I am having two issues at a customer site I am hoping you could give me some insight into. They have a UC320 system with one SPA508 phone with side car and the other phones are SPA303s. The issues are:

1) The customer is complaining that the phones hang up or "freeze" and become unresponsive to input at random periods. It does not happen with all phones at the same time. Its one phone at a time and it is random. I have seen it where if you press a key you get a high pitch tone and the phone is unresponsive. You have to reboot the phone for it to work. I noticed this behaviour after I upgraded the UC320 firmware to version 2.1.1. This also occurs with the SPA508 phone as well.

2) The other issue is the the time that the system takes to actually outpulse the digits entered on the phone's key pad and the dial soft key is pressed. Is this something that can be reduced??

These issues have the customer at the point of wanting to return the system. Any ideas would be greatly appreciated.

Regards,

Oril

Patrick Born Thu, 11/10/2011 - 16:42

Hi Oril,

I'm checking with my colleague who is a UC320 expert and will report back.

Regards,

Patrick

-----------

nalbert Thu, 11/10/2011 - 17:29

Oril,

Thanks for you feedback.

Regarding

1. I request to kindly take the time to open a SBSC case on this issue. Phone freezes are rare, however when they happen we want to know everything about them. I request you to kindly send me the exact circumstances under which the phone froze to nalbert@cisco.com.

2. The phone typicaly takes 3-4 secs to send digits to the Telco. Does your Telco play a stuter tone?  This may delay the Post Dial Delay.

Patrick Born Fri, 11/11/2011 - 08:47

Thanks for the support Navin, much appreciated.

Orilsingh_2 Fri, 11/11/2011 - 10:23

Navin,

Thank you for the assistance I will definitely act on   your suggestions. With regards to issue 2, no the Telco does not play a   stutter tone. It takes closer to 10 seconds to actually hear ring back   from the Telco instead of 3-4 like you mentioned.

Regards,

Oril

cisla1234 Fri, 11/11/2011 - 08:27

Hi Patrick,

There are 2 main issues we need resolved when using the SPA525 with     Asterisk 1.6.2.5.  The 2 issues are parking and Intercom.

Parking.

Typically what we've been doing in the past for parking with other     phones is a feature which will allow the user to press a 'park'     button.  This will essentially transfer the call to a parking lot     (ie 700).  The system will then play out which parking space it's in     (audio) before the use hangs up.

The solution provided in the past

--

- Define PSK1 as : fnc=sd;ext=700@$PROXY;vid=1;nme=Park
- confLx|1;flash|1;xferLx|2;conf|1;xfer|2;toggle|4;redial|5;dir|6;bxfer|4;park|8;phold;psk1|3

--

was not successful, because what     happens is that the phone sends the call to parking lot but hangs up     in doing so.  Thus you never hear which parking lot number.  This     function needs to be more like an  *attended transfer* rather than a *speeddial* which just hangs up.

ICOM, (Intercom)

We need a way to use a directed Intercom.  A user presses an 'ICOM'     button (can be a prefix), and then waits for the user to enter the     recipients extension.  The recipients phone needs to automatically     pickup speaker.  We are doing this server side.  What the PBX is     expecting to see is a *xxx (where xxx is the extension).  The PBX     will then send the appropriate 'ALERT' to the recipients phone to     auto answer call.

The solution provided in the past ( found in

http://ofps.oreilly.com/titles/9780596517342/asterisk-SysAdmin.html

)

--

exten => *201,1,SIPAddHeader(Call-Info:\;answer-after=0)
same => n,Page(${PageDevice},i)

--

was not successful, because the     string provided by O'Reilly must not be right because the phone never     auto answers. We tried multiple variations of syntax, which none     were successful.  We need you to tell me *exactly* what the phone     wants to see!

thanks,

ci



Patrick Born Fri, 11/11/2011 - 08:49

Hi Ci,

Great questions.

I'll work on this in my lab and report back.

Regards,

Patrick

----------

Patrick Born Fri, 11/18/2011 - 13:44

Hi Ci,

I'm still working the issues you raised. The event is about to be closed, but I'm going to continue to chase down a solution. I'll post to the community when done.

Please feel free to contact me at paborn@cisco if you'd like me to share directly with you once I can figure out something.

Regards,

Patrick

----------

kornelius Fri, 11/11/2011 - 21:36

Hi Patrick,

SPA2102 after upgrade firmware - LAN problem:

Few days ago I updated from 3.3.6 to 5.2.12 (latest ver) and got confirmation about success.

My PC was connected to SPA so it worked as SIP and router.

Later when I restarted PC it lost network connection with SPA - LAN port stop respond (NO ip .

I involve Dlink router after DSL modem and connect PC and SPA (phone still works).

After all I opened WAN port with IVR code and now have web access to SPA - reupdated again firmware 5.2.12

VOIP works but LAN port still not responds - ip for it I know 192.168.1.1 but...

WAN port 192.168.0.100 - works fine

but I need SPA work as router - ANY help?

DHCP,NAT - in configuration (I didn't change LAN properties)

thanks

S

Patrick Born Tue, 11/15/2011 - 07:15

Hi Serg,

When you say, "LAN port stop respond (NO ip ."

Do you mean no IP address on computer, or no IP traffic is flowing?

1. Please confirm that the following are correct:

  • SPA2102 blue INTERNET port is connected to DSL modem
  • SPA2102 yellow ETHERNET port is connected to your PC

2. Reboot your PC and use the command prompt to determine the PC's IP address: C:\ ipconfig /all

Did your PC report an IP address of 192.168.0.2? [if not, you could have a configuration problem on the SPA2102]

By default, the LAN side of the 2102 is 192.169.0.1 and the first DHCP client gets 192.168.0.2.

Things that could be wrong on the SPA2102's configuration include:

  • LAN DHCP server could be disabled
  • Networking service should be NAT [Router > LAN Setup tab]

Let me know how it goes,

Patrick

----------

kornelius Tue, 11/15/2011 - 10:12

Hi Patrick

Thank you very mutch for the assistance! You helped me.

Problem was as you wrote - 'LAN DHCP server could be disabled'

for some reason after upgrade it switched to - 'no' and I lost attention for check it.

Now SPA works as router.

PS

One more question:

I switched from dry loop dsl ISP to cable ISP and previosly had 'PPPOE' connection type - now 'DHCP'

so with pppoe connection led 'Internet' on SPA was green steady and with cable DHCP connect lead 'Internet' on SPA now flashing continiosly.

Modem Motorola has no web access - 'black box'. Is this 'dhcp talking'  beetwen modem and spa would influence on my mothly traffic?

and should I worry about it?

again - thanks!

Patrick Born Wed, 11/16/2011 - 08:48

Hi Serg,

Thanks for letting the community and me know that the issue is resolved.

You ask;

I switched from dry loop dsl ISP to cable ISP and previosly had 'PPPOE' connection type - now 'DHCP'

so  with pppoe connection led 'Internet' on SPA was green steady and with  cable DHCP connect lead 'Internet' on SPA now flashing continiosly.

Modem  Motorola has no web access - 'black box'. Is this 'dhcp talking'   beetwen modem and spa would influence on my mothly traffic?

and should I worry about it?

DHCP does not really talk much. The SPA2102 is a DHCP client and will receive an IP address on lease from the DHCP server. The lease time can be really short or really long, depending on how the DHCP server is configured. Once the lease period comes close to expiration, the SPA2102 will request a renewal of the lease period for the same IP address. DHCP interaction does not generate network traffic and is local between the SPA2102's WAN port and the DHCP server's LAN port.

The flashing LED does indicate that there is traffic on the network. If you are running a browser, all the advertisements, tool bars, and related tasks may well be generating network traffic.

I suggest you download Wireshark from http://wireshark.org and run it on your PC to determine what traffic is running between the SPA2102 WAN port and your cable modem's LAN port. [install a hub between the two in order to view this traffic]

Regards,

Patrick

----------

kornelius Wed, 11/16/2011 - 12:15

Hi Patrick,

Thank you for usefull tool - wireshark, I installed it and now know for sure that between PC and SPA LAN port traffic is really low as I expected (I forgot to tell before that I checked 'Network' spa led even with disconnected PC from it - led was flashing, and when SPA worked behind Dlink router - Dlink's led 'Internet' also flashed but not spa led).

That means the cable modem Motorola SB5102 initiates this traffic with any router.

I don't have now hub (thanks for advise about it)

and can't check traffic between WAN spa port and cable modem.

Cable is SHAW but ISP another company from east cost.

Would see and try my best.

Serg

john.ventura73 Mon, 11/14/2011 - 07:25

Hi Patrick, I have a couple of questions:

1)  What Bluetooth class is the SPA525G2?

2) How can I configure a speed dial to dial a short number and have the speed dial dial a much longer number?

I'm lookind forward to the responses.

John

Patrick Born Tue, 11/15/2011 - 06:57

Hi John,

1)  What Bluetooth class is the SPA525G2?

A: The SPA525G2 phones are class-2 (2.5mW power) Bluetooth devices. This means that they've about a 10 meter range.

2) How can I configure a speed dial to dial a short number and have the speed dial dial a much longer number?

A: You could configure the phone line's dial plan to recognize and accept a short number and then dial a longer number. For example, if you want to dial #10 [hash/pound, one, zero] and have the phone dial 13035551212 you could add the following to the front of phone's extension's dial plan: "<#10: 13035551212>|"  (without "" quotes)

This must be on the left-most side of the dial plan definition to make sure that it receives the first match.

In addition, make sure that there are no #10 (or whatever you use) vertical service activation codes on the phone [Regional tab] or on your call control.

When you dial #10, the phone will send out 13035551212 as the dialed string.

Regards,

Patrick

-----------

ntopbrick Fri, 11/18/2011 - 11:13

Good afternoon, Patrick.

We are preparing for a migration of subscribers from another MSO.  They are using SPA2102s.  During our system and interoperability testing, we foolishly assumed these subs would be running a more recent version of firmware than what comes out of the box (v3.3.6).  I successfully upgraded two of our 4 devices to the latest v5.2.12 and completed most of my test cases...only to learn today the production devices are still on the old v3.3.6.

I have not been able to find any information on:

a) how to downgrade / revert / roll-back to the previous release that was installed

b) where a download exists for the old v3.3.6 firmware binary

c) if a factory reset will restore the old firmware revision as well as default settings

d) how to save the current configuration settings to a file via the web interface (if I am lucky enough to be able to downgrade, that is)

Any information or assistance in this matter would be greatly appreciated.

Best regards,  BobD

Patrick Born Fri, 11/18/2011 - 13:42

Hi Bob,

Not sure if you've seen this page, but it's a great resource for most things ATA:

https://supportforums.cisco.com/docs/DOC-9888

The Admin Guide contains most, if not all that you're looking for:

http://www.cisco.com/en/US/docs/voice_ip_comm/csbpvga/ata/administration/guide/ATA_AG_v3_NC-WEB.pdf

I'll address each of your questions here:

a) how to downgrade / revert / roll-back to the previous release that was installed

Upgrading/Downgrading is accomplished using any of the following means:

Using the exe file and upgrading devices one at a time

Using an URL to upgrade: http:///admin/upgrade?tftp:///pathToBinFile

Using the upgrade rule in the device's provisioning file and then when the device resyncs, it will upgrade/downgrade

b) where a download exists for the old v3.3.6 firmware binary

This is no longer available on Cisco.com. We'd prefer you to use a  current version of firmware so you do not run into issues that have  already been fixed. If you really need the old firmware, contact me at  paborn at cisco and I'll do my best to locate for you.

c) if a factory reset will restore the old firmware revision as well as default settings

No, a factory reset only resets all values to the factory default of the version of installed firmware.

d)   how to save the current configuration settings to a file via the web   interface (if I am lucky enough to be able to downgrade, that is)

This may help you:

https://supportforums.cisco.com/docs/DOC-9896

Regards,

Patrick

----------

Actions

Login or Register to take actions

This Discussion

Posted November 4, 2011 at 1:33 PM
Stats:
Replies:26 Avg. Rating:5
Views:6119 Votes:0
Shares:0

Related Content

Discussions Leaderboard