×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

OSPF DR and BDR bidding question

Unanswered Question
Nov 7th, 2011
User Badges:

hi:



i am using Packet tracer to test OSPF DR and BDR bidding.


according to text book, if the interface's router ID is the highest , it will become DR and the next highest will be BDR.


but in my test, i don't see this happening .


R1's conf


interface Loopback101

ip address 100.100.100.100 255.255.255.0

!

interface FastEthernet0/0

ip address 1.1.1.10 255.0.0.0

duplex auto

speed auto

!

interface FastEthernet1/0

no ip address

duplex auto

speed auto

shutdown

!

interface Serial2/0

no ip address

shutdown

!

interface Serial3/0

no ip address

shutdown

!

interface FastEthernet4/0

no ip address

shutdown

!

interface FastEthernet5/0

no ip address

shutdown

!

router ospf 1

log-adjacency-changes

network 0.0.0.0 255.255.255.255 area 1

!

ip classless

!

!

!

!

!

!

!

line con 0

line vty 0 4

login

!

!

!

end


R1's "show ip protocols"


Routing Protocol is "ospf 1"

  Outgoing update filter list for all interfaces is not set

  Incoming update filter list for all interfaces is not set

  Router ID 100.100.100.100

  Number of areas in this router is 1. 1 normal 0 stub 0 nssa

  Maximum path: 4

  Routing for Networks:

    0.0.0.0 255.255.255.255 area 1

  Routing Information Sources: 

    Gateway         Distance      Last Update

    1.1.1.1              110      00:00:43

  Distance: (default is 110)




R2's conf


hostname R2

!

!

interface Loopback1

ip address 10.10.10.10 255.255.255.0

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

shutdown

!

interface FastEthernet1/0

ip address 1.1.1.1 255.0.0.0

duplex auto

speed auto

!

interface Serial2/0

no ip address

shutdown

!

interface Serial3/0

no ip address

shutdown

!

interface FastEthernet4/0

no ip address

shutdown

!

interface FastEthernet5/0

no ip address

shutdown

!

router ospf 1

log-adjacency-changes

network 0.0.0.0 255.255.255.255 area 1

!

ip classless

!

!

!

!

!

!

!

line con 0

line vty 0 4

login

!

!

!

end




R2's IP protocol details



Routing Protocol is "ospf 1"

  Outgoing update filter list for all interfaces is not set

  Incoming update filter list for all interfaces is not set

  Router ID 10.10.10.10

  Number of areas in this router is 1. 1 normal 0 stub 0 nssa

  Maximum path: 4

  Routing for Networks:

    0.0.0.0 255.255.255.255 area 1

  Routing Information Sources: 

    Gateway         Distance      Last Update

    1.1.1.10             110      00:01:51

  Distance: (default is 110)



obviously R1 has higher router ID.

but at the end


R1#show ip ospf neighbor


Neighbor ID     Pri   State           Dead Time   Address         Interface

10.10.10.10       1   FULL/BDR        00:00:35    1.1.1.1         FastEthernet0




R2#show ip ospf neighbor


Neighbor ID     Pri   State           Dead Time   Address         Interface

100.100.100.100   1   FULL/DR         00:00:35    1.1.1.10        FastEthernet1/0



as it shows from above data, R2 was chosen as DR despite that R1 has higher Router ID and they both have same priority number.



please help me out on this, i have been thinking for hours.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Peter Paluch Mon, 11/07/2011 - 10:41
User Badges:
  • Cisco Employee,

Hello,


I believe you are simply reading the output incorrectly. R1 is the DR and R2 is the BDR. The output says:


R1#show ip ospf neighbor


Neighbor ID     Pri   State           Dead Time   Address         Interface

10.10.10.10       1   FULL/BDR        00:00:35    1.1.1.1         FastEthernet0


R1 knows about a neighbor whose RID is 10.10.10.10, IP address is 1.1.1.1 and whose state is BDR.


R2#show ip ospf neighbor


Neighbor ID     Pri   State           Dead Time   Address         Interface

100.100.100.100   1   FULL/DR         00:00:35    1.1.1.10        FastEthernet1/0


R2 knows about a neighbor whose RID is 100.100.100.100, IP address is 1.1.1.10 and whose state is DR.


The show ip ospf neighbor shows your neighbor's roles, not your own.


Best regards,

Peter

Actions

This Discussion

Related Content