×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

CM Express - Calls from Cisco SCCP to Cisco SIP not working

Unanswered Question
Nov 16th, 2011
User Badges:

Hi All,


Hope you can recommend some areas here to look in, because this is drving me crazy!


Have inherited a Cisco CUCME 7.1 built on a 2811 router. I have both SIP(7941) and SCCP (7941/7960) handsets, all up and working. (all using 4 digit patterns).


If I dial SIP > SCCP , the SCCP displays the inbound caller infomation  - this is OK

If I dial SCCP>SCCP, the SCCP displays the inbound caller information - this is OK


If I dial SCCP to SIP, then the SIP displays "From Unknown Number".


Bearing in mind that these phones are all on the same pbx switch I am at a loss to understand why this doesnt work. (Judging by the lack of mentions of this or similar problems on various google searches, I get the impression this should work. the only times it appears there may be issues is when leaving the PBX to go to another PBX / external service Provider - something I am not doing at the moment).


I have checked everything I can find regarding caller-id to ensure I am not blocking it in anyway.


there are no translation rules built for ext to ext dialling, and I cant see that I would need one for internal to internal calls either. (but tell me if I am wrong)

I have configured the directory and relevant settings, but this has made no difference.


I have run debug  (debug voice ccapi inout) and captured the trace.To me it looks like the SCCP is sending its extension number, but for some reason (which I have not worked out yet), the SIP phone does not receive it.


I have tried different versions of phone software but they made no difference. I am extremely reluctant to "factory reset" the whole switch - apart from a lack of clear instructions on how to do this is mightly putting me off doing this anyway. I am new to the Cisco Express, and have only been working with it for a week, so any advice or suggestions would be greatly appreciated.


I can provide config and outputs fot debug if anyone is really keen!


Kind regards,


A frustrated Cisco Express user!!!



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Aaron Harrison Wed, 11/16/2011 - 11:40
User Badges:
  • Super Bronze, 10000 points or more
  • Community Spotlight Award,

    Member's Choice, May 2015

Hi


If you're new to this type of thing, I would say there's no point starting by trying to dig yourself out of a hole.. sounds like someone may have been playing around with SIP because it's new. In general, it is new, but it's not better.. I would suggest you maybe post up your config so we can see what you are working with, but would also suggest you search out how to switch the 7941 SIPs back to SCCP and updateing the config to match.


Keep it simple.


Aaron

NoelNesbitt Thu, 11/17/2011 - 02:06
User Badges:

Hi Aaron,


Thank you for the quick response, it is much appreciated.


I have been working on various phone systems (mitel / meridan/bcm450 and various siemens systems for the last 13 years, so I am not unfamiliar with how recalcitrant phone systems can be! - especially with the introduction of SIP and interconnectivity with non SIP can be a headache).


On the whole the PBX is working fine and yesterday afternoon I interconnected with a non Cisco PBX just fine, and the SCCP> foreign SIP devices works - display and everything in both directions. Also connection it wiith the voicemail system on the foreign PBX and eveyrthing works hunky dorey - it is just the Cisco SCCP to Cisco SIP that does not want to display correctly.


Unfortunately dropping the SIP devices back to SCCP is not an option in the environment here. (I do know how to do it, but there is a requirement for mixed environment here of SIP and SCCP).


One thing I did discover late yesterday was the following:-


On initial dial from cisco SCCP to cisco SIP, the SIP displays "From Unknown Number". If the call is answered at the SIP device and then puts the call on hold and then retrieves from hold, then the display will change to show the extension number of the SCCP phone, and stops displaying "from Unknown Number". Definitely sounds SIP related - I just need pointing in the right direction to work out what is causing the problem. there are times I hate SIP.


I have attached the config file from the cisco PBX - at the moment it contains a number of boards which are NOT in use - all we have configured  and working is a SIP/IP link to a non Cisco PBX, and that is working fine. The config file also contains the version at the top of the file. I have also attached a debug ccsip trace of a SCCP>SIP, including putting the call on hold and retrieving it.


Any advice on areas to go and look at on the Cisco will be appreciated. For the moment, it is a problem that is not stopping us from working and moving forward, so it is not the end of the world - just a frustrating one. I suspect a setting that I have not spotted is doing the damage, and I am not quite familiar enough with Cisco PBX to work it out. (Despite reading / re-reading the admin guide and IOS commands for both the router and CME before resorting to posting on here!


Kind regards,


Becky

Actions

This Discussion

Related Content