×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

H-VPLS using MPLS in access

Unanswered Question
Nov 21st, 2011
User Badges:

Dears,

I would like your assistance regarding below plz

How to map EoMPLS PW from U-PE to N-PE  to the VPLS network at N-PE


U-PE1 <----- MPLS ----->  N-PE2 <-------- VPLS Network -------> N-PE3

                                                   


I believe xconnect vc @ U-PE should match vfi vpn id @ N-PE as below, correct ?


U-PE

interface gi1/0

ip add 10.0.0.1 255.255.255.0

xconnect 10.0.0.2 99 encapsulation mpls


N-PE2

l2 vfi test manual

vpn id 99

neighbor 3.3.3.3 encapsulation mpls

neighbor 4.4.4.4 encapsulation mpls


Many Thanks


BR,

Sherif Ismail

Attachment: 
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
maayre Tue, 11/22/2011 - 02:40
User Badges:

Hi Sherif,


I'm not sure that the ID has to match, I believe you are missing a neighbor statement on the N-PE2 towards the U-PE;


     l2 vfi test manual

     vpn id 99

     neighbor 3.3.3.3 encapsulation mpls

     neighbor 4.4.4.4 encapsulation mpls

     neighbor 10.0.0.1 99 enc mpls


It seems a little odd that the U-PE xconnect IP is to a destination inside a subnet on the same interface, maybe you meant;


     int gi1/0

     xconnect 10.0.0.2 99 enc mpls


     int gi1/1

     ip add 10.0.0.1 255.255.255.0

     mpls ip


The only reference I could find was from another different thread on this forum which referenced this;

http://www.cisco.com/en/US/docs/ios/zz_trash/mp_hvpls_npe_red.html#wp1056907

Sherif Atef Ahm... Tue, 11/22/2011 - 02:46
User Badges:

Thanks Matthew

Maybe thats why it was not working .... I will try above & let you know


Many Thanks


BR,

Sherif Ismail

judebryant Mon, 11/28/2011 - 11:27
User Badges:

Remember,


If you want to segment traffic.  Use the xconnect on the SVI.


example

Vlan100 - customer A

Vlan 200 - customer B


l2 vfi 99 manual

vpn id 99

neighbor 1.1.1.1 encapsulation mpls


l2 vfi 98 manual

vpn id 98

neighbor 2.2.2.2 encapsulation mpls


interface vlan100

ip address 10.1.1.1 255.255.255.0

xconnect vfi 99


interface vlan200

ip address 10.2.2.1 255.255.255.0

xconnect vfi 98


This way you can segment traffic comming in on one port and forward to different destination.


Regards

Jude

Sherif Atef Ahm... Tue, 11/29/2011 - 23:28
User Badges:

Thanks Jude for your reply

Your configuration works well with QinQ H-VPLS however I am asking about MPLS H-VPLS

I still didnt try Matthew suggestion


Will let you know once I tried it


Regards

Sherif Ismail

judebryant Wed, 11/30/2011 - 11:41
User Badges:

I knew that.  Just wanted to throw in an additional scenerio.


Regards

Jude

Actions

This Discussion