Extend PSTN over Ethernet/wifi to an IP Phone

Answered Question
Nov 22nd, 2011

Hello forum,

I appreciate any input on the following configuration:

PSTN <> SPA3102 <> eithernet/wifi <> IP Phone

I basically just need to place and receive calls on the IP phone using the PSTN line.

Is this possible? Any suggestions on configuration would be appreciated. Thank you.

I have this problem too.
0 votes
Correct Answer by Howard Wittenberg about 2 years 4 months ago

Instead of calling the Line 1 configuration (default port = 5060) you call the PSTN Line Tab configuration (default port = 5061.   In other words userid@ip_address:5061 or ip_address:5061 if you don't have a userid configurated on the PSTN Lint Tab.  The SPA3102 is really two separate adapters with built-in internal communication.

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (1 ratings)
jasbryan Wed, 11/23/2011 - 09:29

Daniel,

This wouldn’t work; think of the 3102 also as an IP phone. It would be like attempting to register an IP phone to another IP phone and trying to route calls out the PSTN. As I have seen some strange configurations with these units but not like this. Your ip phones needs to be able to register to a sip server/PBX – the configuration you’re looking for uses UC320 device.

http://www.cisco.com/en/US/products/ps11388/index.html

Hope this helps,

Jasbryan

Howard Wittenberg Sun, 11/27/2011 - 16:28

The SPA3102 will bridge a pstn line call with a voip call.  You can configure the PSTN Line Tab of the SPA3102 to pass calls between an attached PSTN line and an IP Phone such as the Cisco/Linksys ip phones where both devices have settings so that you can communicate between the units without registration.  This setting is essential.

There are probably several ways you can configure the ip phone.  For outgoing calls to the PSTN line you can setup a speed dial (or a dial plan) to call the SPA3102 and get a dial tone for the PSTN line.  You would do this by a sip uri that called the SPA3012.  Another way would setup the ip phone with the SPA3102 as an unregistered proxy and then with one-stage dialing dial the pstn number directly.  For this you could setup http digest authentication on the SPA3102.

For incoming calls to the ip phone you would setup the PSTN Line tab's pstn-to-voip gateway to automatically forward any incoming PSTN line call to the ip phone.  You would do this with a dial plan.

danielihrig Tue, 11/29/2011 - 14:38

I was able to get this working, after combing through many forum postings for config settings required. Attached is the config summary if anyone is interested. I used x-lite 4 for my softphone.

One thing I can't figure out: I have a phone connected to the phone port of the SPA. That phone does not ring for an incoming PSTN call, nor can I use that phone to place a PSTN call. I get dial tone (SPA dialtone) but not PSTN dialtone. I dial numbers but just get a fast busy. Any ideas on how to get that working - for both inbound and outbound calls - would be appreciated.

Howard Wittenberg Tue, 11/29/2011 - 17:11

Daniel

To get the phone attached to the SPA3102 to ring on a PSTN line incoming call you need to have the following settings:

1.  PSTN Answer Delay 16 (number of seconds you want the phone tp ring before the call goes to the pstn-to-voip gateway and is thus transferred to the softphone with your configuration)

2: PSTN Ring Thru Line 1: YES

For outgoing pstn line calls from the phone attached to the SPA3102 you need to setup a Line 1 dial plan to send the call to the PSTN Line.  Something like this: (<#9,:>xx.<:@gw0>|xx.) which if you dial #9 first the call will then be sent to the PSTN Line, otherwise the call will be sent to your voip provider.  On the PSTN Line Tab the voip-to-pstn gateway need to be enabled, and One Stage Dialing should be set to Yes.

danielihrig Wed, 11/30/2011 - 09:15

Outbound is fixed. Thank you. Still can't receive calls from the phone port. I see the status of PSTN is ringing and it rings on the voip phone only.

PSTN line:

PSTN answer delay = 10

PSTN ring thru line 1 = yes

VoIP-To-PSTN Gateway Enable:= yes

One stage dialing = yes

Howard Wittenberg Wed, 11/30/2011 - 09:56

Looking at what you posted again, I believe the problem is the User 1 Tab setting of Cfwd All Dest: gw0.  Remove that.  When the incoming pstn line call "rings thru" to Line 1 the call is forwarded away from the phone.  If you have a need to forward incoming voip calls to Line 1 to the voip-to-pstn gateway I am sure there is an alternative way.

danielihrig Wed, 11/30/2011 - 15:17

If I remove Cfwd All Dest: gw0 I can no longer place outbound calls from my softphone to PSTN.

I am not using a VOIP provider, the purpose of this is simply to extend PSTN access across a LAN to IP Phones.

Correct Answer
Howard Wittenberg Wed, 11/30/2011 - 15:30

Instead of calling the Line 1 configuration (default port = 5060) you call the PSTN Line Tab configuration (default port = 5061.   In other words userid@ip_address:5061 or ip_address:5061 if you don't have a userid configurated on the PSTN Lint Tab.  The SPA3102 is really two separate adapters with built-in internal communication.

danielihrig Wed, 11/30/2011 - 15:43

Thanks for the additional info. However, removing Cfwd All Dest: gw0 does not get the phone port to ring upon incoming call. Looks like I get a caller ID display on the phone, but no ringing and can't answer the call.

danielihrig Wed, 11/30/2011 - 16:34

I double checked all the settings (also left Cfwd All Dest: gw0 removed), power cycled the SPA, and it's working. Incoming calls ring through the phone port for 16 seconds, then ring the softphone. Softphone is using port 5060 for outbound and that's working. Will update config doc and repost. Thanks again.

Actions

Login or Register to take actions

This Discussion

Posted November 22, 2011 at 8:19 AM
Stats:
Replies:11 Avg. Rating:5
Views:4225 Votes:0
Shares:0
Tags: pstn, ata, 3102
+

Related Content

Discussions Leaderboard