Connecting a stand alone rack mount server to UCS system

Answered Question
Nov 23rd, 2011

Hi,

I read some where on the dcoumentation that A stand alone Cisco server like c210, c250 can be attached to the UCS fabric Interconnect. Can some cisco expert throw some light into it?

My understanding is,

I will have to connect the UCS FI to a external rack mount FEX and Cisco Servers would connect to the FEX. Can some one clarify?

What are the required configuration for the above setup at UCS FI?

I have configured the UCS FI ports as server ports and connect them to a external FEX with Twinax cable. But the ports are link down. Is twinax cable supported? Would i have to do extra configuration that we do for while connecting a Nexus 5000 to a FEX?

Any help would be apprciated.

Thanks.

I have this problem too.
0 votes
Correct Answer by David McFarland about 2 years 4 months ago

The details of connecting a standalone rack server are covered in this doc

https://supportforums.cisco.com/docs/DOC-15034

Dave

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (1 ratings)
niranjandas Wed, 11/23/2011 - 14:46

One update. I was conencting to wrong ports at FEX side. There are designated ports only those are to be connected from a FEX to switch. When i connected at correct ports in FEX with Twinax cable it worked. Now on UCS manager i see the FEX. Question is it recognized the FEX as FEX 2? Are the no FEX no get auto assigned ?

Now what to do from here on?

From UCS CLI,  doing scope to fex,

cisco-A-A /fex # show

FEX:

    ID         Fabric ID Overall Status

    ---------- --------- --------------

             2 A         Accessibility Problem

cisco-A-A /fex #

What is this accessiblity probelm is about?

niranjandas Wed, 11/23/2011 - 15:41

Thanks for the post. It is very much helpful.

For my setup, i still see accessibility problem. As per the doc, this may happen during FEX firmware update and may take about 20 mins. It is more than a hour for me, accessibility problem is not going away.

IOM status shows, "operable". Not sure how to get rid of accessiblity issue resolve.

niranjandas Mon, 11/28/2011 - 16:52

I have tried the steps as given on the docs "mentioned above" and my FEX status was "accessibility problem" for a long time. Only difference is, i was using a 10G FEX model 2232PP instead of 2248T.

My understanding from the above doc is, FEX is needed in the setup only if you wish to manage the rack mount server using the UCS software (UCS Manger). It does not play a rule on the FCoE protocol and the way FCoE CNA communicates to UCS Fabric Interconnect 6120's.

So coming back to the picture where the 10G CNA is connected to the UCS FI part, I looked at the doc and configuration steps and configured according. It asks to configure UCS FI switch port as "server port" where a 10G CNA will be attached.

I did and collect a finisar trace. From the trace it appeared the switch was not doing anyting the FCoE protocol requires during initialization called FIP process. Following ponints were observed which did not comply with FCoE protocol.

  1. Though CNA was sending FIP VLAN request all the time, there was not any FIP VLAN reply from the switch.
  2. LLDP was not negotiated, during early stages of FCoE login, LLDP negotiation happens where priority and bandwidth sharing for the link is negotiated.
  3. There was not any "Discover Advertisement" (DA) from the switch port. Without DA, CNA is never going to find any FCoE capable device on the network.

Can some cisco expert let me know what is wrong? At least if some one can let me know for sure that a UCS FI port which is configured as "server port" is capable of doing FCoE protocol and does send DA. It is possible that i might miss a simple configuration steps on UCS FI which is causing the trouble. If you point me out a check list that needs to be cleared for the server port on the UCS FI to work.

Appreciate all your help.

Thanks,

David McFarland Mon, 11/28/2011 - 18:48

The 2232 is not supported with the current UCSM release code, 2.0(1X). It will not work. Currently, the only supported topology is per the doc.

Dave

niranjandas Mon, 11/28/2011 - 19:07

Ok I understand it. I have 2248T also. But i think i am stuck with a different problem than FEX. Some configuration appears wrong to me on the server port.

If i look the running config from NXOS cli show command it shows,

cisco-A-A(nxos)# show running-config interface ethernet 1/15

!Command: show running-config interface Ethernet1/15

!Time: Tue Nov 29 02:05:43 2011

version 4.2(1)N1(1.4i)

interface Ethernet1/15

  description S: Server

  pinning server

  switchport mode trunk

  switchport trunk native vlan 4044

  switchport trunk allowed vlan 4044,4047

  no shutdown

Now i can not figure it how it is part of native vlan 4044 and switchport trunk allowed vlan 4044, 4047. I dont have a associated VSAN for these VLAN. If i try to create one with these VLAN, UCSM  field becomes "red" and does not allow me to put 4044, 4047 in the FCoE VLAN field. On the other hand i have not found a command to change the VLAN for the interface. Until the VLAN which are allowed for the 10G interface, have one VSAN asscoaited with it, FCoE wont happen per my understanding.

David McFarland Mon, 11/28/2011 - 19:18

If etherent 1/15 is your 2248 connection, it appears correct. The 2248 connects to the LOM port on the C-series server. It only passes control plane traffic. All control plane traffic is carried on VLAN 4044, 4047. The data plane traffic VLAN is user defined and would be via the CNA connection to the fabric interconnect.

VLANs 4044 and 4047 are not end user configurable.

In the current implementation, the 2248-LOM is the control plane and the CNA-FI is the data plane. It's not quite the same as the B-series implementation where the chassis IOM passes both control and data plane to the FI.

Dave

niranjandas Mon, 11/28/2011 - 19:42

Ok, probably i connected a FEX to that port earlier and it had the settings from there.

I am still not clear why the FI's server port does not send "Discovery Advertisement". Not sure how FCoE login is going to take place?

Actions

Login or Register to take actions

This Discussion

Posted November 23, 2011 at 1:42 PM
Stats:
Replies:8 Avg. Rating:5
Views:1567 Votes:0
Shares:0
Tags: No tags.
Categories: General UCS Hardware
+

Discussions Leaderboard