NAT-PT is not available on IOS 12.4

Unanswered Question
Nov 24th, 2011

Hello,

I have a Cisco IOS image named "c3660-ik9o3s-mz.124-18" installed. I've tried to configure IPv6 NAT-PT feature but the commands are not available. I disabled CEF as per one of the Cisco's articles but it doesn't help. I assume that NAT-PT is not supported since it is not mentioned in the CCIE's blueprint.

Your advice is highly appreciated.

Regards,

AM

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 1 (1 ratings)
fbovy Sat, 11/26/2011 - 00:12

Nat-pt is dead, deprecated, obsoletes!

No wonder it is no more shipped

Nat64 is its successor but not in iOS

iOS-XE or XR

Sent from Cisco Technical Support iPhone App

stmillet Sun, 11/27/2011 - 16:49

AM,

NAT-PT is supported in 12.4 Mainline, however is not complied into the featureset you are using. You will need to upgrade to the Enterprise Plus featureset to access this feature.

Now that aside, some clarification on the status of NAT-PT. It is still supported in IOS, and as of yet has not reached end of life status. HOWEVER, the protocol has sever limitations and has been deprecated by the IETF. The industry as a whole is moving toward NAT64, which is roadmapped for the IOS platforms at some point in the future. As pointed out this feature is currently suppored on our IOS-XR and IOS-XE platforms (read CRS-1 and ASR1k).

Feel free to play / experiment etc, however we would recommend against using in porduction. Please use with caution.

I hope this helps

Stephan

CARL LINDAHL Tue, 11/29/2011 - 07:09

This is all good and well that NAT-PT is dead, but when you invest in Cisco Nexus 7K platform and are stuck with buggy code that ipv6 neighbor process is broken and connectivity suffers, the only work around we have found for IPv6 connectivity is using IPv6 NAT-PT. Works great on a 2811.....

GIANRICO FICHERA Sat, 06/23/2012 - 03:24

The question is that I have a 7206VXR platform with NPE-G2 and I would like to give IPv6 services to my customers.

NAP-PT is supported because is not EOL. Is not dead.

You can disable DNS-ALG in NAT-PT and disable NAT46. You can configure a DNS64 server and use it with this configuration. I tried that and it works.

So NAT-PT - DNSALG - NAT46 = NAT64. I know that is not "exactly" the same thing (alg support, CEF support) ...

RFC 4966 is mandatory only for big carriers?

Tell me what do you think about this

bye

Gianrico Fichera

Actions

Login or Register to take actions

This Discussion

Posted November 24, 2011 at 6:22 AM
Stats:
Replies:7 Avg. Rating:1
Views:1815 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard