×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Unable to launch Topology Services in LMS 4.1

Answered Question
Nov 27th, 2011
User Badges:

When I try to Launch Topology Services from windows 7 client I am getting the following error message:

Cannot connect to ANIServer: ANIServer7.0-CCADLMS001


Attached is the screenshot for reference. Also attaching the SC QUERY and SYSTEMINFO files.


I have done the following steps so far:

  • Open the orb.properties file.
  • Windows: NMSROOT\lib\classpath

where NMSROOT is the directory where you have installed Cisco Prime LMS.

Set the property as follows:

jacorb.dns.enable=off

  • Go to Admin > Trust Management > Local Server > Certificate Setup.

The Certificate Setup page appears.

Enter the IP Address of the Cisco Prime LMS Server in the Hostname textbox.

Populate the other columns as explained in the Online help for Administration of Cisco Prime LAN Management Solution 4.1.

Click Apply to generate the self-signed certificate.

  • Restart the daemons by net stop crmdmgtd and net start crmdmgtd
  • checked the firewall settings and in the client and server. Tried disabling firewall also. No go.

Please help.


Regards,

Ramakrishnan Natarajan

Correct Answer by Michel Hegeraat about 5 years 8 months ago

Enable java logging and console display in the control panel java icon.


Post the log here.


Run "pdshow -brief" on the LMS server


Post the results


Can you client resolve CCADLMS001 to the server IP ?


Cheers,


Michel

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3.7 (3 ratings)
Loading.
Correct Answer
Michel Hegeraat Sun, 11/27/2011 - 04:22
User Badges:
  • Gold, 750 points or more

Enable java logging and console display in the control panel java icon.


Post the log here.


Run "pdshow -brief" on the LMS server


Post the results


Can you client resolve CCADLMS001 to the server IP ?


Cheers,


Michel

networklal Sun, 11/27/2011 - 05:38
User Badges:

Dear Michael,


Thanks a lot for the interest. The issue seems to be resolved now. After looking at your questions I tried the following:


I enabled the DNS entry  for the LMS server in our DNS servers and made sure it is resolving.

Then tried Topology services again and received the same error.

I then set jacorb.dns.enable=on

Then I checked the LMS server hostfiles and found that there were host entries for LMS hostname pointing to 127.0.0.1.

I removed the same

I then reissued the certificactes from Admin > Trust Management > Local Server > Certificate Setup with the hostname.

I then restarted the daemon services and it started workiing.


Thanks a lot.

Michel Hegeraat Sun, 11/27/2011 - 05:46
User Badges:
  • Gold, 750 points or more

Yes, only localhost should point to 127.0.0.1.


Cheers,


Michel

Martin Ermel Mon, 11/28/2011 - 10:13
User Badges:
  • Blue, 1500 points or more

Hi Michel,


I also noticed - now on the 3rd installation of LMS 4.1 on windows - that there was an entry of the hostname pointing to 127.0.0.1 in the hosts file.

see this thread for other problems with this entry:

https://supportforums.cisco.com/message/3455693#3455693


I amalmost certain that the installation procedure writes this stupid entry into the hosts file....

Michel Hegeraat Mon, 11/28/2011 - 23:09
User Badges:
  • Gold, 750 points or more

I confirm that Martin. Good spotting!. I just noticed it in a server I installed yesterday. These 2 lines were added to the hosts file.


127.0.0.1       localhost

127.0.0.1   LMS4


A bit silly for both, since these entries were allready in the hosts file, done by the windows install I think


127.0.0.1       localhost

::1             localhost


Cheers,


Michel

faizul_azaha Wed, 10/10/2012 - 00:23
User Badges:

Hi all,


I have the same problem here from Windows 7 client, but I'm using LMS 4.2.1 on Windows Server 2008 platform.


Can share with me, how to issue the certificate via Admin > Trust Management > Local Server > Certificate Setup.

I could not find this option in both LMS and Windows.


Thanks.

Faizul

faizul_azaha Wed, 10/10/2012 - 03:02
User Badges:

Hi Martin,


Thanks a lot for your help, I appreciate it.


Faizul

Actions

This Discussion

Related Content