I want to enable dhcpv6 over mpls vpn, what should I do ?

Unanswered Question
Dec 2nd, 2011

I read document http://www.cisco.com/en/US/docs/ios/ipv6/configuration/guide/ip6-dhcp.html not get. I don't know which router and interface configuration ?

Just Network Diagram:

[Internet IPv6] -- ASR1000(DHCPv6 Server) -- [PE1 -- PE2 -- PE3] -- 1800(Client DHCPv6); PE is 7600

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
fsebera Tue, 12/06/2011 - 07:35

If the DHCPv6 client and DHCPv6 server are on the same subnet (I.E. LOCAL SUBNET)

!

! GLOBAL CONFIG:

!

ipv6 dhcp pool REMOTE-SITE

prefix-delegation 1133:4608:52E:FAA0::FACE/64 0001000115FA54DF00EDA44DF23F (UID of PC)

prefix-delegation pool VLAN301

dns-server (ipv6-address-of-DNSv6-server)

domain-name SITE.COMPANY.COM

! And on the interface supporting LOCAL DHCPv6 clients:

!

!

interface FastEthernet0/0.301

description To SW3 Access-Switch

encapsulation dot1Q 301

ip address 172.16.3.1 255.255.255.0

ipv6 address 1133:4608:524F:FAB0::1/64

ipv6 enable ipv6 nd managed-config-flag

ipv6 nd other-config-flag

ipv6 dhcp server SITE3 rapid-commit preference 1 allow-hint

!

!

! ----------OR-------------

! If DHCPv6 server is not local, this setup will forward the DHCPv6 request to the DHCPv6 server, whereever it is.

!

!

interface FastEthernet0/0.201

description To SW2 (access switch)

encapsulation dot1Q 201

ip address 172.16.2.1 255.255.255.0

ipv6 address 1133:4608:524F:EBB0::1/64

ipv6 nd prefix default no-advertise

ipv6 nd managed-config-flag

ipv6 dhcp relay destination 1133:4608:524F:FFE0::12

fsebera Wed, 12/07/2011 - 12:39

Sorry, it's not UID it's DUID (my bad).

Anyway, from your PC command prompt (DOS), type in ipconfig /all, you will receive similar output to below.  Including the DUID # is used mainly for static DHCPv6 assignment, normally for printers and servers but can also be used for PC's.  Assigning the DUID is optional.

:

From what you have asked form above, I think you want to have PC generated DHCPv6 request leave your local remote LAN and cross the MPLS network back to your DHCPv6 server(s). By using these three lines on the local LAN interface:

ipv6 nd prefix default no-advertise

ipv6 nd managed-config-flag

ipv6 dhcp relay destination

will cause your 1800 series router to forward the PC's DHCPv6 request across the MPLS WAN.

:

One note, These instructions assume the MPLS provider supports IPv6 or has some provision to tunnel your IPv6 traffic OR you have a tunnel configure on the 1800 series router, I.E. Auto 6-to-4. If you use Auto 6-to-4 tunnel, the provider will only see IPv4 packets and all is good. There are MANY DIFFERENT options here.

:

Hope this helps

Frank

:

C:\Users\my-user-name>ipconfig /all

Windows IP Configuration  

Host Name . . . . . . . . . . . .  : --gone--  

Primary Dns Suffix  . . . . . . .  : --gone--  

Node Type . . . . . . . . . . . .  : Hybrid 

IP Routing Enabled. . . . . . . . : No  

WINS Proxy Enabled. . . . . . . .  : No  

DNS Suffix Search List. . . . . .  : --gone--

Ethernet adapter Local Area Connection* 15:  

Media State . . . . . . . . . . .  : Media disconnected  

Connection-specific DNS Suffix  .  : 

Description . . . . . . . . . . . : Juniper Network Connect Virtual Adapter 

Physical Address. . . . . . . . . : --gone--  

DHCP Enabled. . . . . . . . . . .  : Yes 

Autoconfiguration Enabled . . . . : Yes

Ethernet adapter Local Area Connection:  

Connection-specific DNS Suffix  . : --gone--  

Description . . . . . . . . . . . : Intel(R) 82577LM Gigabit Network Connection  

Physical Address. . . . . . . . . : MAC-ADDRESS HERE  

DHCP Enabled. . . . . . . . . . . : Yes  

Autoconfiguration Enabled . . . . : Yes  

Link-local IPv6 Address . . . . . : --gone--  

IPv4 Address. . . . . . . . . . . : --gone--  

Subnet Mask . . . . . . . . . . . : 255.255.254.0  

Lease Obtained. . . . . . . . . . : Monday, November 21, 2011 8:00:41 AM  

Lease Expires . . . . . . . . . . : Friday, December 09, 2011 8:11:57 AM  

Default Gateway . . . . . . . . . : --gone--  

DHCP Server . . . . . . . . . . . : --gone--  

DHCPv6 IAID . . . . . . . . . . . : 2556323357  

DHCPv6 Client DUID. . . . . . . . : 00-02-10-51-21-BA-44-11-AF-55-C3-11-22-3F  

DNS Servers . . . . . . . . . . . : --gone--

                                    --gone--  

Primary WINS Server . . . . . . . : --gone--  

Secondary WINS Server . . . . . . : --gone--  

NetBIOS over Tcpip. . . . . . . . : Enabled

plawansai Wed, 12/07/2011 - 17:28

I am service provider. In real network, 1800 copy to ONT and ASR is Bras.

Actions

Login or Register to take actions

This Discussion

Posted December 2, 2011 at 2:15 AM
Stats:
Replies:4 Avg. Rating:
Views:974 Votes:0
Shares:0
Tags: mpls, vrf, mpls/vpn, l3, dhcpv6
+

Related Content

Discussions Leaderboard