×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

DCI and OTV

Unanswered Question
Dec 8th, 2011
User Badges:

Hi,

Please see diagram attached.We need to connect two datacentres and run OTV .two 10 g links between datacentres are dark fiber and configured in Layer 3 port channel ahd also a OTV  join interface.due to some requiremnets OTV vdc has vPC running between each site locally.I have posted my config, please review and see if it can work.I know its not recommend way but we have certain requirmrnts to run this way.




DC1


7k1


interface port-channel100

  description "OTV join link"

  ip address 1.1.1.1/30



interface Overlay0

  otv join-interface port-channel100

  otv extend-vlan 20

  otv use-adjacency-server 1.1.1.1  1.1.1.2 unicast-only

  otv adjacency-server unicast-only

  no shutdown



ip route 0.0.0.0/0 1.1.1.2

otv site-identifier 0001.0001.0001



7K2


same config


----------------------------


DC2


7K1


interface port-channel100

description "OTV join link"

ip address 1.1.1.2/30



interface Overlay0

otv join-interface port-channel100

otv extend-vlan 20

otv use-adjacency-server 1.1.1.2 1.1.1.1 unicast-only

otv adjacency-server unicast-only

no shutdown



ip route 0.0.0.0/0 1.1.1.1

otv site-identifier 0002.0002.0002



7K2



same config

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
mwlangedijk Sat, 01/14/2012 - 18:11
User Badges:

Make sure you PVC domains are different, also there is no local site vlan, you need this for the two 7ks to select an AED



Sent from Cisco Technical Support iPad App

mohammedrafiq Sun, 01/15/2012 - 06:59
User Badges:

Hi thanks for reply,


vPC domain in both DC's are diffrent.Can you explain bit further that why is necessary , not to have site local vlan?


Currently site local vlan 99 has been configured in all the VDC's in both datacentres.


Regards,

mwlangedijk Sun, 01/15/2012 - 09:05
User Badges:

Hi,


The two 7K's elect an authoritative edge device over the site vlan, the active AED will forward traffic (assuming you are not loadbalancing). If you don't have a local site vlan it will simply not work, i don't even think the overlay interface will come up without it.


Martijn

Jerry Ye Sun, 01/15/2012 - 09:47
User Badges:
  • Cisco Employee,

Like MWLANGEDIJK said, you need to have site VLAN for OTV edge device to elect AED. I don't see the OTV internal interface configuration and I cannot provide any advise. If you use the command show otv, you can see the status of the site-vlan. Here is a sample output from my lab (BTW, I am using multicast, but the site-vlan config is the same as unicast):


Pri-DC-OTV-1# sh otv


OTV Overlay Information

Site Identifier 0000.0000.0100


Overlay interface Overlay0


VPN name            : Overlay0

VPN state           : UP

Extended vlans      : 10-11 20-21 30-31 40-41 (Total:8)

Control group       : 239.0.0.1

Data group range(s) : 232.1.1.0/24

Join interface(s)   : Po1121 (10.10.101.2)

Site vlan           : 111 (up)

AED-Capable         : Yes

Capability          : Multicast-Reachable


One really import information about site-vlan, it should not be extended over OTV, it is local to each site.


Below is the command guide for your reference:


http://www.cisco.com/en/US/docs/switches/datacenter/sw/5_x/nx-os/otv/command/reference/basics_otv_cmds_external_docbase_0900e4b181582ec7_4container_external_docbase_0900e4b18215d854.html#wp1826603


HTH,

jerry

mohammedrafiq Sun, 01/15/2012 - 11:51
User Badges:

Hi,

The site VLAN is configured and OTV is working fine, except below  duplicate address error message.not sure why this error is generated.its the MAC add of int e3/1 which is part of int po100(join int).




""2012 Jan 13 14:34:07 otv2 %ISIS_OTV-4-LAN_DUP_SYSID: isis_otv-default [28740] L1 LAN IIH - Duplicate system ID 4055.3927.d1c2 detected over Overlay0 from 4055.3927.d1c2"""""



otv2(config-if-overlay)#  sh otv


OTV Overlay Information

Site Identifier 0002.0002.0002


Overlay interface Overlay0


VPN name            : Overlay0

VPN state           : UP

Extended vlans      : 101 103 105 107 191 193 200 300-303 (Total:11)

Join interface(s)   : Po100 (1.1.1.2)

Site vlan           : 1001 (up)

AED-Capable         : Yes

Capability          : Unicast-Only

Is Adjacency Server : Yes

Adjacency Server(s) : 1.1.1.2 / 1.1.1.1


otv2(config-if-overlay)# sh otv isis


ISIS process : default

VPN: Overlay0

  System ID : 4055.3927.d1c2  IS-Type : L1

  SAP : 439  Queue Handle : 12

  Maximum LSP MTU: 1392

  Graceful Restart enabled. State: Inactive

  Last graceful restart status : none

  Metric-style : advertise(wide), accept(narrow, wide)

  Area address(es) :

    00

  Process is up and running

  VPN ID: 53

  Incremental update routes during SPF run

  Stale routes during non-graceful controlled restart

  Interfaces supported by OTV-IS-IS :

    Overlay0

Level 1

Authentication type and keychain haven't been configured

Authentication check is specified

  Address family IPv4 unicast :

    Number of interface : 1

    Adjacency check disabled

    Distance : 115

  Address family IPv6 unicast :

    Number of interface : 1

    Adjacency check disabled

    Distance : 115

  Address family MAC unicast :

    Number of interface : 1

    Adjacency check disabled

    Distance : 115

  L1 Next SPF: Inactive



-otv2(config-if-overlay)# sh int e3/1

Ethernet3/1 is up

  Dedicated Interface

  Belongs to Po100

  Hardware: 10000 Ethernet, address: 4055.3927.d1c2 (bia ccef.4823.b349)

  Description: * OTV

  MTU 9216 bytes, BW 10000000 Kbit, DLY 10 usec

  reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA

  full-duplex, 10 Gb/s, media type is 10G

  Beacon is turned off

  Auto-Negotiation is turned off

  Input flow-control is off, output flow-control is off

  Rate mode is dedicated

  Switchport monitor is off

  EtherType is 0x8100

  Last link flapped 13:40:35

  Last clearing of "show interface" counters never

  30 seconds input rate 5040648 bits/sec, 766 packets/sec

  30 seconds output rate 54894728 bits/sec, 4642 packets/sec

  Load-Interval #2: 5 minute (300 seconds)

    input rate 7.63 Mbps, 894 pps; output rate 32.70 Mbps, 2.83 Kpps

  L3 in Switched:

    ucast: 0 pkts, 0 bytes - mcast: 0 pkts, 0 bytes

  L3 out Switched:

    ucast: 0 pkts, 0 bytes - mcast: 0 pkts, 0 bytes

  RX

    3094425998 unicast packets  353521 multicast packets  19 broadcast packets

    3094779539 input packets  3053498432578 bytes

    284395082 jumbo packets  0 storm suppression packets

    0 runts  0 giants  1 CRC  0 no buffer

    1 input error  0 short frame  0 overrun   0 underrun  0 ignored

    0 watchdog  0 bad etype drop  0 bad proto drop  0 if down drop

    0 input with dribble  0 input discard

    0 Rx pause

  TX

    11996399744 unicast packets  353521 multicast packets  21 broadcast packets

    11996753286 output packets  17406552054383 bytes

    433788413 jumbo packets

    0 output error  0 collision  0 deferred  0 late collision

    0 lost carrier  0 no carrier  0 babble  0 output discard

    0 Tx pause

  7 interface resets

Jerry Ye Sun, 01/15/2012 - 17:59
User Badges:
  • Cisco Employee,

What software version? 5.2(1)?


Regards,

jerry

Jerry Ye Mon, 01/16/2012 - 15:43
User Badges:
  • Cisco Employee,

You are hitting the following bug:


CSCtw82691


It is fixed in 5.2(3a).


HTH,

jerry

boris.kudr Wed, 10/23/2013 - 20:12
User Badges:
  • Bronze, 100 points or more

Hi Jerry,


I think I am facing the same bug in 6.1.2

Could you send me a copy of the bug description? It apprears to be in a protected section of bug tool.


Thank you in advance.


Cheers,

Boris

Jerry Ye Mon, 10/28/2013 - 06:50
User Badges:
  • Cisco Employee,

Hi Boris,


Bug, CSCtw82691 is already fixed in NX-OS 5.2(3a). I don't believe your issue is the same.


Regards,

jerry

Actions

This Discussion

 

 

Trending Topics: Other DC Subjects