×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Nexus 5K VPC Consistency issue

Unanswered Question
Dec 13th, 2011
User Badges:

Issue : VPC consistency failed and VPC status is down on some of port channels wher as some other is working . This issue is for po18 only . once this is resolved will work on other Portchannels.




Topology,:


                        5k1                                   5k2

                            |                                      |

                            |                                      |

                            |                                      |

                          fex3                                 fex4                   


                                   \                               /

                                    \                             /

                                     \                           /

                                      \                          /

                                             server



Log for 5k3


5K3# sh run int e103/1/18


!Command: show running-config interface Ethernet103/1/18

!Time: Tue Dec 13 22:31:37 2011


version 5.0(3)N1(1b)


interface Ethernet103/1/18

description *** Connected to GLARWI457-DATA1 ***

switchport access vlan 201

spanning-tree port type edge

channel-group 18 mode active


5K3#

5K3# sh run int po 18


!Command: show running-config interface port-channel18

!Time: Tue Dec 13 22:33:50 2011


version 5.0(3)N1(1b)


interface port-channel18

description ***Connected to GLAWI457***

switchport access vlan 201

vpc 18


5K3# sh vpc brief

Legend:

               (*) - local vPC is down, forwarding via vPC peer-link


vPC domain id                   : 1  

Peer status                     : peer adjacency formed ok    

vPC keep-alive status           : peer is alive                

Configuration consistency status: success

Per-vlan consistency status     : success                      

Type-2 consistency status       : success

vPC role                       : primary                      

Number of vPCs configured       : 8  

Peer Gateway                   : Disabled

Dual-active excluded VLANs     : -

Graceful Consistency Check     : Enabled


vPC Peer-link status

---------------------------------------------------------------------

id   Port   Status Active vlans  

--   ----   ------ --------------------------------------------------

1   Po1   up     1-2,50-52,70-72,150,200-201,400,600,800               


vPC status

----------------------------------------------------------------------------

id     Port       Status Consistency Reason                     Active vlans

------ ----------- ------ ----------- -------------------------- -----------

4     Po4         down* failed     Consistency Check Not     -        

                                     Performed                            

5     Po5         down* failed     Consistency Check Not     -        

                                    Performed                            

10     Po10       up     success     success                   50-51,150,2

                                                                 00-201,400

11     Po11       up     success     success                   50-51,150,2

                                                                 00-201,400

12     Po12       up     success     success                   50-51,150,2

                                                                 00-201,400

13     Po13       up     success     success                   50-51,150,2

                                                                 00-201,400

18     Po18       down* success     success                   -        

19     Po19        down* success     success                   -        


GLASW-5K3# sh vpc consistency-parameters vpc 18


   Legend:

       Type 1 : vPC will be suspended in case of mismatch


Name                       Type Local Value           Peer Value           

-------------               ---- ---------------------- -----------------------

Shut Lan                   1     No                     No                  

STP Port Type               1     Default               Default              

STP Port Guard             1     None                   None                

STP MST Simulate PVST       1     Default               Default              

Allowed VLANs               -     201                   201             (check this  local and peer vlan )

Local suspended VLANs       -     -                     -                    

GLASW-5K3#

GLASW-5K3#



Log for 5k4



5K4# sh run int eth 113/1/18


!Command: show running-config interface Ethernet113/1/18

!Time: Tue Dec 13 22:31:03 2011


version 5.0(3)N1(1b)


interface Ethernet113/1/18

description *** Connected to GLAWI457-DATA2 ***

switchport access vlan 201

spanning-tree port type edge

channel-group 18 mode active


5K4#

5K4# sh run int po 18


!Command: show running-config interface port-channel18

!Time: Tue Dec 13 22:34:09 2011


version 5.0(3)N1(1b)


interface port-channel18

description ****Connected to GLAWI457***

vpc 18

switchport access vlan 201


5K4#

5K4# sh vpc brief

Legend:

               (*) - local vPC is down, forwarding via vPC peer-link


vPC domain id                   : 1  

Peer status                     : peer adjacency formed ok    

vPC keep-alive status           : peer is alive                

Configuration consistency status: success

Per-vlan consistency status     : success                      

Type-2 consistency status       : success

vPC role                       : secondary                    

Number of vPCs configured       : 8  

Peer Gateway                    : Disabled

Dual-active excluded VLANs     : -

Graceful Consistency Check     : Enabled


vPC Peer-link status

---------------------------------------------------------------------

id   Port   Status Active vlans  

--   ----   ------ --------------------------------------------------

1   Po1   up     1-2,50-52,70-72,150,200-201,400,600,800                


vPC status

----------------------------------------------------------------------------

id     Port       Status Consistency Reason                     Active vlans

------ ----------- ------ ----------- -------------------------- -----------

4     Po4         down* failed     Consistency Check Not     -        

                                     Performed                           

5     Po5         down* failed     Consistency Check Not     -        

                                     Performed                            

10     Po10       up     success     success                   50-51,150,2

                                                                 00-201,400

11     Po11       up     success     success                   50-51,150,2

                                                                 00-201,400

12     Po12       up    success     success                   50-51,150,2

                                                                 00-201,400

13     Po13       up     failed     Consistency Check Not     50-51,150,2

                                     Performed                  00-201,400

18     Po18       down* failed     Consistency Check Not     -        

                                     Performed                            

19     Po19       down* failed     Consistency Check Not     -        

                                     Performed                            


5K4# sh vpc consistency-parameters vpc 18


   Legend:

       Type 1 : vPC will be suspended in case of mismatch


Name                       Type Local Value          Peer Value            

-------------               ---- ---------------------- -----------------------

Shut Lan                   1     No                     No                  

STP Port Type               1     Default               Default             

STP Port Guard             1     None                   None                

STP MST Simulate PVST       1     Default               Default              

Allowed VLANs               -     201                   1                   (check here local and peer vlan )  

Local suspended VLANs       -     -                     -                    

5K4#

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
clunsfor Wed, 12/14/2011 - 12:57
User Badges:

Chandan,


What is the status of the physical interfaces and port-channel?  Do you see these as up if you do a `sh int` and `sh port-channel summary`?


Chris

chandanmajumdar Wed, 12/14/2011 - 14:39
User Badges:

Port channel and physical ports are down [line protocol down , configured and administratively UP] as the device is yet to be connectted by the DC engineer .

chandanmajumdar Wed, 12/14/2011 - 14:43
User Badges:

BUT For a different port channel [po 13 ] the portchannel , and physical interface and PO is up still the VPC is failing the consistency.


5K4# sh vpc brief

Legend:

                (*) - local vPC is down, forwarding via vPC peer-link


vPC domain id                   : 1  

Peer status                     : peer adjacency formed ok     

vPC keep-alive status           : peer is alive                

Configuration consistency status: success

Per-vlan consistency status     : success                      

Type-2 consistency status       : success

vPC role                        : secondary                    

Number of vPCs configured       : 8  

Peer Gateway                    : Disabled

Dual-active excluded VLANs      : -

Graceful Consistency Check      : Enabled


vPC Peer-link status

---------------------------------------------------------------------

id   Port   Status Active vlans   

--   ----   ------ --------------------------------------------------

1    Po1    up     1-2,50-52,70-72,150,200-201,400,600,800                 


vPC status

----------------------------------------------------------------------------

id     Port        Status Consistency Reason                     Active vlans

------ ----------- ------ ----------- -------------------------- -----------

4      Po4         down*  failed      Consistency Check Not      -         

                                      Performed                            

5      Po5         down*  failed      Consistency Check Not      -         

                                      Performed                            

10     Po10        up     success     success                    50-51,150,2

                                                                 00-201,400

11     Po11        up     success     success                    50-51,150,2

                                                                 00-201,400

12     Po12        up     success     success                    50-51,150,2

                                                                 00-201,400

13     Po13        up     failed      Consistency Check Not      50-51,150,2

                                      Performed                  00-201,400

18     Po18        up     success     success                    201       

19     Po19        up     success     success                    201       



5K4# sh int po 13

port-channel13 is up

vPC Status: Down, vPC number: 13 [packets forwarded via vPC peer-link]

  Hardware: Port-Channel, address: 0007.7dc9.fc4f (bia 0007.7dc9.fc4f)

  Description: "Connected to GLAVM403"

  MTU 1500 bytes, BW 2000000 Kbit, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA

  Port mode is trunk

  full-duplex, 1000 Mb/s

  Beacon is turned off

  Input flow-control is off, output flow-control is on

  Switchport monitor is off

  EtherType is 0x8100

  Members in this channel: Eth113/1/13, Eth113/1/14

  Last clearing of "show interface" counters never

  30 seconds input rate 106976 bits/sec, 13372 bytes/sec, 54 packets/sec

  30 seconds output rate 2132520 bits/sec, 266565 bytes/sec, 561 packets/sec

  Load-Interval #2: 5 minute (300 seconds)

    input rate 173.32 Kbps, 36 pps; output rate 2.44 Mbps, 419 pps

  RX

    403285418 unicast packets  171096 multicast packets  161845 broadcast packets

    403618359 input packets  275739294703 bytes

    138861776 jumbo packets  0 storm suppression bytes

    0 runts  0 giants  0 CRC  0 no buffer

    0 input error  0 short frame  0 overrun   0 underrun  0 ignored

    0 watchdog  0 bad etype drop  0 bad proto drop  0 if down drop

    0 input with dribble  0 input discard

    0 Rx pause

  TX

    1612098077 unicast packets  186946046 multicast packets  117268953 broadcast packets

    1916313076 output packets  947767205968 bytes

    431627748 jumbo packets

    0 output errors  0 collision  0 deferred  0 late collision

    0 lost carrier  0 no carrier  0 babble

    0 Tx pause

  5 interface resets


5K4# sh port-c summary

Flags:  D - Down        P - Up in port-channel (members)

        I - Individual  H - Hot-standby (LACP only)

        s - Suspended   r - Module-removed

        S - Switched    R - Routed

        U - Up (port-channel)

--------------------------------------------------------------------------------

Group Port-       Type     Protocol  Member Ports

      Channel

--------------------------------------------------------------------------------

1     Po1(SU)     Eth      LACP      Eth4/15(P)   Eth4/16(P)  

4     Po4(SD)     Eth      LACP      Eth4/13(I)  

5     Po5(SD)     Eth      NONE      Eth4/14(D)  

10    Po10(SU)    Eth      NONE      Eth113/1/33(P)  Eth113/1/34(P) 

11    Po11(SU)    Eth      NONE      Eth113/1/26(P)  Eth113/1/27(P) 

12    Po12(SU)    Eth      NONE      Eth113/1/8(P)  Eth113/1/9(P) 

13    Po13(SU)    Eth      NONE      Eth113/1/13(P)  Eth113/1/14(P) 

18    Po18(SU)    Eth      LACP      Eth113/1/18(P) 

19    Po19(SU)    Eth      LACP      Eth113/1/19(P) 

112   Po112(SU)   Eth      NONE      Eth4/1(P)    Eth4/2(P)   

113   Po113(SU)   Eth      NONE      Eth4/3(P)    Eth4/4(D)   

GLASW-5K4#





5K4# sh vpc consistency-parameters vpc 13


    Legend:

        Type 1 : vPC will be suspended in case of mismatch


Name                        Type  Local Value            Peer Value            

-------------               ----  ---------------------- -----------------------

Shut Lan                    1     No                     No                   

STP Port Type               1     Default                Default              

STP Port Guard              1     None                   None                 

STP MST Simulate PVST       1     Default                Default              

mode                        1     -                      on                   

Speed                       1     -                      1000 Mb/s            

Duplex                      1     -                      full                 

Port Mode                   1     -                      trunk                

Native Vlan                 1     -                      1                    

MTU                         1     -                      1500                 

Admin port mode             1     -                                           

Allowed VLANs               -     50-51,150,200-201,400  50-51,150,200-201,400

Local suspended VLANs       -     -                      -                    

GLASW-5K4#

clunsfor Thu, 12/15/2011 - 06:22
User Badges:

As you've probably seen now, until you have operational members in the port-channels, you'll see the vpc as failed and "consistency check not performed" on one of the switches.


Interestingly, the vpc consistency parameters are missing the local values for 5K4.  Have you tried doing a shut/no shut of po13 on 5K4, or removing and re-adding the vpc command to the port-channel?

Actions

This Discussion