×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

CUCM one side voice

Unanswered Question
Dec 26th, 2011
User Badges:

Hello All,



                  I am using Cisco call manager 6.0 and i am using public IP on it.I configure it well now my phone are registered from every network but i have one problem that my voice is going but i can't hear the another side voice. On my router or switch m not using any voice vlan or any rule so please advise me how to solve this problem ?


thanks



Mukesh

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Leonardo Tadeu Mon, 12/26/2011 - 15:31
User Badges:
  • Blue, 1500 points or more

Do you have a topology to provide? And do you have a firewall in your topology?


The IP Routing is working fine?


Thanks

Mukesh Kumar Mon, 12/26/2011 - 22:16
User Badges:

Hello Leonardotadeu,



                            Sorry dear i have no topology to provide u but i can explain it I am working on ISP and i my CUCM is connected with BGP running router and i have no firewall and ACL.I think my routing is running well that's why imy phone are registered and one side voice is coming,and on router i have no voip rules like voice vlan or anything so please tell me can i need any additional command on router or switch for Voip ?


Thanks in Advance


Regards


Mukesh

Gajanan Pande Mon, 12/26/2011 - 22:26
User Badges:
  • Cisco Employee,

Mukesh,


Are you using Cisco Hosted Collaboration Solution ( HCS ) ?


GP

Mukesh Kumar Mon, 12/26/2011 - 23:19
User Badges:

Hello Gajanan,


                         No m not using HCS.


Thanks

Leonardo Tadeu Tue, 12/27/2011 - 03:42
User Badges:
  • Blue, 1500 points or more

The problem occur between IP Phones on different networks? Or in the same network?


Regards

D_Lebedev Tue, 12/27/2011 - 03:25
User Badges:

Hi,

As a rule one way audio problems depends on routing issues.

If you have no back route,it will be so.

You should be able to ping phone IP and call destination IP from nearest switch to the phone.


http://www.scribd.com/doc/2584048/Cisco-Configuring-Voice-VLAN


http://www.cisco.com/en/US/docs/switches/lan/catalyst3550/software/release/12.2_25_see/configuration/guide/swvoip.html#wp1030825


Hope it helps.

Mukesh Kumar Tue, 12/27/2011 - 04:14
User Badges:

Hello Leonardotabeu,


         The voice problem is occur on both network local and public.all the phone of locan and public are registered with CUCM and call also going,but problem it that when the any phone are registered with public IP then voice is going and coming but when phone are registered with private(local) ip then the voice is going ans i have no any firewall or ACL in my network.


My configuration are:-


On router

interface GigabitEthernet0/3.522

encapsulation dot1Q 522

ip address 109.205.117.229 255.255.255.252


On switch


interface fa0/11

switchport voice vlan 522

switchport mode access

switchport port-fast


If you found any wrong in this configuration please tell me .



Thanks


Regards

Mukesh



CUCM :

Ip add:- 109.205.117.230

Leonardo Tadeu Tue, 12/27/2011 - 07:46
User Badges:
  • Blue, 1500 points or more

Sorry i dont unterstand can put like this the call  flow:


IP Phone A (Public IP) ---> CUCM ---> IP Phone B (LAN)


And point when the issue occur and in what direction.


Thanks

D_Lebedev Tue, 12/27/2011 - 21:28
User Badges:

IP Phone A (Public IP)---SW1---...---...---... ---> CUCM --->---SW2---...---... IP Phone B (LAN)


Can you ping SW2 from SW1?

Mukesh Kumar Tue, 12/27/2011 - 23:33
User Badges:

Hello All ,


Thanks for reply.


I am using this type of topology.


1.   IP Phone A (Public IP)---SW1---...---...---... ---> CUCM --->---SW2---...---... IP Phone B(Public IP) Both side voice


2.  IP Phone A (Public IP)---SW1---...---...---... ---> CUCM --->---SW2---...---... IP Phone B(Private IP)

                                                                                                              voice at only IP Phone A


3.IP Phone A (Private IP)---SW1---...---...---... ---> CUCM --->---SW1---...---... IP Phone B(private IP) no voice both side


If u found any problem in this topology please advise me.


thanks


Mukesh

D_Lebedev Wed, 12/28/2011 - 00:00
User Badges:

Hi,


So,check your routes.


You should be able ping without problems Private and Public IP in your network.

If you'll not be able to ping Phones,no voice will be.


Check routing tables ...

Mukesh Kumar Wed, 12/28/2011 - 03:20
User Badges:

Hello,


                          I can ping from my CUCM any Public IP and my CUCM ip is also pinging from any network so i think my routing is good but the IP of Phone is not the my DHCP subnet ip ,the phone taking ip from own network ao what may be this problem ?



thanks


Mukesh

D_Lebedev Wed, 12/28/2011 - 03:28
User Badges:

Ok.


So,


For example.


You have Phone A with 192.168.1.1 Address.

Phone B with 10.11.12.13 address.

On the SW for Phone A i thik you should have Voice vlan Ip address like 192.168.1.XXX

And on the SW for Phone B SW voice vlan address should be 10.11.12.XXX


If you have L2 switches,it doen't matter,then from your router or another L3 device,nearest to the phone A and Phone B

You should ping successfull.


ping 10.11.12.13 /source-interface 192.168.1.XXX


ping 192.168.1.1 /source-interface 10.11.12.XXX


So,Phones should (communicate) ping each other without problems.

Mukesh Kumar Wed, 12/28/2011 - 04:01
User Badges:

HI D,


                   I  explain my topology here:-


CUCM IP :- 109.205.117.230/30( Public IP)

DHCP Server IP:- 109.205.117.230

Primary TFTP Server IP Address(Option 150):- 109.205.117.230

DHCP Subnet:- 10.10.0.0/24


On router (CISCO 7200)

interface GigabitEthernet0/3.522

encapsulation dot1Q 522

ip address 109.205.117.229 255.255.255.252


On switch(Cisco C3550)


interface fa0/11

switchport voice vlan 522

switchport mode access

switchport port-fast


First IP Phone IP:-  117.199.123.15 (Voice can hear)

Second IpPhone IP:- 192.168.1.119 (NO voice hear   )


Auto registration is enable.


Sir please tell me if i have any wrong in this configuration.

Thanks in Advance


Regards


Mukesh

D_Lebedev Wed, 12/28/2011 - 06:15
User Badges:

Temporary give 192.168.1.119 to some PC/Laptop and try ping\trace 117.199.123.15


You will see where packets stop.

I'm sure it is routing based problem.


Everything is ok with your configuration i think.


I faced with same problem in our first branch installation.

If you have no routes to all Phone's subnets.You'll not be able to make 2 way calls.

Mukesh Kumar Wed, 12/28/2011 - 08:09
User Badges:

Hello D,


                           Yes you are right i have some packet drop when i do to tracert.but my public ip is advertised good and i can ping and trace it from any where and my "sh ip route" is also good.

So want i can do for it please advise me .


Thanks


Regards


Mukesh

michael.wilson@... Wed, 12/28/2011 - 08:24
User Badges:

What is doing the topology hiding? Sounds as if signaling is fine, but your rtp traffic is going else where.



Sent from Cisco Technical Support iPad App

arnela.jokhoo Thu, 12/29/2011 - 19:32
User Badges:

Seems like he has a nat issue?? public ip into private you have any firewalls between networks?

Actions

This Discussion