Outgoing calls through h323 gateway fails

Unanswered Question
Dec 26th, 2011

Hello!

Please help..I`m trying to set up a new CUCM 8.6.1(a). All is well, but it`s impossible to configure pass calls through h323-gateway. Appropriate route-patterns and CSS are configured. Incoming calls over this h323-trunk successfully come to call-manager, but an outgoing call I hear the tube short beeps. I note that if I make the inter-cluster trunk, everything works in both directions.

P.S. On my existing CUCM 7.1.5 this problem did not exist.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
acampbell Tue, 12/27/2011 - 02:50

Hi,

Can you provide the router config and explain the number being dialled

Regards

Alex

dmitry.bondarovich Tue, 12/27/2011 - 02:59

Yes, certainly. Once again I will specify that with this router successfully works my existing CUCM 7.1.5

For example I try to dial number 94571919, which matching with a "dial-peer voice 106 pots"

version 15.1

service nagle

no service pad

service tcp-keepalives-in

service tcp-keepalives-out

service timestamps debug datetime msec localtime

service timestamps log datetime msec localtime

service password-encryption

service sequence-numbers

!

hostname M69-KFB-VOICE

!

boot-start-marker

boot system flash:c2951-universalk9_npe-mz.SPA.151-3.T.bin

boot-end-marker

!

card type e1 0 3

logging buffered 51200 informational

!

aaa new-model

!

aaa authentication login default group radius local

aaa authorization exec default group radius local

!

!

aaa session-id common

clock timezone MSK 4 0

network-clock-participate wic 3

network-clock-select 1 E1 0/3/0

!

no ipv6 cef

ip source-route

ip cef

!

!

!

!

!

no ip domain lookup

ip domain name *.ru

ip name-server 8.8.8.8

multilink bundle-name authenticated

!

!

!

!

isdn switch-type primary-net5

!

voice-card 0

!

!

!

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

redirect ip2ip

fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none

h323

  emptycapability

  h225 signal overlap

  h225 connect-passthru

  h245 passthru tcsnonstd-passthru

sip

!

voice class codec 1

codec preference 1 g729r8

codec preference 2 g711alaw

codec preference 3 g711ulaw

!

!

!

!

voice translation-rule 1

rule 1 /44.../ /8124571919/ type any subscriber plan any isdn

rule 2 /41.../ /8126110000/ type any subscriber plan any isdn

rule 3 /.*/ /8124571919/

!

voice translation-rule 10

rule 1 reject /9287473224/

!

voice translation-rule 30

rule 1 /.*/ /44700/

!

voice translation-rule 50

rule 1 /.*/ /99051000127991/

!

!

voice translation-profile Gorod

translate calling 1

!

voice translation-profile Incoming-Call-Block

translate calling 10

!

voice translation-profile SKYPE

translate calling 50

!

voice translation-profile incoming_from_SIP_provider

translate called 30

!

!

fax receive called-subscriber $d$

mta send server 10.105.4.40 port 25

mta send subject CISCO FAX SERVER

mta send with-subject both

mta send filename fax.tif date

mta send postmaster *

mta send mail-from hostname *.ru

mta send mail-from username robot

!

application

service tkbmenu flash:vxml-ivr/TKB2.vxml

!

service fax flash:app_fax_detect.2.1.2.3.tcl

  param mode listen-first

  param prompt flash:/Prompts/en/en_default_fax.au

!

service KITFinance flash:kit-ivr/KFB-RU.vxml

!

!

vxml audioerror

vxml version 2.0

license udi pid CISCO2951/K9 sn FCZ143371ND

hw-module pvdm 0/0

!

hw-module pvdm 0/1

!

!

!

archive

log config

  logging enable

  notify syslog contenttype plaintext

  hidekeys

!

redundancy

!

!

controller E1 0/3/0

framing NO-CRC4

pri-group timeslots 1-31

!

controller E1 0/3/1

shutdown

framing NO-CRC4

pri-group timeslots 1-31

!

ip ssh version 2

!

!

!

!

interface Loopback0

ip address 10.56.253.2 255.255.255.0

!

interface GigabitEthernet0/0

description ### MNG ###

ip address 10.56.0.50 255.255.255.0

duplex auto

speed auto

!

interface GigabitEthernet0/1

description ### DATA ###

ip address 10.59.1.5 255.255.255.0

duplex auto

speed auto

h323-gateway voip bind srcaddr 10.59.1.5

!

interface GigabitEthernet0/2

description ### INET ###

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/3/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

no cdp enable

!

interface Serial0/3/1:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

no cdp enable

!

ip forward-protocol nd

!

ip http server

ip http authentication aaa

ip http secure-server

ip http secure-port 4434

!

ip route 0.0.0.0 0.0.0.0 10.56.0.1

!

ip access-list standard SNMP-Access

permit 10.58.10.58

permit 10.57.5.21

permit 10.57.5.25

permit 10.105.4.10

permit 10.105.1.20

!

logging trap debugging

logging source-interface GigabitEthernet0/0

logging 10.57.5.21

!

nls resp-timeout 1

cpd cr-id 1

!

!

control-plane

!

!

voice-port 0/0/0

cptone RU

description TEST

!

voice-port 0/0/1

cptone RU

!

voice-port 0/0/2

cptone RU

!

voice-port 0/0/3

cptone RU

!

voice-port 0/3/0:15

!

voice-port 0/1/0

cptone RU

!

voice-port 0/1/1

cptone RU

!

voice-port 0/1/2

cptone RU

!

voice-port 0/1/3

cptone RU

description ### DCF_FAX ###

!

voice-port 0/3/1:15

!

voice-port 0/2/0

cptone RU

!

voice-port 0/2/1

cptone RU

!

!

!

mgcp profile default

!

!

dial-peer voice 100 pots

description Telephony-Operator

translation-profile outgoing Gorod

preference 1

destination-pattern 9810T

direct-inward-dial

port 0/3/0:15

prefix 810

no sip-register

!

dial-peer voice 102 pots

description Telephony-Operator

translation-profile outgoing Gorod

preference 1

destination-pattern 98[^1].........

direct-inward-dial

port 0/3/0:15

prefix 8

no sip-register

!

dial-peer voice 104 pots

description Telephony-Operator

preference 1

destination-pattern 90T

direct-inward-dial

port 0/3/0:15

prefix 0

no sip-register

!

dial-peer voice 106 pots

description Telephony-Operato

translation-profile outgoing Gorod

call-block translation-profile incoming Incoming-Call-Block

call-block disconnect-cause incoming call-reject

preference 1

destination-pattern 9[^8]......

direct-inward-dial

port 0/3/0:15

no sip-register

!

dial-peer voice 1100 voip

description ### Internal_numbers ###

call-block translation-profile incoming Incoming-Call-Block

call-block disconnect-cause incoming call-reject

destination-pattern 4....

session target ipv4:10.97.4.4

codec g711ulaw

no vad

!

dial-peer voice 1001 pots

service tkbmenu

incoming called-number 6110000

direct-inward-dial

!

dial-peer voice 1101 voip

description ### Redirect to Msk Willstream ###

destination-pattern 1....

session target ipv4:10.97.4.4

codec g711ulaw

no vad

!

dial-peer voice 1002 pots

description TEST

destination-pattern 49998

port 0/0/0

no sip-register

!

dial-peer voice 1003 pots

description ### DCF_FAX ###

destination-pattern 41233

port 0/1/3

no sip-register

!

dial-peer voice 1004 pots

description ### 3323990_44950 ###

destination-pattern 44950

port 0/0/0

no sip-register

!

dial-peer voice 1005 pots

description ### 3323260_44350 ###

destination-pattern 44350

port 0/0/1

no sip-register

!

dial-peer voice 1006 pots

description ### 3348823_44355 ###

destination-pattern 44355

port 0/0/2

no sip-register

!

dial-peer voice 1007 pots

description ### 3323266_44952 ###

destination-pattern 44952

port 0/0/3

no sip-register

!

dial-peer voice 1008 pots

description ### 3323291_44352 ###

destination-pattern 44352

port 0/1/0

no sip-register

!

dial-peer voice 1102 voip

description ### Avaya ###

destination-pattern [1-3,5-8]....

session target ipv4:10.97.4.4

dtmf-relay h245-alphanumeric

codec g711ulaw

no vad

!

dial-peer voice 1009 pots

description ### ISDN-IVR ###

call-block translation-profile incoming Incoming-Call-Block

call-block disconnect-cause incoming call-reject

service kitfinance

incoming called-number 4571919

direct-inward-dial

no sip-register

!

dial-peer voice 1111 voip

description ### INCOMING_SIP ###

translation-profile incoming SKYPE

huntstop

answer-address 99051000127991

redirect ip2ip

session protocol sipv2

incoming called-number 99051000127991

voice-class codec 1 

no voice-class sip session refresh

no vad

!

dial-peer voice 1010 pots

description ### FAX-DEPOSITARIUM ###

destination-pattern 44951

port 0/1/1

!

dial-peer voice 1103 voip

description ### Avaya_Backup ###

destination-pattern [1-3,5-8]....

session target ipv4:10.97.4.5

dtmf-relay h245-alphanumeric

codec g711ulaw

no vad

!

dial-peer voice 1200 pots

description ### ISDN-IVR_8-800 ###

call-block translation-profile incoming Incoming-Call-Block

call-block disconnect-cause incoming call-reject

service kitfinance

incoming called-number 3323529

direct-inward-dial

no sip-register

!

dial-peer voice 1011 pots

description ### FAX-SERVER ###

destination-pattern 44999

port 0/2/0

no sip-register

!

dial-peer voice 110 pots

service fax

incoming called-number 3323260

direct-inward-dial

forward-digits all

!

dial-peer voice 111 mmoip

service fax_on_vfc_onramp_app out-bound

destination-pattern 3323260

information-type fax

session target mailto: *clients@brokerkf.ru

!

dial-peer voice 101 pots

description Telephony-Operator

translation-profile outgoing Gorod

preference 2

destination-pattern 9810T

direct-inward-dial

port 0/3/1:15

prefix 810

no sip-register

!

dial-peer voice 103 pots

description Telephony-Operator

translation-profile outgoing Gorod

preference 2

destination-pattern 98[^1].........

direct-inward-dial

port 0/3/1:15

prefix 8

no sip-register

!

dial-peer voice 105 pots

description Telephony-Operator

preference 2

destination-pattern 90T

direct-inward-dial

port 0/3/1:15

prefix 0

no sip-register

!

dial-peer voice 107 pots

description Telephony-Operator

translation-profile outgoing Gorod

preference 2

destination-pattern 9[^8]......

direct-inward-dial

port 0/3/1:15

no sip-register

!

dial-peer voice 1105 voip

description ### Lync ###

destination-pattern 33...

session target ipv4:10.97.4.4

dtmf-relay h245-alphanumeric

codec g711ulaw

no vad

!

dial-peer voice 1020 pots

description ### IT FAX ###

destination-pattern 44710

port 0/1/2

!

dial-peer voice 1104 voip

destination-pattern 10.

session target ipv4:10.57.4.10

dtmf-relay h245-alphanumeric

codec g711ulaw

no vad

!

!

num-exp 3261318 41237

num-exp 3261349 44731

num-exp 3261351 44734

num-exp 3323297 41243

num-exp 3320032 44934

num-exp 3323296 44020

num-exp 7024101 44560

num-exp 7024142 44922

num-exp 3261315 44896

num-exp 3323295 41233

num-exp 3323266 44952

num-exp 3348823 44355

num-exp 99051000127991 41235

num-exp 4571999 44503

num-exp 3323291 44352

num-exp 3323290 44950

num-exp 2400101 48533

num-exp 3268890 44700

!

!

!

gatekeeper

shutdown

!

!

call-manager-fallback

secondary-dialtone 9

max-conferences 8 gain -6

transfer-system full-consult

ip source-address 10.59.1.5 port 2000

max-ephones 200

max-dn 200

system message primary Backup_Telephony!

system message secondary Backup_Telephony!

transfer-pattern .T

!

!

!

line con 0

line aux 0

line vty 0 4

exec-timeout 100 0

logging synchronous

transport input ssh

line vty 5 15

exec-timeout 100 0

logging synchronous

transport input ssh

!

scheduler allocate 20000 1000

ntp server 10.96.0.1 source GigabitEthernet0/0

end

acampbell Tue, 12/27/2011 - 03:42

Hi,

Just to test can you add these lines to the config

!

voice service voip

no ip address trusted authenticate

!

Regards

Alex

acampbell Tue, 12/27/2011 - 04:06

Hi,

As you said dial peer 106 POTS should be matched.

What about a VOIP dial peer from the new CUCM which H323 VOIP dial peer matches the CUCM

Regards

Alex

torsten.brink Tue, 12/27/2011 - 04:34

Have you checked call routing on CUCM and can you confirm that h.323 messages are received on GW, when doing outbound calls?

Cheers

Torsten

Sent from Cisco Technical Support iPhone App

Carlo Poggiarelli Tue, 12/27/2011 - 07:48

Hi.

Can you send us the output of a debug voip dialpeer inout and a debug isdn q931 during an outgoing call?

Thanks

Regards

Carlo

dmitry.bondarovich Tue, 12/27/2011 - 21:11

Hi.

I can`t send these debugs because on a router doesn't come any traffic from my CUCM 8.6.1.

On the CUCM all necessary rout-patterns are adjusted. I repeat that if I make inter-cluster trunk instead of h323-gateway then all works perfectly.

May be its a bug in the CUCM 8.6.1??

Unfortunately, I don't have any appropriate smartnets to open a case in TAC

Carlo Poggiarelli Tue, 12/27/2011 - 22:04

Hi.

Just a check...

Can you try to put your H323 gateway in a route group than in a route list and use this RL for route patterns.

Let me know.

Regards

Carlo

dmitry.bondarovich Tue, 12/27/2011 - 22:09

Carlo,

I already tried it to do - doesn't help...

May be it`s necessary somewhere in CUCM-services something check/uncheck..I`m in confusion..

dmitry.bondarovich Tue, 01/10/2012 - 03:34

Hi Arnela

don`t direct attention on my IOS-gateway. In parallel with the problem CUCM 8.6.1 I have the CUCM 7.1.5 with identical settings, which works fine.I can use various devices on another side of my 323-trunk and outgoing calls won't work.

arnela.jokhoo Fri, 12/30/2011 - 05:49

just a note, your second controller is shutdown. If you need it bring it up

Sent from Cisco Technical Support iPhone App

dmitry.bondarovich Wed, 01/11/2012 - 01:24

Hi all!

I see the trace files in my CUCM 8.6.1 and see the next one message (when I call from CUCM to h323 gateway):

(88) Incompatible destination

The cause could be one of the following occurrences:

•     The number being dialed is not capable of the type of call.

You are calling a restricted line in unrestricted mode.

You are calling a POTS phone using unrestricted mode.

What this mean and where I should search my problem??

sensanka Wed, 01/11/2012 - 02:35

Hi Dmitry,

Can you add bearer-cap speech under voice port like below just for testing

voice-port 0/3/0:15

bearer-cap speech

Regards,

Senthil

dmitry.bondarovich Wed, 01/11/2012 - 02:40

Hi SenthilKumar,

don`t direct attention on my IOS-gateway. In parallel with the  CUCM 8.6.1 I have the CUCM 7.1.5 with identical settings, which works  fine.I can use various devices on another side of my 323-trunk and  outgoing calls won't work. My problem - directly in CUCM 8.6.1

P.S. I try to add bearer-cap speech - still not work

sensanka Wed, 01/11/2012 - 02:45

Hi Dmitry,

In CUCM CDR, do you see the 88 cause code released by source or destination. If it is destination can  you share the complete set of logs like CM Services, debug isdn q931 and debug voip dial-peer inout

Regards,

Senthil

dmitry.bondarovich Wed, 01/11/2012 - 02:50

Hi SenthilKumar,

It`s a source 88-code which generated by CUCM and I can see any traffic on my IOS-gateway.

sensanka Wed, 01/11/2012 - 05:41

Hi Dmitry,

Can you share the logs for the failed call, so that we can check on that

Regards,

senthil

sensanka Thu, 01/12/2012 - 00:59

Hi Dmitry,

Call Manager sends the Setup Message to the Gateway and immediately it gets Realease Messages with Incompatable Destination as the cause.

Setup Message : Sent

SETUP, pd = 8, callref = 0x0004

Bearer Capability i = 0x0800900A2, ITU-T standard, Speech, Circuit mode, 64k, mu-law

Display i = 'Bond'

Calling Party Number i = '44002' - Plan: Unknown,Type: Unknown, Presentation Allowed,User-provided, verified and passed

Called Party Number i = '12345' - Plan: Unknown,Type: Unknown

Release Message : Received

RELEASE_COMP, pd = 8, callref = 0x8004

Cause i = 0x0810D8 - Incompatible destination

Did you had any chance to take the IOS Gateway Logs. If you have those please share. We may have to look how gateway treats this SETUP message.

Regards,

Senthil

sensanka Fri, 01/13/2012 - 00:15

Hi Dmitry,

Did you get any chance to find the issue.

Regards,

Senthil

dmitry.bondarovich Fri, 01/13/2012 - 00:37

Hi SenthilKumar,

problem with IOS-gateways was successfully resolved. There was a tall-fraud prevention issue on my router.

But problem with any 3d-party h323 gateways (etc. Avaya) still actually. When I make outgoing call from CUCM-Phone to Avaya-Phone then I have in CUCM logs cause code (34) no circuit/channel available

Actions

Login or Register to take actions

This Discussion

Posted December 26, 2011 at 10:48 PM
Stats:
Replies:24 Avg. Rating:
Views:1713 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard

Rank Username Points
1 21,026
2 15,047
3 10,314
4 7,999
5 4,856
Rank Username Points
140
95
72
66
55