×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

SRP 527 W - ADSL issue

Unanswered Question
Dec 28th, 2011
User Badges:

Hi there, I recently bought 2 SRP 527 W for  customer and i am trying to install them.  I have updated the firmware to the latest version.

Problem

It can detect BTs business ADSL but the Logical Link is not picking up.  I have checked and rechecked the setting with BT but no joy.  the original BT router works.

Can anyone please tell me what i am missing!

yours

K

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 1 (1 ratings)
Loading.
Andrew Hickman Fri, 12/30/2011 - 15:08
User Badges:
  • Cisco Employee,

Hi Kerr,


We haven't had issues with connecting to BT ADSL services with recent code, so I can only suggest there is still a configuration issue.


You might want to ensure that you are using PPPoA with VC-Mux and a PVC of 0/38.  Sounds like you have a rechecked the username and password.


If you share more detail of how you have the device configured, we might be able to provide more specific help.


Regards,


Andy

william.dalebout Fri, 04/26/2013 - 21:15
User Badges:

I can't get the PVC0 link to pick up either.  The ADSL link says "showtime" but the virtual link shows down->down.

No log, no error, no explanation, nothing in the manual.  I have no idea what's wrong and no idea how to find out.


It would be really nice if there was an autodetect feature.  I don't know the correct settings and the guy from my ISP couldn't figure them out either. 


It would make sense if the username and password were wrong, but my TP-Link router is working just fine with the same settings.


Help?

Andrew Hickman Mon, 04/29/2013 - 02:33
User Badges:
  • Cisco Employee,

Hi William,


Showtime just means that the modem has trained up (i.e. it knows there is a DSL service there).


You will need to configure the VPI/VCI values that your service provider uses.  The SRP does has an autodetect feature for this - but it only covers the most common values.  If your SP uses something less common, you will need to add this manually.


Once you have that, you need to select the correct encapsulation, address and authentication settings.  Again, your SP should be able to tell you this. Most common here is PPPoA, but your service may be different.  Addressing would typically always be automatic with PPP services - even if your SP provides you with a fixed IP address.


The only thing that might be worth explicitly checking with your SP is the authentication protocol.  The SRP supports CHAP - let me know if your SP only supports PAP.


So, questions for your ISP guy (please don't post your private account details here):


What is:

     VPI

     VCI

     Encapsulation (PPPoA?)

     Authentication Username

     Authentication Password

     Authentication protocol (CHAP/PAP?)


Regards,


Andy

william.dalebout Mon, 04/29/2013 - 03:57
User Badges:

Hi Andy, thanks.


That's the issue though, my ISP never heard of half of these settings.  I had them come over and fiddle with it for several hours and they couldn't figure it out.  I have my username and password and should probably be using PPPoE.  That's all they know.


Every other ADSL router on the market either auto-detects or has only the one setting.  How can I figure this out without trying them all?  By my math there are several dozen possible combinations.


Best,

W

Andrew Hickman Mon, 04/29/2013 - 04:28
User Badges:
  • Cisco Employee,

Hi William,


Seems odd that your ISP doesn't know these things - they are pretty standard characteristics.


Who is your ISP?


Andy

Andrew Hickman Mon, 04/29/2013 - 07:59
User Badges:
  • Cisco Employee,

Hi William,


I did a quick Google search.  You could try the following to see if you have any luck:



The username and password should have been provided by your ISP.  Don't worry about the service name - you can leave that blank.


There is also a possibility that the service is locked to your TP Link device MAC address.  You could try using that to configure the MAC address clone feature (don't click on "clone your PC's MAC", just enter the address manually - it should be printed somewhere on the TP Link device.


Hope that helps,


Andy

william.dalebout Mon, 04/29/2013 - 16:08
User Badges:

Hi Andy,


Thanks.


Now instead of "down" the status says "applied."  Is that good?



But the other page says the logical link is still down.



Is this progress?

I really wish this were in the manual somewhere.


Best,

W

CSCO12233910 Mon, 04/29/2013 - 18:14
User Badges:

you pppoe is not username ,the link status is down,not connect to ISP,no gateway is description wan link  is no up

CSCO12233910 Mon, 04/29/2013 - 18:54
User Badges:

ok ,your vc No(and isp give you username password). must correct,current VC  maybe is wrong,else the link can be up

CSCO12233910 Mon, 04/29/2013 - 19:06
User Badges:

try it with 0/35、0/81、8/81(user llc),and  where are you ,which province

william.dalebout Tue, 04/30/2013 - 01:30
User Badges:

Here are my current settings.  It's probably a matter of figuring out the right VPI/VCI settings but it doesn't hurt to be sure.


Andrew Hickman Tue, 04/30/2013 - 01:59
User Badges:
  • Cisco Employee,

Hi William,


You're right, it could just be a case of hunting for the right VPI/VCI setting.  Doesn't your TP Link device tell you how it is configured when it is working?


While you are trying different VPI/VCI settings, I'd recommend that you keep "keep alive" selected, rather than "Connect on demand".


Also I assume that your username and password is correct.  User name is typically of the form "[email protected]".


Al though it probably shouldn't make a difference, you might want to try using PPPoA instead of PPPoE (some ISPs limit their service to only allow PPPoA).


Regards,


Andy

william.dalebout Wed, 05/01/2013 - 00:13
User Badges:

Update: it works!


As per Mr. Chen's suggestion I got into my old modem (cat) and copied down all the settings.  Then I reset the SRP527 to factory settings, ran the wizard again and changed ONLY the VPI/VCI settings.  So she's up now and running well.


It's odd that the autodetect thingy didn't work, and it kinda blows that there's no error log.  But oh well.  Thanks to everyone for their help.

Actions

This Discussion

Related Content