Cisco 2112 Wireless LAN Controller and Apple TV Airplay

Answered Question
Sep 27th, 2011

Hi All,

I am having a trouble with using iTunes, iPhones and iPads on our Wireless LAN. We have the 2112 WLC and 10 1142N WAPs. If I do a network scan, I can see the Apple TV and see that port 5353 is open, which is Apple's Bonjour service.  However, if I try to play music/video in iTunes, or on an iPhone/iPad, I do not see the Airplay icon.  If I plug into the LAN, the Airplay icon appears immediately. I have created an allow all rule in the ACL but still no dice.  Any help would be greatly appreciated.

Thx

Benmar

This Solution has been added in the following document

https://supportforums.cisco.com/docs/DOC-21728

Attachment: 
I have this problem too.
0 votes
Correct Answer by George Stefanick about 2 years 6 months ago

So you enabled IGMP snooping. Under controller, you have multicast enabled and a multicast address too?

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (5 ratings)
George Stefanick Tue, 09/27/2011 - 17:33

Hello "Fart Box",

There are a few dependecnys for these devices to work. First all the devices MUST be on the same SUBNET. Secondly, multicast needs to be enabled.

Are both of these comments correct on your network today ?

fartbox007 Tue, 09/27/2011 - 18:06

Hello George,

Sorry for my sophomoric name. I didn't realize I had made it that.

Anyhow, yes.. the IP of the Apple TV is 192.168.200.133 and the iPhone is 192.168.200.50

I believe I have enabled Multi-cast in Controller > Multicast > Global Multicast Mode

Thank you for your help.

Benmar

Correct Answer
George Stefanick Tue, 09/27/2011 - 18:26

So you enabled IGMP snooping. Under controller, you have multicast enabled and a multicast address too?

AJCamacho Thu, 03/20/2014 - 17:15

Hi George,

My case is a little bit more complex, in the lab I could configure mDNS on my 5508 with the global multicast and igmp snooping disabled. Only I needed was Global mDNS multicast enabled (from Cisco Guide) and it worked fine under the following scenarios:

All the services connected wireless

IPAD on subnet A and Apple TV on subnet B, no Firewall in the middle. Peer to Peer Blocking in the WLC was any DROP or DISABLED and it worked fine.

BUT, when I moved into production environment, the only way that it works is by having both Apple Devices in the same subnet with the Peer to Peer bloking DISABLED. I have a firewall in the middle so I do not know what should I check in the firewall to allow Airplay to work.

There is something really weird. in the IPAD, I can see the AIRPLAY icon at the bottom of the screen, when I click on it, I can see MIRRORING and I moved it to the right to activated it BUT nothing happens on the AppleTV connected to an screen. I mean, looks like the request for MIRRORING from the IPAD to the Apple TV device is not reaching this one. A few seconds after activating MIRRORING in the IPAD looks like the request is dropped since that the mirroring is not active.

I have an open case with TAC but any ideas are welcomed.

By the way, I am running v 7.6 in the WLC in order to implement mDNS (no bonjour gateway required, intervlan traffic managed by the WLC) and also LSS.

thanks

Abraham

 

fartbox007 Wed, 09/28/2011 - 10:36

George, you are a genius sir.  Setting the multicast address to 239.0.0.0 made the Airplay icon appear immediately.

Thank you so much for your help.

Benmar aka F A R T Box

George Stefanick Tue, 12/13/2011 - 07:37

I'm glad you could find a solution. Feel free to support the rating system and rate helpful post !

Sent from Cisco Technical Support iPhone App

George Stefanick Thu, 01/19/2012 - 00:03

Have you configured your wired side for multicast ? Also all your apple devices need to be in the same subnet ..

Sent from Cisco Technical Support iPad App

b.bezjak@guggen... Thu, 01/19/2012 - 02:32

Hi George,

I've activated Multicast and IGMP Snooping in Controller->Multicast.

The Multicast Group Adress in Controller->General is 224.0.0.251

The Web-Interface on my 2106 differs in many things compared to the Howto mentioned in Vinay Sharma's Post.

Scott Fella Thu, 01/19/2012 - 03:51

It's hard to verify that you have configured everything. Can you post your config and tell us what WLAN SSID these devices are on.

Thanks,

Scott Fella

Sent from my iPhone

b.bezjak@guggen... Thu, 01/19/2012 - 05:18

Hi Scott,

maybe the mistake is, that our Computers are in 255.255.255.0 and the Multicast Group Adress is

224.0.0.251 ?

Do I have to change everything?

Scott Fella Thu, 01/19/2012 - 05:24

That shouldn't matter multicast address is going to be different from what your clients use... as long as on the siwtch side, you configure ip multicast-routing and ip pim sparse-dense-mode (or sparse or just dense) you should be fine.  Here is another link that might help you from a member.  I have it working at a couple clients now and at my lab.  I just made sure to enable global multicast on the wlc.

https://supportforums.cisco.com/message/3519224#3519224

http://www.thehelpdesk.co.nz/2012/01/how-to-use-apple-tv-with-cisco-877w.html

cohensitdept Fri, 02/03/2012 - 04:56

Hi there. I have a similar problem.

in controller, general AP Multicast mode i have set to multicast and 239.0.0.0

in controller multicast i have enabled globle multicast mode and igmp snooping

IP of Apple TV 192.168.55.151

IP of iPhone 4S 192.168.55.14

When i use Lan scan on my iPhone i can see the Apple TV but no bonjour services found.

Quick port scan shows ports 49152 and 62078 open on the apple tv.

Airplay is enabled on the Apple TV and the iPhone works on a different wireless network to a different Apple TV.

The wired network is a single nonrouter VLAN in a cisco 3750, but cant see the bonjour even if the apple TV is also wireless.

Any thouhgts? Thanks in advance.

cohensitdept Fri, 02/03/2012 - 05:28

Ah, interesting. The 3750 doesn't do any routing for this VLAN, so i haven't assigned it an IP address.

Didn't think i would have to enable multicast for it.

Is it possible to enable multicast purely on one vlan on a 3750?

The other vlans are doing routing and i don't really want multicast on them.

Thanks

Scott Fella Fri, 02/03/2012 - 05:32

Well you need to enable multicast routing on the layer 3 and then you can define the vlan interface and set that to

ip pim sparse-dense-mode or ip pim sparse-mode but then you will have to specify an RP.

cohensitdept Fri, 02/03/2012 - 05:49

Thanks. Have been following the cisco document at:-

http://www.cisco.com/en/US/products/hw/switches/ps5023/products_configuration_example09186a008076c6e0.shtml

but in my vlan (55) when i do ip pim dense-mode it errors at pim:(

Also when i do no ip multicast-routing distributed I ge the same invalid input at '^' marker message.

We have ipbase software on our 3750s so looks like we can't enable multicast routing, am i right?

Stephen Rodriguez Fri, 02/03/2012 - 05:50

piggy back Scott,

When you issue ip multicast routing it is a global command. So all. Alb would be able to route multicast traffic if you pim enable them.

Steve

Sent from Cisco Technical Support iPhone App

cohensitdept Fri, 02/03/2012 - 09:26

Just an update.

The Apple TV is plugged into a linksys switch on vlan 55, the controller is plugged into the 3750's and the access points for the controller are plugged into the 3750's via a POE switch.

Both the Access point POE switch and the controller are plugged into trunk ports with all vlans piped to them as the wireless has multiple SSID's on different VLANs.

the 3750's have an ipbase software image.

Is there any way i can get this to work?

alois.heilmaier... Mon, 02/13/2012 - 11:22

I am just on the same problem, but with WLC4400.

Apple Airplay needs multicast, so I configured following:

network multicast global enable
config network multicast mode unicast
config network multicast igmp snooping enable
config network multicast igmp timeout 60

So I should not need multicast between controller an access points because of "multicast mode unicast".

Up to now I don't know if it works.


alois.heilmaier... Wed, 02/15/2012 - 13:59

Hi, I read something about that.

So I think Apple's bonjour protocol needs multicast. You have to enable it on the controller.

On the controller you can configure multicast support in 2 ways:

1. multicast in unicast mode: multicast packets between controller and access point delivered via unicast. So in your wired infrastucture multicast is not needed. Unfortunately so I think this mode is not supported on WLC 2112. Please double check this for your own.

2. multicast in multicast mode: wired infrastucture must support multicast. Multicast packets (bonjour protocol) between controller and access point are delivered via multicast. So for multicast in multicast mode you have to configure a multicast address, a LWAPP/CAPWAPP Multicast address. That address should be a 239.x.x.x, via this infrastructure bonjour multicast packets (224.0.0.251) are delivered.

One exception, multicast over guest anchor is not supported, i any way. That's my problem in my infrastructure I mentioned in this thread.

Sent from Cisco Technical Support iPad App

cohensitdept Fri, 02/17/2012 - 05:10

Hi thanks for the reply.

I have been speaking to Cisco about this problem and it appears that we either need to enable multicast ont eh 3750's by purchasing a license upgrade and allowing the 3750's to do the routing for the 55 VLAN, or move the controller management interface and the management interfaces of the AP's intot he 55 VLAN as apraently the controller will only multicast on the VLAN that the management interface is on

The 55 VLAN is a segmented public access VLAN so we don't want to put the management interfaces on it or allow routing to the rest of the network on it, so looks like we are stuck!

So it looks like we are going to purchage some very cheap Wireless AP's for the 55 VLAN to get this working.

Shame really.

AJCamacho Tue, 03/25/2014 - 09:53

Hi Scott,

I do not know if you already have this information but I moved to production the Apple TV service using mDNS on version WLC 5508 7.6 and it did not worked because I have an ASA in the middle. So I basically had to open ports: tcp5000, tcp7000 & 7001, tcp7100, udp7010, udp7011, tcp/udp49152-65535 based on the link:  http://community.arubanetworks.com/t5/Unified-Wired-Wireless-Access/apple-macbook-airplay-appletv-firewall-port-findings/td-p/55048 and it worked.

Now I am facing another issue, the mirroring is extremely slow. I mean, when I click in the IPAD the mirroring icon, I am switched immediately to the Apple TV based on the data displayed on the screen connected to this device. But, when I select any icon in the IPAD main screen, it takes from 15-20 seconds to display the information in the Apple TV screen. Have you worked with the QoS part on the WLC for Apple TV? thanks

 

 

mali1977us Tue, 04/17/2012 - 15:54

I just want to update every one I was having a similar issue on the 5508 and I had the multicast IP setup as 239.255.255.10, once I changed it to 239.0.0.0 Air Play icon re appeared.  I'm just curious now though how come it didn't work with the (AP Multicast Mode) 239.255.255.10 IP?

However under "Controller --> Mobility Management and Multicast Messaging --> Local Group Multicast IP Address" I left 10.255.255.210.

Actions

Login or Register to take actions

This Discussion

Posted September 27, 2011 at 4:16 PM
Stats:
Replies:28 Avg. Rating:5
Views:38982 Votes:0
Shares:0

Related Content

Discussions Leaderboard