×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Trouble with Force Night and phone lines

Unanswered Question
Jan 4th, 2012
User Badges:

Hi Team


Need a quick help.

We did a UC320W setup for a customer with 6 handsets. Their is Auto attendant that is activated by a Force Night Button.


This customer has Phone line from a Carrier that are IP lines. But these lines are provisioned through an IAD (integrated Access device) and converted into PSTN grade output.

This PSTN grade output is then supplied by us to FXO in UC320W.


Problem is that each night when the client pushes the Force Night Button and next day comes to office pushes the Force Night button to re activate the system, phone lines are not working by then. Somehow the only way to bring it back to life is re booting the IAD of the phone provider.


Looks like their is some kind of signal going back in IAD from our UC320W.


Any ideas or suggestions...

Thanks


Regards

Harish Kumar

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Christopher Edg... Thu, 01/05/2012 - 06:55
User Badges:
  • Silver, 250 points or more

Hi Harish,


The Force Night function simply changes the Auto attendant menu (if provisioned) and day night call routing.  It does not do anything to the FXO trunks or hardware. 


Can you elaborate on what you mean when you say the phone lines are not working?  What happens to an inbound call?  Do you see that FXO LEDs on the front of the UC320W are off (not connected)?


Is the firmware current in the IAD?  Does the carrier do any kind of nightly maintenance on their IAD?


If you simply unplug the FXO and then plug it back in does the FXO line start working again?


Chris

group9optus Fri, 01/06/2012 - 00:21
User Badges:

Hi Chris


Thanks for your response...


Phone lines not working means the

1. When the client comes next morning and take the Night Mode OFF, their are no incoming or outgoing calls possible.

2. Then they do Power cycle with IAD and then everything goes back normal.


I don't know about the status of LED's as I was not able to go on to the site.


As for the carrier, I have sent mails to confirm about the maintenance schedules.

Looks to me that there is some complatibility issue with the UC320 and carrier IAD.


Unplug FXO does not make any difference but rebooting IAD does.

Please advice.


Regards

Harish Kumar

Christopher Edg... Fri, 01/06/2012 - 07:58
User Badges:
  • Silver, 250 points or more

Hi Harish,


If unplugging the FXO doesn't make a difference but rebooting the IAD does, this makes me think the problem is on the IAD.  Unplugging the FXO changes the port electrically, much like unplugging an ethernet cable and plugging it back in causes the port to reinitialize.


Another test you can try to isolate to the IAD is next time it happens, unplug the FXO from the UC320 and then connect an analog phone to the line to the IAD.  See if you have dialtone and can make calls using the analog phone.  If not, this says the problem is with the IAD.


Chris

group9optus Sun, 01/08/2012 - 15:44
User Badges:

Hi Chris


I went there last night. Followiing were the findings.


1. Telecom IAD has the lines OK when we have this problem.

2. LED's on FXO ports are also ON.

3. Instead of rebooting IAD, I rebooted our UC320W and everything went normal

4. I checked all the phone lines out at IAD with a standard handset and was all good.

5. Changing Night mode was a trouble all the times.


My observation is some issue with the Night mode. As soon as we push the button from Orange to Green the lines are not working.


One more very important finding is: I plugged in a standard handset at the FXS port (While the Phone system not working). This FXS port is physically short with FXO1. I could listen the Auto Attendant message geting repeated continuously. Under this situation when we called the main number it showed busy.

Is it possible that when somebody calls in the night mode, Auto attendant does not disconnects after the message played.


Please advice.

Kind Regards

Harish Kumar

Christopher Edg... Mon, 01/09/2012 - 08:09
User Badges:
  • Silver, 250 points or more

Hi Harish,


Please make sure you are running 2.1.4(3) or higher: 

https://supportforums.cisco.com/message/3507345#3507345


If there was an active call on the FXO port the FXO LEDs will blink.  When you tested with the FXS port on the UC320W did you have it provisioned in the GUI?


On the GUI, please select Services -> Feedback -> Report a Problem and put ATTENTION CHRIS EDGEWORTH  and a URL to this discussion in the text area.  Then we can take a look at your specific configuration.


Thanks,


Chris

group9optus Tue, 01/10/2012 - 17:03
User Badges:

Hi Chris


I think we had the 2.1.3, anyway I will check and upgrade when on site tomorrow..


Yes the FXS port was configured in GUI...


I will also send you the Feedback tomorrow....

Meanwhile we had an issue at another site of Call not getting disconnected while in Voicemail (with same carrier IP Lines).


SBCS huys have sent a PMF file by the name

Enable_FXO_Silence_Detection-Disconnect.pmf


We will try this tomorrow and will update you...This PMF worked with the other site (With the Voicemail issue as mentioned above).


Kind Regards


Harish Kumar

group9optus Thu, 01/12/2012 - 03:44
User Badges:

Hi Chris


Need urgent help, this is turning into disaster for us. The PMF file as I mentioned in the previous update has resulted in call drops (both incoming and outgoing) at all three sites that we did this file upload in last 2 days. This is resulting in clients frustration and our time wastage.


For this one I have asked the technician to send you the feedback.


Please help.....


Kind Regards

Harish Kumar

Christopher Edg... Thu, 01/12/2012 - 07:56
User Badges:
  • Silver, 250 points or more

Hi Harish,


As always, for immediate help, you should contact the Cisco Small Business Support center where there is assistance 7x24.


The PMF for disconnecting based upon silence is not an ideal solution.  I would suggest disabling/removing the PMF.  It is important that you upgrade to 2.1.4(3) or higher.  Apply the configuration.  Then rerun the Impedance matching on each of the FXO lines.


2.1.4(3) contains a key fix that addresses a potential configuration problem where impedance settings may have been lost.  Having correct impedance is important for the UC320W to be able to detect the CPC disconnect tone.  This allows the UC320W to know when the PSTN user had hung up the call.  Additionally, some partners have found it necessary to contact the FXO telco and asked to have the CPC disconnect duration increased.  We are looking for a minimum of 200ms of CPC.


I have not seen the feedback submission so far.


Thanks,


Chris

Christopher Edg... Thu, 01/12/2012 - 15:22
User Badges:
  • Silver, 250 points or more

Hi Harish,


I have recieved your feedback and see the system is still on 2.1.3.  Recommend the system is upgraded to 2.1.4(3) and then Impedence matching is run on each of your FXO lines.  You can find this on the FXO Lines page.


Next, unless you want the AA message to repeat up to 3 times if the user just lets the AA timeout, I would change the timeout action to either End Call or if you want a second play of the office closed message, Play prompt Then End Call.  This explicitly tells the UC to terminate the call.


Hope this helps.


Chris

group9optus Thu, 01/12/2012 - 17:13
User Badges:

HI Chris


Thanks for your quick update, Sorry I had to ask you as SBCS team was struggling to solve the issue..

We have also sent you the feedback after installing 2.1.4(3)..The problem is still there..

How do we do the impedance matching...


We will try your suggestion on AA...

Kind Regards


Harish Kumar

Christopher Edg... Fri, 01/13/2012 - 07:00
User Badges:
  • Silver, 250 points or more

Hi Harish,


Impedance matching is covered in the UC300 Troubleshooting Guide: 

https://supportforums.cisco.com/docs/DOC-16469


Essentially, go to the FXO page of the Configuration Utility and select Impedance matching button.  Select the FXO you want run the impedance matching tool on.  Enter a phone number of a landline phone that you can put on mute.  The Phone number should be in the number you would dial if you were dialing from an analog phone connected to the FXO port, that is no steering digits are used.  Start the test, answer the call on the landline phone and put the call on mute.  You will hear a series of tones on the landline.  The test takes 7-8 minutes per line.  The test should be run on each line.

When the test finishes update the recomended impedance values for the line.


Chris

Actions

This Discussion