ASR9K-ASR1K EoMPLS PW

Unanswered Question
Jan 12th, 2012

I have simple hub and spoke topology with ASR9K used as a hub and ASR1K's as spokes. ASR9K configured for l2vpn domain:

interface Loopback0

ipv4 address x.x.a.144 255.255.255.255

!

l2vpn

bridge group group_name

  bridge-domain bd441

   neighbor x.x.x.147 pw-id 441

   neighbor x.x.y.127 pw-id 441

   neighbor x.x.z.40 pw-id 441

   routed interface BVI441

!

Two of ASR1K connected works fine, but x.x.x.147 (IOS XE 3.5.0) still shows VC status down.

Here is detailed debug outputs and configuration from x.x.x.147:

mpls label range 16000 1048575

mpls ldp router-id Loopback1 force

mpls ip

interface Loopback1

ip address x.x.x.147 255.255.255.255

interface TenGigabitEthernet0/1/0.441

encapsulation dot1Q 441

xconnect x.x.a.144 441 encapsulation mpls

interface TenGigabitEthernet1/0/0.997

encapsulation dot1Q 997

ip address x.x.g.194 255.255.255.252

mpls ip

router ospf 1

router-id x.x.x.147

redistribute connected subnets

network x.x.g.192 0.0.0.3 area 0

ASR1K#show mpls l2transport vc 441 detail

Local interface: Te0/1/0.441 up, line protocol up, Eth VLAN 441 up

  Destination address: x.x.a.144, VC ID: 441, VC status: down

    Output interface: none, imposed label stack {}

    Preferred path: not configured

    Default path: no route

    No adjacency

  Create time: 00:01:54, last status change time: 00:01:54

  Signaling protocol: LDP, peer x.x.a.144:0 up

    Targeted Hello: x.x.x.147(LDP Id) -> x.x.a.144, LDP is UP

    Status TLV support (local/remote)   : enabled/supported

      LDP route watch                   : enabled

      Label/status state machine        : remote ready, LndRru

      Last local dataplane   status rcvd: No fault

      Last BFD dataplane     status rcvd: Not sent

      Last local SSS circuit status rcvd: DOWN(not-forwarding)

      Last local SSS circuit status sent: Not sent

      Last local  LDP TLV    status sent: None

      Last remote LDP TLV    status rcvd: No fault

      Last remote LDP ADJ    status rcvd: No fault

    MPLS VC labels: local unassigned, remote 16887

    PWID: 4563

    Group ID: local unknown, remote 47

    MTU: local unknown, remote 1500

    Remote interface description: Access PW

  Sequencing: receive disabled, send disabled

  Control Word: Off (configured: autosense)

  VC statistics:

    transit packet totals: receive 0, send 0

    transit byte totals:   receive 0, send 0

    transit packet drops:  receive 0, seq error 0, send 0

ASR1K(config-subif)# no xconnect x.x.a.144 441 encapsulation mpls

ASR1K(config-subif)# xconnect x.x.a.144 441 encapsulation mpls

Jan 12 14:49:25.644 EET: AToM[x.x.a.144, 441]: FSM init LndRnd

Jan 12 14:49:25.644 EET: AToM[x.x.a.144, 441]: Dataplane : No fault

Jan 12 14:49:25.644 EET: AToM[x.x.a.144, 441]: FFD       : No fault

Jan 12 14:49:25.644 EET: AToM[x.x.a.144, 441]: AC status DOWN(not-forwarding)

Jan 12 14:49:25.644 EET: AToM[x.x.a.144, 441]: Provisioned

Jan 12 14:49:25.644 EET: AToM[x.x.a.144, 441]: Evt provision, idle -> provisioned

Jan 12 14:49:25.644 EET: AToM[x.x.a.144, 441]: . Provision vc

Jan 12 14:49:25.644 EET: AToM LDP[x.x.a.144, 441]: LDP OPEN request

Jan 12 14:49:25.644 EET: AToM[x.x.a.144, 441]: . NMS: VC oper state:  DOWN

Jan 12 14:49:25.644 EET: AToM[x.x.a.144, 441]: . NMS:     err codes:    no-fwdg

Jan 12 14:49:25.644 EET: AToM[x.x.a.144, 441]: SYSLOG: VC is DOWN, PW Err

Jan 12 14:49:25.644 EET: AToM LDP[x.x.a.144, 441]: Signaling peer-id of VC changed to x.x.a.144

Jan 12 14:49:25.644 EET: AToM[x.x.a.144, 441]: Evt remote ready, provisioned -> remote ready

Jan 12 14:49:25.644 EET: AToM[x.x.a.144, 441]: . Receive remote vc label binding, instance 1

Jan 12 14:49:25.644 EET: AToM[x.x.a.144, 441]: . Adjacency : No fault

Jan 12 14:49:25.644 EET: AToM[x.x.a.144, 441]: .. S:Evt ADJ up in LndRnd

Jan 12 14:49:25.644 EET: AToM[x.x.a.144, 441]: .. S:Evt dataplane clear fault in LndRnd

Jan 12 14:49:25.644 EET: AToM[x.x.a.144, 441]: . Check if remote connected

Jan 12 14:49:25.644 EET: AToM[x.x.a.144, 441]: .. Remote label is ready

Jan 12 14:49:25.644 EET: AToM[x.x.a.144, 441]: .... S:Evt remote ready, LndRnd -> LndRrd

Jan 12 14:49:25.644 EET: AToM[x.x.a.144, 441]: .... S:Evt remote up, LndRrd -> LndRru

Jan 12 14:49:25.644 EET: AToM[x.x.a.144, 441]: .... S:Act send SSS(UP)

Jan 12 14:49:25.644 EET: AToM[x.x.a.144, 441]: .....  [no service]

Jan 12 14:49:25.644 EET: AToM[x.x.a.144, 441]: .... S:Evt ADJ up in LndRru

Jan 12 14:49:25.644 EET: AToM[x.x.a.144, 441]: .... S:Act send SSS(UP)

Jan 12 14:49:25.644 EET: AToM[x.x.a.144, 441]: .....  [no service]

Jan 12 14:49:25.644 EET: AToM[x.x.a.144, 441]: .. Yes, connected

Jan 12 14:49:25.644 EET: AToM LDP[x.x.a.144]: Hello adj created with local address 0.0.0.0

Jan 12 14:49:25.644 EET: AToM LDP[x.x.a.144]: Opening session, 1 clients

Jan 12 14:49:25.644 EET: ldp-trgtnbr: x.x.a.144 -> x.x.a.144 Req active by client, MPLS AToM Circuit

Jan 12 14:49:25.644 EET: ldp-trgtnbr: Created avl tree for vrf default

Jan 12 14:49:25.644 EET: ldp-trgtnbr: x.x.a.144 allocated

Jan 12 14:49:25.644 EET: ldp-trgtnbr: x.x.a.144 Set peer start; flags 0x10

Jan 12 14:49:25.644 EET: ldp: ldp start; tbl 0

Jan 12 14:49:25.644 EET: ldp-trgtnbr: x.x.a.144 Defer peer cleanup; cleancnt 1

Jan 12 14:49:25.644 EET: ldp-trgtnbr: x.x.a.144 Set peer finished; flags 0x1F

Jan 12 14:49:25.644 EET: ldp-trgtnbr: x.x.a.144 ref count incremented to 1

Jan 12 14:49:25.644 EET: AToM LDP[x.x.a.144]: Session is up

Jan 12 14:49:25.644 EET: AToM LDP[x.x.a.144, 441]: LDP open

Jan 12 14:49:25.644 EET: AToM LDP[x.x.a.144, 441]: Signaling peer-id of VC changed to x.x.a.144

Jan 12 14:49:25.644 EET: AToM LDP[x.x.a.144, 441]: LDP UP

Jan 12 14:49:25.644 EET: AToM[x.x.a.144, 441]: Evt ldp up in remote ready

Jan 12 14:49:25.644 EET: AToM[x.x.a.144, 441]: . Take no action

As for me VC still down becouse local SSS circuit still down.

     Last local SSS circuit status rcvd: DOWN(not-forwarding)

I try to compare two debug outputs from this one and working ASR1K and see that's in work case session continues with suc

Jan 12 14:10:59: AToM MGR [x.x.a.144, 441]: Receive SSS STATUS(UP)

Jan 12 14:10:59: AToM MGR [x.x.a.144, 441]: . AC status UP

Jan 12 14:10:59: AToM MGR [x.x.a.144, 441]: ... S:Evt local up, LndRru->LnuRru

Jan 12 14:10:59: AToM MGR [x.x.a.144, 441]: .. Event local ready, state changed from remote ready to establishing

Jan 12 14:10:59: AToM MGR [x.x.a.144, 441]: .... Alloc local binding

...

What "SSS" mean, why it has status down and how to fix it?

ASR1K#show int TenGigabitEthernet 0/1/0.441

TenGigabitEthernet0/1/0.441 is up, line protocol is up

...

Thanks for any ideas

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
rsimoni Tue, 01/17/2012 - 06:04

since nobody answered and the required level of troubleshooting is quite high I suggest you open a TAC case for this (you can do this directly from CSC)

Riccardo

vinijain Wed, 03/21/2012 - 18:48

Hello,

from the logs I see the following:

1) There is no local MTU learnt. Could you please configure a MTU value on the local interface. You may configure a service instance on the router and then assign a MTU value to that service instance. this shall help to sync up the MTU between the ASR9k and the ASR1k

2) There is no local label seen. The above may be the cause for the same.

Please check and let me know if that helps.

Regards

Vinit

Actions

Login or Register to take actions

This Discussion

Posted January 12, 2012 at 5:08 AM
Stats:
Replies:2 Avg. Rating:
Views:1694 Votes:0
Shares:0

Related Content

Discussions Leaderboard